Recording

   Print  Previous  Next
Introduction
Overview
Initial Configuration
Main Output Recording
Cue List Recording
Record Editing
SCE Video

 

 

Introduction

You can use the Recording functionality to create MADRIX Record files [of the file type *.mrec].

This file type can be used in 2 ways:

A] *.mrec files can be converted to create Stand-alone Shows for MADRIX PLEXUS.
Learn more »MADRIX PLEXUS
B] *.mrec files can be played just like a video using SCE Video [as described in this topic].
Learn more »SCE Video

 

 

Overview

There are two locations in the MADRIX Software where you can create records.

Main Output Recording
Cue List Recording

 

 

Initial Configuration

Patching

Please configure your virtual LED matrix with the help of the »Matrix Generator or »Patch Editor to define the correct resolution for your record.

 

 

Options

Before you start recording, make sure to set up your required frequency [FPS] in the Options.

Learn more »Recording

 

 

Main Output Recording

Overview

You can find the Main Output Recording directly on the main user interface.
As the name implies, you will record everything from your Main Output. This will include any crossfades, effect changes, brightness changes, etc.

 

Important Note

Only the Main Output will be recorded. Make sure that your content is displayed on Preview Output before you start to record.

 

How To Record

Left Mouse Click - Click REC in order to start the recording process.
- The context menu allows for more options. Learn more below.
The button will now pulsate in red and a new window will open to see more details.

 

 
- State - Shows the current status of the recording process [Started, Stopped].
- FPS - Shows the currently set recording frequency in Frames Per Second. Learn more »Recording
- Duration - Shows how long the record currently is in HH:MM:SS:FF [hours:minutes:seconds:frames].
- Frame Count - Shows the total number of single frames that has been recorded and created.
- Key Frame Count - Shows the total number of frames that differ from each other. The MADRIX Software will automatically optimize the file size of records if recorded frames are identical. Hence, the total number of frames can be different to the number of recorded key frames. For example, a color change [without a fade] might use only two colors. In this case, the record may have 400 frames in total, but just 2 key frames.
- Buffer Usage - Shows the status of the temporary storage.
Left Mouse Click - Click REC a second time in order to stop the recording process.
Please wait a few seconds to let the software process the data. You will be asked for the location to store the record file on your hard driver as well as a name for the file. Click Save in order to confirm.
If needed, you can edit your records after the initial recording process. Learn more below.

 

Context Menu

Right Mouse Click - Click REC in order to call up the context menu.

 
- Set Duration... - Allows you to set a specific time that the record should last.
- Watch... - Calls up the Main Output Recording window again for more details.
- Cancel - Aborts the recording process without asking you to save the file.

 

 

Cue List Recording

Overview

The Cue List Recording features are part of the Cue List .

You can open the Cue List in 3 ways:

Go to the menu Tools > Cue List...
Or press F7
Or click Layer Control > Cue List on the user interface.

 

Important Note

Make sure to create A Cue List first. Otherwise, Cue List Recording is not available to you.
All cues need to have a Duration set.
Learn more »Cue List

 

How To Record

From - Defines the cue to start with. Enter the desired value. The default value is 1.
To - Needs to be activated first. Allows to set the last cue to record to and thus create a range from cue to cue. If deactivated, the recording will automatically stop at the last cue.
Left Mouse Click - Click REC in order to start the recording process.
The button will now pulsate in red and a new window will open to see more details.

 

 
- State - Shows the current status of the recording process [Started, Stopped].
- FPS - Shows the currently set recording frequency in Frames Per Second. Learn more »Recording
- Duration - Shows how long the record currently is in HH:MM:SS:FF [hours:minutes:seconds:frames].
- Frame Count - Shows the total number of single frames that has been recorded and created.
- Key Frame Count - Shows the total number of frames that differ from each other. The MADRIX Software will automatically optimize the file size of records if recorded frames are identical. Hence, the total number of frames can be different to the number of recorded key frames. For example, a color change [without a fade] might use only two colors. In this case, the record may have 400 frames in total, but just 2 key frames.
- Buffer Usage - Shows the status of the temporary storage.
The software will automatically stop the recording process according to your settings.
Please wait a few seconds to let the software process the data. You will be asked for the location to store the record file on your hard driver as well as a name for the file. Click Save in order to confirm.
If needed, you can edit your records after the initial recording process. Learn more below.

 

Context Menu

Right Mouse Click - Click REC in order to call up the context menu.

 
- Watch... - Calls up the Cue List Recording window again for more details.
- Cancel - Aborts the recording process without asking you to save the file.

 

 

Record Editing

Overview

Go to the menu Tools > Record Editing...
[Keyboard shortcut: Ctrl+Alt+R]
A new window will open.

Recording Dialog

 

Records

This section allows you to work with your record files.

Directory

Browse For Folder

Defines a directory on your harddisk/computer. All record files will be saved in this folder. By default, a useful folder is automatically already chosen for you [For example C:\Users\USERNAME\Documents\MADRIX\records].
Use ... to choose a different folder.

Filter

Simply enter a name/word and the filter will only show files that include these characters in their file name. Delete any input to show all files again.

List

Files, i.e. records, will be displayed in the large list of the Recording window. If you did not create any records yet, the list is empty [as shown above].

Show *.mrec Files

Shows all MADRIX Record files [of the file type *.mrec] in the list that could be found in the specified directory. When activated, the button is green. Disable the option to hide all Record files.

Show *.dxd Files

Show all DMX Data files [of the file type *.dxd] in the list that could be found in the specified directory. When activated, the button is green. Disable the option to hide all DMX Data files.

Refresh List

Refreshes the list of records. Please make sure to select your preferred records directory first.

File

Shows the name of the record and its file type [of the file type *.mrec or *.dxd]. Double-click on the list entry to change the name of the file.

Date - Time

Shows the time and date when the record was created.

Matrix Size

Shows the size of the virtual matrix [Matrix Size] used for this record. Learn more »Patch Editor

Duration

Shows the length of the record, i.e. how long it is. The format is HH:MM:SS:FF [Hours:Minutes:Seconds:Frames].

KF

Stands for Key Frames. MADRIX will automatically optimize the file size of records if recorded frames are identical. Hence, the total number of frames can be different to the number of recorded key frames. For example, a color change [without a fade] might use only two colors. In this case, the record may have 400 frames in total, but just 2 key frames.

FPS

Stands for Frames Per Second. Shows the number of frames recorded per second of the record file.

Delete

Deletes selected files from your harddisk. You can also use the Del key on your keyboard.

 

File Information

Select a file in the list.
Go to the tab File Information to show detailed information about the record file you have created.

File Information

 

Record Editing

After creating a record, you can edit the record.

Select your Record file in the list.
Select the tab Record Editing

Edit Record
 

A small preview window is provided in the lower left to inspect the record.
Please note: If you see the message !NO MADRIX 5 KEY! in the preview window and a rotating cross, that means that you are using MADRIX in demo mode. However, this is no problem. Your record will NOT include this text!
 
Use the provided controls to edit your record:
 

Slider

Use the slider to select a specific frame.
Use the small, white triangles to manually set up the In Frame [start frame] and the Out Frame [end frame] for the record.

Frames

This field displays the current frame that is also shown in the small preview window. Enter a number to jump directly to this frame.

Play Pause

Start or stop the preview playback.

Forward/Rewind

Rewind or forward one frame per click.

Skip

Skip directly to the In Frame or the Out Frame.

Skip

Skip to the beginning or the end of the record.

Start Frame

Enter a number or use the slider to select a specific frame. Then, use the S button to set the In Frame [start frame].

End Frame

Enter a number or use the slider to select a specific frame. Then, use the S button to set the Out Frame [end frame].

Find Loop

MADRIX will search the Record File in order to find a segment that is loopable. It will automatically set the In Frame and Out Frame afterwards. Use the button Export to export your loop. Before that, you can also insert Blend Frames.

Blending

Insert Blend Frames into your record if you want to.
- First, enter the number of frames you wish to use. This defines the length.
- Second, choose the fade mode [XF: Cross-Fade, WF: White-Fade, BF: Black-Fade, Learn more »Crossfader And Main Output].
- Third, click Blend.
- Fourth, use Play/Pause to preview the edited record.
- Fifth, use the button Export to export your loop.
Note: The beginning of your record will be cut by the defined frame number. This is indicated by a red line below the slider.
Example: If you enter 100 frames, MADRIX will create the fade using the first 100 frames and the last 100 frames. Those frames will blend into each other. To have a smooth fade, the record is then cut by 100 frames and starts at frame 101.

Export

Use this button to export the edited record. Choose a name in the second step.

 

PLEXUS Conversion

Use this tab to convert MADRIX Record files [of the file type *.mrec] into DMX Data files [of the file type *.dxd].
A MADRIX KEY with a valid MADRIX 5 License is required in order to use this feature!
Learn more »MADRIX PLEXUS

PLEXUS Conversion

 

 

SCE Video

Follow these steps to play back a record file in SCE Video:
 

1] Select the effect SCE Video.
 
Selection

 

2] The controls of the SCE Video effect become available as a result.
 
SCE Video

 

3] Load your MADRIX Record file [of the file type *.mrec].
Open Video FileUse Open and select the file you wish to play.

 

4] The SCE Video effect will play your Record File.
 
*.mrec Playback

 

 

Recording

Overview

Go to the tab Recording to create a new record.

Start Recording

Step 1]

Click Start to start recording. MADRIX will begin to record the Main Output.

Note:
- When recording without a Cue List, you can change Storage Places, use the crossfader, change the Opacity, use the Master, etc. in order to customize your record.
- When creating a Record file to be played via SCE Video, SCE Video will ignore intensity changes by the Master. However, a Blackout will be recorded and played back as such by SCE Video.

Recording Process

Step 2]

Various information will be displayed during recording.
Duration - Is displayed in HH:MM:SS:FF [Hours:Minutes:Seconds:Frames].
Frames - Displays the total number of recorded frames.
Key Frames - Displays the number of key frames. MADRIX will automatically optimize the file size of records if recorded frames are identical. Hence, the total number of frames can be different to the number of recorded key frames. For example, a color change [without a fade] might use only two colors. In this case, the record may have 400 frames in total, but just 2 key frames.

 

MADRIX 5.0d
[Ctrl & +/-] = Zoom In/Out | [Ctrl & 0] = 100%
Print   Previous   Next


Enable automatic translation | Activer la traduction automatique | 启用自动翻译