Layers

   Print  Previous  Next
Introduction
Layer Tabs
Context Menu
Layer Settings
Layer View

 

 

Introduction

Layers Example
 

MADRIX Effects and Layers are closely related.
Layers can be used to combine visuals and to create completely new effects.
 
By default, only 1 Layer is created and shown.
You can choose to use only 1 Layer at a time or multiple Layers. Using multiple Layers can alter the displayed visuals immensely.
MADRIX supports an unlimited number of Layers.
[The actual number of Layers available for use depends on your computer performance and Matrix Size.]

 

This chapter describes ways to work with Layers in particular.
- A general overview about the controls for Layers and MADRIX Effects is provided in a previous chapter. Learn more »Effect Areas [Left/Right]

 

 

Layer Tabs

Every Layer is represented by a Layer Tab.

Layer Order
< > - Changes the order of Layers.
- When changing the order, you change the visual outcome of your effect.
- Click < to move the Layer to the left.
- Click > to move the Layer to the right.

Layer Name - You can change the Layer's label.
Right Mouse Click > Rename or Double-Click on Layer Tab - Allows you to rename the description label of the Layer tab. Simply enter a new name and click OK

 

 

Context Menu

A context menu offers various options when working with Layers.

You can access the Layer context menu in 3 ways:

Click Layer
Or Right Mouse Click on a Layer Tab
Or go to Edit > Layer Left / Layer Right

 

Layer Context Menu

 

Layer Left/Right > New - Creates a new Layer.
Layer Left/Right > Duplicate - Creates a exact copy of the currently selected Layer.
 
Layer Left/Right > Copy - Copies the Layer into the clipboard of the computer.
Layer Left/Right > Paste - Applies all settings of the Layer in the clipboard to the currently selected Layer.
Layer Left/Right > Insert - Creates a new Layer and applies all settings of the Layer in the clipboard to the currently selected Layer.
 
Layer Left/Right > Rename - Allows you to change the label of the Layer.
 
Layer Left/Right > Remove - Removes the currently selected Layer entirely.

 

 

Layer Settings

Overview

Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer:

Opacity
Blind And Solo
Submaster
Map Settings
Mix Modes
Link
Filters [FX]
Stepped Rendering
Effect Parameter Chaser
Layer Macro

 

Opacity

Layer Opacity

Layer Opacity - Makes the Layer transparent. This is mainly useful when using at least 2 Layers or more.
- If you are using only 1 Layer, the submaster controls the Layer brightness.
- The default value is 255 [100%].
- Perform a right-click to reset to 255 [100%].
 
Input Field - Allows you to directly enter a value. Valid values range from 0 to 255.

 

Blind And Solo

Blind Mode and Solo Mode are 2 modes to quickly hide or show Layers. You can quickly include or exclude them from the visual end result of your effect.

Blind Button

Pulsating Layer in Blind Mode

Blind - Hides the currently selected Layer.
- The Layer will not be visible anymore in the Previews and Output, but you will still be able to adjust its settings. In this way, you may have a look at your created effect excluding certain Layers.
- Blind Mode will stay activated even if you switch to other Layers or Storage Places.
- The Layer tab will pulsate in red if Blind Mode is active.
- Blind Mode also affects Link Mode. A Layer with an activated Link Mode will also be set to Blind Mode if Blind Mode is activated for the Layer it is linked to.

Solo button

Pulsating Layer in Solo Mode

Solo - Hides every Layer except the currently selected Layer. Hence, this Layer is the only one that will be displayed.
- Solo Mode will stay activated even if you switch to other Layers or Storage Places.
- The Layer tab will pulsate in green if Solo Mode is active.
- Solo Mode overrides Blind Mode.

 

Submaster

Submaster Button

 

Submaster

Submaster - Regulates the intensity of an effect.

Click SUB and the button extends into a fader.
Make sure to click and continue to hold the mouse button at the same time.
Afterwards, simply move the fader with the help of your mouse.
Release the mouse button to set up the specific value [The fader will disappear automatically].
A value of 255 means full intensity.
A value of 0 means no intensity and will render the effect completely black.
The tooltip shows the currently set value.

The Submaster allows you to solely adjust the intensity of the running effect or Layer. To adjust the intensity of all running effects you have to use the Master. Learn more »Master / Audio Input Level

 

Map Settings

Modifying the Map Setting allows to freely resize, reposition, and further modify every MADRIX Effect.
Learn more »Mapping / Tiling / Rotation

 

Mix Modes

Overview

Just like an image-editing software, you can use different Mix Modes to mix Layers with each other. This results in diverse color combinations and often completely new effects. These can also be referred to as blend modes.

 

How Mix Modes Work

Mix Modes are based on basic mathematical calculations.
As such, Mix Modes combine the color values [tonal values] of 2 Layers in different ways. A foreground Layer and a background Layer are used.
All Mix Modes, except for Mask, work pixel by pixel and color channel by color channel.
- Each single pixel of the foreground Layer is combined with the corresponding pixel of the background Layer.
- Each color channel of a single pixel is combined with the equivalent color channel of the corresponding pixel.

 

Applying A Mix Mode

You can use Mix Modes if you have at least 2 Layers [foreground and background]. Then, you can apply the Mix Mode to the second Layer.
In MADRIX, the second Layer is positioned to the right. It is the foreground Layer. In MADRIX, the last Layer is on top.
If you apply the Mix Mode to the first Layer, nothing will happen.
You can decrease [or increase] the impact that each Layer has on the visual result by using the Opacity slider.
In the example below, Mix Mode XOR is selected.
 

How To Use A Mix Mode
 

By default, Normal is selected.
Right Mouse Click - Resets the filter to its default value [Normal].

SCE Color Effect Example

 

List Of Mix Modes

Mix Modes

Normal - Is the default setting.
If you do not wish to use a Mix Mode or if you want to deactivate a selected Mix Mode, choose Normal.

 
Normal is also a Mix Mode and the default way of how Layers are mixed together. Since it is the default Mix Mode, you can only use the Opacity Slider to change the visual outcome. If you set Opacity of Layer 2 to 50%, you will create a result like a cross-fade between the two Layers.
If you change the position of one Layer with the position of the other Layer, the result will not look the same.

Darken - Compares both Layers and only uses the darkest color value for each color channel per pixel [this will be the lower color value].

The result will look the same if you change the position of one Layer with the position of the other Layer.

Multiply - Multiplies the color values of each pixel of Layer 2 with the color values of each pixel of Layer 1.
[Values are converted to always ensure a maximum color value of 255].

The Color Filter of the Main Output works like this.

The result will look the same if you change the position of one Layer with the position of the other Layer.

Color Burn - Is the inversion of Color Dodge.
Layer 1 will be darkened by Layer 2. The darker Layer 2, the darker the result.

If you change the position of one Layer with the position of the other Layer, the result will not look the same.

Linear Burn - Is subtractive color mixing.
The color values of both Layers will be added up. But when the result is lower than 255, the values will be set to 0 [black].

The result will look the same if you change the position of one Layer with the position of the other Layer.

Lighten (HTP) - Is the inversion of Darken.
It compares both Layers and only uses the brightest color value for each color channel per pixel [this will be the higher color value].

Is at the same time the Mix Mode HTP, applying the Highest Takes Precedence principle for DMX values.

The result will look the same if you change the position of one Layer with the position of the other Layer.

Screen - Is the inversion of Multiply.
Layer 2 and Layer 1 will be negatively multiplied and often brighten each other.

The result will look the same if you change the position of one Layer with the position of the other Layer.

Color Dodge - The brighter Layer 2, the brighter will be Layer 1.
A completely black Layer 2 will not change Layer 1.
A completely white Layer 2 will brighten every color channel, except for black color values.

If you change the position of one Layer with the position of the other Layer, the result will not look the same.

Linear Dodge - Will simply add up the color values of both Layers.

The result will look the same if you change the position of one Layer with the position of the other Layer.

Overlay - Is a combination of Multiply and Screen.
The result depends the intensity of Layer 1. If Layer 1 is darker than 50% Gray, the color values of both Layers will be multiplied. If Layer 1 is brighter than 50% Gray, the color values will be negatively multiplied and the amount will be doubled. A Layer 2 with 50% Gray will have no affect on Layer 1.

If you change the position of one Layer with the position of the other Layer, the result will not look the same.

Soft Light - Layer 2 will modulate the color values of Layer 1 and create soft mixtures in areas of highlights and shadows.
[Overlay is quite similar, but creates sharp contrasts instead.]

If you change the position of one Layer with the position of the other Layer, the result will not look the same.

Hard Light - Creates the result of Overlay, when changing the position of Layer 2 with the position of Layer 1.
It compares the intensity of both Layers.
If Layer 2 is brighter than 50% Gray, Layer 1 will be brightened.
If Layer 2 is darker than 50% Gray, Layer 1 will be darkened.

If you change the position of one Layer with the position of the other Layer, the result will not look the same.

Vivid Light - Will mainly increase the contrast of highlights and shadows.
The result is like a combination of Color Burn for shadows and Color Dodge for highlights.

If you change the position of one Layer with the position of the other Layer, the result will not look the same.

Linear Light - Increases the contrast.
It is similar to Linear Burn, but color values of Layer 2 have greater affect.

If you change the position of one Layer with the position of the other Layer, the result will not look the same.

Pin Light - Is like a combination of Darken and Lighten.
It compares the color values of both Layers and creates one of three results. Average color values will often remain unaffected.
The result can be twice the brightness of Layer 2 darkened by a full 255 if Layer 1 is darker than that.
The result can also only be Layer 1 if Layer 1 is brighter than the first result and darker than the third result.

Or the result can be twice the brightness of Layer 2 if Layer 1 is brighter than that.

If you change the position of one Layer with the position of the other Layer, the result will not look the same.

Hard Mix - Only uses the six primary colors red, green, blue, yellow, cyan, magenta, or black, or white.
Color channels will be mixed and either be set to 0 or 255. [255 will be set for every color channel result from 1 to 254. 0 will be set, when the color channel result is 0.]

The result will look the same if you change the position of one Layer with the position of the other Layer.

Difference - Will calculate the difference between color values for each pixel.
[If the result is negative, it will be multiplied by -1 to always have positive color values.]
Differences in color values will be easily visible for each pixel. If both pixels are identical, the difference will be 0 and thus black could be the maximum result for a pixel.

The result will look the same if you change the position of one Layer with the position of the other Layer.

Exclusion - Bright color areas will invert the color values of the corresponding area of the other Layer.
White areas will completely invert the color.
Very dark areas [black] will change nothing on the other Layer.
Average gray values will heavily change the contrast, up to a complete gray.

The result will look the same if you change the position of one Layer with the position of the other Layer.

AND - Is a logical operator.
Color values are converted into 8-bit binary form and thus an eight-digit value [using either 0 or 1 for each digit] will be created. Values will be compared pixel by pixel, channel by channel, bit by bit, with a result of either 0 or 1.
AND will only result in 1, when both bits have a value of 1.

It is recommended to only use Layers with solid colors, because otherwise color transitions will create artifacts.

The result will look the same if you change the position of one Layer with the position of the other Layer.

OR - Is a logical operator.
Color values are converted into 8-bit binary form and thus an eight-digit value [using either 0 or 1 for each digit] will be created. Values will be compared pixel by pixel, channel by channel, bit by bit, with a result of either 0 or 1.
OR will always result in 1, except when both bits have a value of 0.

It is recommended to only use Layers with solid colors, because otherwise color transitions will create artifacts.

The result will look the same if you change the position of one Layer with the position of the other Layer.

XOR - Is a logical operator.
Color values are converted into 8-bit binary form and thus an eight-digit value [using either 0 or 1 for each digit] will be created. Values will be compared pixel by pixel, channel by channel, bit by bit, with a result of either 0 or 1.
XOR will result in 1, when both bits are not identical.

It is recommended to only use Layers with solid colors, because otherwise color transitions will create artifacts.

The result will look the same if you change the position of one Layer with the position of the other Layer.

NAND - Is a logical operator. It is the inversion of AND.
Color values are converted into 8-bit binary form and thus an eight-digit value [using either 0 or 1 for each digit] will be created. Values will be compared pixel by pixel, channel by channel, bit by bit, with a result of either 0 or 1.
NAND will always result in 1, except when both bits have a value of 1.

It is recommended to only use Layers with solid colors, because otherwise color transitions will create artifacts.

The result will look the same if you change the position of one Layer with the position of the other Layer.

NOR - Is a logical operator. It is the inversion of OR.
Color values are converted into 8-bit binary form and thus an eight-digit value [using either 0 or 1 for each digit] will be created. Values will be compared pixel by pixel, channel by channel, bit by bit, with a result of either 0 or 1.
NOR will only result in 1, when both bits have a value of 0.

It is recommended to only use Layers with solid colors, because otherwise color transitions will create artifacts.

The result will look the same if you change the position of one Layer with the position of the other Layer.

Mask - Uses the alpha channel of Layers.
It will merge the Layers together. The result will only be visible on areas where the two Layers overlap. The rest will be set to black.

The result will look the same if you change the position of one Layer with the position of the other Layer.

 

Link

Overview

Link Button

Link - Combines 2 Layers with each other.
If you activate Link mode, the currently selected Layer will be linked to the Layer underneath. It means that it will be linked to the Layer left to it.

 

Example 1

1] Select a Storage Place and create 2 Layers . Choose SCE Ticker / Scrolling Text for Layer 1. Choose SCE Plasma for Layer 2.
 

adsda

adsda

 

2] As a first result, you will see the following image in the Previews. Because of the standard settings, the Layer order, and the 2 Layers, only SCE Plasma is visible.
 

Without Link Mode 

Without Link Mode

3] Activate Link Mode. The button glows green.
 
Link Mode Example 3

 

4] As a result, both Layers will be merged and the preview looks completely different. The text will be filled with the Plasma effect and in this way, both Layers are used to create a new effect.
 

With Link Mode

With Link Mode

 

Example 2

You could describe Link Mode differently.
As previously described, effects may be build out of several Layers. Each Layer can contain a different MADRIX Effect.
All Layers of that effect will be used to render the visual outcome. When rendering the visuals, Mix Modes, Opacity, position of Layers, etc. will all be included in the render process.
Because of this, Link Mode can also be very useful when using more than two Layers.
Use Link Mode and MADRIX will handle two linked Layers like one Layer in the render process.

 

1] Select a Storage Place and create 3 Layers. Choose SCE Metaballs for Layer 1. Choose SCE Ticker / Scrolling Text for Layer 2. Choose SCE Plasma for Layer 3 and activate Link Mode for Layer 3.
 
Link Mode Example 6

 

2] As a result, you can see that the Plasma effect of Layer 3 is only visible on the text of Layer 2. The Metaballs effect [Layer 1] has not been affected at all.

 
Link Mode Example 7

 

3] If we now add a fourth Layer [SCE Gradient at Layer position 2] and activate Link Mode for this Layer, we will see that the text looks still the same. But the Metaballs effect [Layer 1] now has the colors of the Color Gradient.
 
Link Mode Example 8

 
Link Mode Example 9

 

Filters [FX]

Filters - Special filters can be applied to Layers in order to quickly change your visuals. Learn more »Filters [FX]

 

Stepped Rendering

Stepped Rendering - Is only available for specific MADRIX Effects. It only applies to any movement of the input, i.e. when a Direction other than Stop is activated. Instead of creating a smooth transition for the movement from one voxel to the next voxel [sub-pixel rendering], MADRIX will move the input from voxel to voxel and from step to step without this transition. This might create a rougher overall movement, but it can produce a visually better outcome on the LEDs in certain cases [such as slow movement of large text].

 

Effect Parameter Chaser

Effect Parameter Chaser - Controls the Effect Parameter Chaser to add playlist functionality to the Layer. Learn more »Chaser

 

Layer Macro

Macro Button

Effect Macro Editor - Controls the Effect Macro Editor to add scripting functionality to the Layer. Learn more »Macros And Scripts

 
 

Layer View

Overview

You can switch between 2 views.

By default, the regular Effect Area is shown.
Learn more »Effect Areas [Left/Right]
 

Layer View

Layer View - Activates the second view available for Layers.
- The user interfaces changes as shown below [4 Layers are currently active in this example].
 

Solo And Blind

Solo - Activates Solo Mode for the corresponding Layer.
Blind - Activates Blind Mode for the corresponding Layer.

 

Faders

Each fader regulates the Opacity of a single Layer.
- You can set the fader to a specific position.
- You can enter a value in the input field.
- You can flash the fader.

 

Mouse Control And Keyboard Shortcuts

Single Selection
- A single fader regulates the Opacity of the corresponding Layer.
- Left Arrow / Right Arrow - Quickly switch between faders by using the left or right arrow key.
Multiselection
- Use Ctrl + Left Mouse Click to select multiple faders at the same time. A green outline will show that a Layer is selected. When multiple faders are selected, you can control them at the same time.
- Use Shift + Left Mouse Click to select multiple faders at the same time. A green outline will show that a Layer is selected. When multiple faders are selected, you can control them at the same time.
- Ctrl+A - Selects all faders of all Layers.
- Ctrl+D - Deselects the current fader selection.
Flash
- Use the button showing the Layer's Name or the keyboard shortcut Space
- It instantly sets the intensity to 255 as long as you hold the button/key down.
- To use this feature, the fader needs to be set to a lower value than 255 first.
Restoring The Default Value
- Left Mouse Double-Click - Perform a double-click with your left mouse button directly on a single or multiple faders to restore the Default Value
- Right Mouse Click - Perform a click with your right mouse button directly on a single or multiple faders to restore the Default Value

 

MADRIX 3.6f
[Ctrl & +/-] = Zoom In/Out | [Ctrl & 0] = 100%
Print   Previous   Next