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1 Configuration

1.1 Installation Of The MADRIX Software

This tutorial shows you how you can install the MADRIX software.

Date: 10/2014

MADRIX Version: 3.3 RC (Created with)

System Requirements:  Please  make  sure  that  our  PC  is  meets  the  system  requirements.  You  can  find  the

requirements »here

Attention: Do not plug any MADRIX hardware into your computer before you install the MADRIX software!

1. Download the MADRIX  software  from  »www.madrix.com  or  insert  the  MADRIX  CD into  the  CD-ROM  drive  of

your operational computer. 

2. If  you  use  a  MADRIX  CD,  the  setup  will  start  automatically.  Otherwise,  go  the  directory  where  MADRIX  is

located and double-click on MADRIX_FULL_INSTALL.exe

3. The Select Language dialog of the Installer will be opened. At this dialog you can choose the language during

installation process between English and Chinese.

4. A Welcome window appears. Click Next > and the License Agreement window appears. Click  I Agree after

reading. Otherwise, you cannot install MADRIX.

http://help.madrix.com/m3/html/madrix/index.html?hidd_system_requirements.html
http://www.madrix.com/
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5. Now, you can see the Choose Components window.

In this step, you can choose the components you want to install:

 MADRIX: It is always required to install MADRIX.

MADRIX Interface  Driver It is also always required to install the MADRIX Interface Driver.  It  includes  the

drivers for MADRIX USBone, MADRIX NEO, MADRIX PLEXUS and MADRIX LUNA interfaces.

Desktop shortcut: Create a shortcut to the MADRIX software on the Windows Desktop.

Quick launch shortcut: Creates a shortcut to the MADRIX software in the Windows toolbar.

Examples: Installs some Setup examples, including effects, scripts, and color tables for MADRIX.

MADRIX KEY  Driver:  Installs the driver for the MADRIX KEY. You will need this option  if  you  use  MADRIX

KEY start, KEY dvi start, KEY basic, KEY dvi, KEY professional, or KEY ultimate. You don't need this if you use

the MADRIX software with MADRIX PLEXUS or MADRIX NEO interfaces.
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Interface  Driver: Choose this option if want use MADRIX software with various DMX  interfaces.  You  don't

need this option if you want to use the MADRIX software only with MADRIX  interfaces  or  you  use  MADRIX

only with DVI output. 

Visualizer Driver: Is necessary if you want use the WYSIWYG Visualizer together with MADRIX.

WinPcap  Driver:  Choose  this  option  if  you  want  to  control  the  EuroLite  T9  (e.g.,  LSD  screens)  or

CoulorSmart Link.  

6. Now, you can choose the install location.

Click Browse and select your desired destination folder.  After  that,  click  Install and  the  installation  process

begins. This will take some minutes. When the installation is complete, click Next >
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7. Completing the MADRIX Setup:

6.1  If  you  want  to  use  MADRIX  without  any  hardware  (DMX  interfaces  or  MADRIX  Key):  Check  Run

MADRIX and click Finish to quit the setup and MADRIX will be started.

6.2 If you want  to  use  MADRIX  with  any hardware:  Uncheck  Run  MADRIX,  then  click  Finish to  quit  the

setup. Now, plug your hardware into your PC and wait until Windows finishes the hardware identification

and driver installation. 

Klick Search automatically for updated driver software to install the drivers for the DMX interfaces. 

8. Start MADRIX.

Congratulations! You have successfully installed MADRIX.
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1.2 Where You Can Find Connected Hardware

This tutorial shows you how you can find all connected  interfaces  in  the  MADRIX  software.  Furthermore,  there  are

instructions about what you have to do if MADRIX doesn't detect all connected interfaces.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

Requirements: For this tutorial it is necessary to install the MADRIX software as described in the previous tutorial (»

Installation Of The MADRIX Software).

1

.

Start MADRIX.
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2

.

Now,  there  are  two  different  ways  to  find  the  interfaces  and  MADRIX  KEY(s).  The  first  way  describes  the

procedure if you only use MADRIX hardware. The second way describes the procedure if are using various 3rd-

party interfaces.
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2.

1

If you use only MADRIX hardware, it is very easy to check. Go to Help > About

You can see which MADRIX KEYs and/or interfaces are identified. Every device has its own row/entry in the

table.
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Click OK
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2.

2

If you use various 3rd-party interfaces, go to Preferences > Device  Manager > DMX Devices or press

F4 > DMX Devices. Now, you see the connected devices.

If there is no device displayed,
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go  to  Preferences  >  Options  >  Devices  USB  or  press  Crtl+Alt+O  >  Devices  USB  and  select  your

interface in use. Click OK

Now, go back to the Device Manager > DMX Devices (press F4) and click the Search button.
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You should see the connected devices in the list now.
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3

.

This step is only necessary if you don't see all your plugged-in devices in MADRIX as described in step 2.

Close MADRIX. Go to Windows > Start > Control Panel > System > Device  Manager and see if there is any

device where no driver is installed. You can see it with the help of the yellow question mark in front of the device

name. 

Select this device, press the  right mouse button, and select Install driver. After the driver installation go back

to step 2 and try again.

Congratulations! You have found all detected interfaces in MADRIX.
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1.3 Changing The DMX Universe Of A Connected Interface

In this tutorial, you will learn how you can change the assigned DMX universe of a connected DMX interface.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

Note: In this example, 2 MADRIX PLEXUS will be used as the DMX interfaces. 

1. Start MADRIX and open the Device Manager (Press F4 or go to Preferences > Device Manager).



[Part A] Configuration

//19www.madrix.com

MADRIX 3 Tutorials Version 1.9

2. Now,  the  Device  Manager  will  be  opened  and  you  can  see  that  MADRIX  has  found  4  DMX  universes.  But

universes 1 and 2 are assigned twice. 
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3. We would like to use 4 single DMX universes. In this example, we  are  going  to  change  the  universes  of  the

second MADRIX PLEXUS unit to 3 and 4. 

To do this, select the third row and change Universe to 3 in the Settings panel. 

Click A pply and the settings will be confirmed for this device.
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You can see the change in the column Universe in the list now.

4. In addition, we have to change the assigned DMX universe of the fourth row. Please select the fourth row and

change Universe to 4. Afterwards, click A pply and you can see the change in the list. 
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Congratulations!  You  have  learned  how  you  can  change  the  assigned  DMX  universe  of  connected  hardware

interfaces. 
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1.4 The First Patch

In this tutorial, we want to show you how fast and easily you can create your first patch. It is important for this tutorial

that all fixtures are of the same type.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

We want to patch 8 pieces of the Ehrgeiz FS-60 RGB/1 (Mode 7). 2 units should be placed in the X-direction and 4

units in the Y-direction. This mode of the fixture uses 60 DMX channels per fixture. That means that we need 480 DMX

channels for the whole patch (8 fixtures x 60 channels). A DMX universe includes 512 channels and we only need 480

channels. That means one DMX universe is enough for this patch. For more information about DMX512, have a look at

the »What Is DMX tutorial.
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1. Start  MADRIX  and  go  to  Preferences  >  Matrix  Generator  or  press  the  F2  key  on  your  keyboard.  The

following window appears:
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2. Change the following settings:

Protocol: Should be DMX. If not, change it to DMX because we want to add DMX fixtures.

Fixture: Click on the down arrow on the right side and search for Ehrgeiz fixtures. You can press the E key

and the drop down menu automatically jumps to the fixture manufacturers begin with an E. If you have found

the Ehrgeiz fixtures, click Ehrgeiz FS-60 RGB/1 60 Ch (Mode 7). The drop down menu will be closed and

you can see that Ehrgeiz FS-60 RGB/1 is selected.

Rotation: Select Original

Count: We want to have 2 fixtures in X-direction, 4 in Y-direction, and 1 in Z-direction. Enter 2 for Count X,

4 for Count Y, and 1 for Count Z.

Note: We have now created a 2D Patch. If you want a 3D Patch, change Count Z to higher than 1.

Offset: Here you can create space between fixtures. But in this example we won't have space. Therefore set

 Offset X to 0, Offset Y to 0 and Offset Z to 0.

Start  Corner: It  is  the  position  where  the  fixture  with  the  DMX  start  channel  is  located.  In  this  example

change it to Top Right. That means that the first fixture is at the top on the right side. The second fixture is

also at the top but on the left hand side of the first device. The Start Corner can be understood as a camera

view from you onto the fixtures.

Main Orientation: Change it to Horizontal. Here you can change the orientation of the fixtures' adresses. If

it is set to Vertical, the second fixture is the one under or over (it depends on the Start Corner) the first. If it

is set to Horizontal, the second fixture is next to the first fixture.

Snake Mode: Please activate it. The check box will be illuminated green. That means that the DMX address

of the first fixture in the second row is located under the fixture  with  the  last  DMX  address  of  line  one.  If

Snake Mode is disabled, the DMX  address  of  the  first  fixture  in  line  two  is  patched  under  the  fixture  that

contains the first DMX address.

DMX Start Channel: You will need to set the start channel of your first device. In this tutorial, change it to

13. (Now, we have freed up 12 on the DMX universe and we could use those to easily control a strobe or a

fog machine with the DMX Fader Tool in MADRIX. You can learn how that works in another tutorial called »

The DMX Fader Tool
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Your Matrix Generator should now look like this:

3. Click OK

Congratulations! You have now patched these fixtures as shown below.
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1.5 Creating A Patch With Different Fixtures

In this tutorial, you will learn how to create a patch with 3 different fixtures. 

Date: 09/2014

MADRIX Version: 3.3 (Created with)

We will use several #G-Lec Phantom 60 DVI screens, several Elation LED 60 Tri Strip fixtures, and several Martin

Stage Bar 2.

1. Start MADRIX. Go to Preferences > Patch Editor or press F3. Now the Patch Editor appears: 
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2. Click New on the toolbar, go to File > New, or press Ctrl+N

Click Yes to confirm that all fixtures should be deleted.

Now you will get a new, empty patch.
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3. Click Matrix Size on the toolbar and enter Sixe X: 100, Size Y: 100, and Size Z: 1. Now there is enough space

for all the devices we want to add.
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4. Click Add and let us add the first 4 Elation Professional Design LED 60 Tri Strip fixtures in  horizontal  position

starting from X: 2, Y: 1, and Z: 1

Set up the following settings in the Add Fixtures window:

Protocol: Should be DMX. If it is not, change it to DMX.

Fixture: Click on the arrow on the right side and search the list for Elation Professional Design LED  60 Tri

Strip 60 ch mode. Select it.

Rotation: Should be Original. If it is not, change it to Original.

Count: X = 4, Y = 1, and Z = 1

Offset: X = 0, Y = 0, and Z = 0

Start Position: X = 2, Y = 1,  and Z = 1

Start Corner, Main Orientation, and Snake Mode: Leave the default settings. These options are explained

in a previous tutorial (»The First Patch).

DMX Start Channel: Should be 1. If it is not, change it to 1.

DMX Start Universe: Should also be 1. If it is not, change it to 1.
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Now click Add 
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5. Click Add  on  the  toolbar  again.  Now  we  want  to  add  20  #G-Lec Phantom  DVI Phantom  60  Frame  DVI

fixtures. The dimensions will be 5 rows with 4 columns.

Protocol: Change it to DVI

Fixture: Search for #G-Lec Phantom DVI Phantom 60 Frame (16x16) and select it.

Count: X = 5, Y = 4, and Z = 1

Merge Fixtures: Please enable it. The checkbox will be illuminated in green.

Start Position: We want to add the screens directly below the Tri strips. Set X to 2, Y to 2, and Z to 1
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6. In addition, we want to add another 4 fixtures. But this time they should be positioned below the DVI screen.

Click  Auto  Address  on  the  toolbar.  The  button  should  be  Elation  Professional  Design  LED  60  Tri  Strip

illuminated in green. 

Now select all  Elation Professional Design LED  60 Tri Strip fixtures in the Patch  (Press  and  hold  down the

Ctrl key and click on every single fixture one after another). Afterwards, hold down the Ctrl key again, click on

one of the Elation fixtures, and drag it to the desired position. In our example, the left corner of the left fixture

should be at position X = 2 and Y = 66. The advantage of this method is that you do not need calculate the

DMX addresses. MADRIX does it automatically for you.

Now the patch should look like shown in the following picture. 
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7. In this step, we want  to  add  22  of  Martin  Stage  Bar 2;  positioned  to  the  left  side  of  the  DVI screen.  The

fixtures will be rotated by 90°.

Click Add on the toolbar and configure up the following settings:

Protocol: Should be DMX.

Fixture: Search and choose Martin Stagebar 2 15 Ch (RGBW Mode, 3 Pixel). 

(For  a  faster  search,  press  M  on  your  keyboard  in  the  drop  down  menu  and  it  will  jump  to  the  fixture

manufacturers beginning with M.)

Rotation: Change it to 90° and the fixtures will be added to the patch with an applied rotation of 90°.

Count: Set X to 1, Y to 22, and Z to 1

Offset: X = 0, Y = 0, and Z = 0

Start Position: Set X to 1, Y to 1, and Z to 1

DMX Start Channel: Set it to the next free DMX channel. The next free channel is 481 on DMX universe 1. 

Why? We have already added 8 Elation Professional Design LED  60  Tri Strip  and  every  strip  utilizes  60

DMX  Channels.  That  means  that  all  strips  together  require  480  DMX  channels  in  total  (8  fixtures  x  60

Channels).

DMX Start Universe: 1
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8. Let us add the last fixtures of this tutorial.

Click Add on the toolbar  again.  Because  we  already did  add  several  Martin  Stagebar  2,  we  do  not  have  to

change the Fixture type.

But please change the following settings:

Rotation: 90°

Count: Set X to 1, Y to 22, and Z to 1

Offset: X = 0, Y = 0, and Z = 0

Start Position: Set X to 82, Y to 1, and Z to 1

DMX Start Channel: 301

DMX Start Universe: Set to 2. 

We are using more than 512 DMX channels. That means we need to use more than one DMX universe.
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9. Now, the Patch Size we have set up initially is too large. We will change it to the correct size. Click on Matrix

Size on the toolbar and change the dimensions. Set Size X to 82 and set Size Y to 66. 

Now, the whole patch should look like this:
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Note: For this patch we need to use 3 DMX universes. If there are no more channels available in the current universe

for the next fixture, MADRIX automatically adds the fixture to the next universe.

You can save the Patch if you need it for other Setups. In the Patch, go to  File  > Save  Patch As, choose a directory,

type in a file name, and click Save. Close the Patch. MADRIX updates the new patch automatically.

Congratulations! You have created a Patch with 3 different fixture profiles and 53 fixtures.
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1.6 Creating A Patch With Space Between Fixtures

In this tutorial, you will learn how to create a patch with space between each fixture. This is useful, because of you

can create a patch representing your real fixture arrangement (with space) in the club or on stage.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

We want to create a patch with 16 Eurolite PMB-4 COB.

1. Start MADRIX and open the Patch Editor (Press F3 or go to Preferences > Patch Editor).
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2. Click New on the toolbar or go to File > New. 

Now, click Yes to confirm that all current fixtures will be deleted.

All fixtures will be removed. 
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3. Click Add on the toolbar or go to Edit > Add Fixtures... or press Ins on your keyboard. 

Protocol: Should be DMX. If it is not, change it to DMX.

Fixture: Search and choose EUROLITE LED PMB-4 COB 12 Ch Mode

Rotation: Should be Original

Count: Set X to 4, Y also to 4, and Z to 1

Leave all other parameters with their default settings and click Add
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4. The Patch should look like in the following picture: 

As you can see, there is no space between each fixture. Now,  we  want  to  add  space  between  each  fixture.

Select all the fixtures, except the first column. You can select the fixtures in different ways: 

A] Press and hold the Ctrl key down, then click on every device you want to select in the patch.

B] Press and hold the Shift key down, press the left mouse button and create a selection rectangle above

all fixtures you want to select.

C] Press and hold the Ctrl key down and click on every fixture you want to select in the fixture list on the left

side of the patch window. For this example, select the fixtures with the numbers #0002, #0003, #0004, 

#0006, #0007, #0008, 

#0010, #0011, #0012, 

#0014, #0015, #0016.
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Now, click on one of the selected fixtures with the  left mouse button, hold the left mouse button down and at

the same time move the mouse to the right until the left handed fixtures are at position X = 10

Deselect all fixtures (click into a free area of the patch).

Select all fixtures of the third and fourth column, click and hold the left mouse  button  down on  one  of  the

selected fixtures and move the mouse to the right until the left handed fixtures are at position X = 19

Deselect all fixtures.

Select all fixtures of the fourth column. Now go to the right side of the Patch window to the settings panel. (If

you do not see the panel, go to View > Reset Layout.)

Go to the Fixture Settings category, type in 5 for Offset of Position X,  and click OK. The fixtures should be

moved to the position X = 28
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We have created space between each column, but there is still no space between each row. The Patch should

now look like this: 
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We want to add space between rows:

Deselect all fixtures.

Select all fixtures from row 2 until 4 and move them down until the fixtures of row 2 are at position Y = 5

Deselect all fixtures.

Select the fixtures of row 3 and 4 and move them down until the fixtures of row 3 are at position Y = 9

Deselect all fixtures.

At last, select the fixtures of row 4 and move them down until the fixtures are at position Y = 13

That is it. The patch should look like the patch in the following picture. 
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5. Finally, change the Patch Size to the required total size.

Click Matrix Size on the toolbar and change Size X to 31 and Size Y to 13

Click OK 

Note: It is recommended to save the patch to an external file, because we will need it in another tutorial. Therefore,

go to File > Save Patch As, choose a directory, type in a filename, and click Save

Simply close the Patch Editor and you can work with this patch configuration in MADRIX.

Congratulations! Now you have created a patch that adds space between each fixture.
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1.7 How To Use DVI Map Mode

In this tutorial, you will learn more about the DVI Map Mode.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

The DVI Map  Mode  is  necessary  if  you  want  to  create  a  DVI Patch  with  space  between  DVI fixtures.  The  screen-

capturing  software  or  hardware  captures  a  defined  area  of  your  display  and  you  simply  cannot  set  the  space  in-

between that area.

If you create a patch without space between the fixtures in MADRIX and in reality there is space between them, you

will see an offset and the created effects lose their impact.

With the help of the DVI Map Mode the offset will be removed and the effect will be displayed correctly.



[Part A] Configuration

//50www.madrix.com

MADRIX 3 Tutorials Version 1.9

1. Start MADRIX. Go to Preferences > Patch Editor or press F3. Now the Patch Editor appears: 
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2. Click New on the toolbar, or go to File > New, or press Ctrl+N.

Click Yes to confirm that all fixtures should be deleted. Now you will get a new, empty patch.

3. Click Patch Size on the toolbar and set up Size X = 85, Size Y = 64, and Size Z = 1 
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4. Now, click the Add button on the toolbar or go to Edit > Add Fixtures...

We want to add 16 #G-Lec DVI Phantom60 Frame (16x16)

Protocol: Choose DVI

Fixture: #G-Lec DVI Phantom60 Frame (16x16)

Rotation: Original

Count: Set X to 4, Y to 4, and Z to 1

Offset: Set X, Y, and Z to 0

Start Position: X = 1, Y = 1, and Z = 1

Merge  Fixtures:  Please  disable  the  checkbox,  because  if  it  is  enabled  all  the  added  fixtures  will  be

displayed as one, big fixture.

Start Corner, Main Orientation, Snake Mode, and Start Position: Leave the default settings.
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Now click OK 

The Patch should look like shown in the following picture:
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5. As you can see, there is no space between the fixtures. Let us generate some space in the X-direction.

Select the fixtures of the fourth column and move them until the left side is at position 70. 

Then, select the fixtures of the third column and move them until their the left side has position 47. Now, select

the second column of fixtures and move them to position 24.

(Learn how to select and move fixtures in the tutorial »Creating A Patch With Space Between Fixtures)
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6. Actually, the patch itself would be finished. MADRIX generates the patch with space, but the grabber software

or hardware does not know that you want to have space between fixtures. In the settings of the capture card,

you have to set  up  the  size  of  the  whole  matrix  without  the  space.  In  this  example,  the  size  setting  of  the

capture card is 64 x 64, although our patch has a size of 85 x 64.

Now, we have to activate DVI Map. Click DVI Map on the toolbar. 

You will now see fixtures with a checked pattern, which are labeled DVI Map. The created patch and the DVI

Map are on top of each other. 



[Part A] Configuration

//56www.madrix.com

MADRIX 3 Tutorials Version 1.9

7. We have to adjust the DVI Map for our grabber software or hardware. 

Select the fixtures of the second column and move them to the right border of the first column (close the gap

between first and second row). 

Then, select the fixtures third column and move them to the right border of the second column  (close the gap

between second and third row). 

Finally, select the fixtures of the last column and move them to the right border of the third column (close the

gap between third and fourth row).

Now, the patch should look like this:

Note: We have created a patch for MADRIX and a patch (a DVI Map) for the grabber software or hardware.

MADRIX will show you the patch with space. But in the window  for  the  capturing  software  or  hardware,  the

space will be removed and the offset will be calculated accordingly. MADRIX will do this automatically. 
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8. Close the Patch and select the effect SCE Color in MADRIX. For this example, set up the desired color blue.

You can see  the  space  between  the  fixtures.  All  brightly  illuminated  areas  are  sections  with  fixtures  behind

them. No fixtures are placed in the darker areas. 
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9. We now have to open the window which will be captured by the grabber software or hardware. 

Go to Previews > External Preview 1 > DVI. Now a small window according to the size of your patch will be

opened. You have to move this window to the preconfigured area of the grabber software or hardware. Learn

how this works in the tutorial »MADRIX DVI Output For Screen-Capture Software

Now, change the effect in MADRIX to SCE Color Scroll. Set up the direction to scroll from  top left to button

right.

Now we can see the DVI preview window, such as External 1, but we need it without the space according to

our created DVI Map.

Go to Previews > External Preview 1, or perform a right mouse click on the DVI output window, and enable

 DVI Map Mode 
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The  preview  window  now  looks  like  the  created  DVI  Map  and  MADRIX  calculates  the  offset  automatically.

Thereby,  all  effects  will  be  shown  correctly,  like  you  can  see  in  the  middle  preview  window  of  MADRIX,

Preview Output. 

Congratulations! You have generated a DVI Patch including space between fixtures and a DVI Map for the capture

software or hardware.
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1.8 The MADRIX Fixture Editor

This tutorial shows you how you can use the MADRIX Fixture Editor.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

1. Start the Fixture Editor. You can find it at Start > All Programs > MADRIX 3 > Fixture Editor.

The MADRIX Fixture Editor will be opened and it will be empty at first.
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2. Go to File > Open Library

Select the madrix.mflx and click Open
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Note: The default Fixture Library for MADRIX is the madrix.mflx.

3. You can see the list of available fixtures included in this .mflx file.
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4. We  now  want  to  copy an  existing  fixture  configuration  and  change  the  settings  to  create  our  own  custom

profile.

In this example, we will change the  fixture profile  !generic RGB Light 1 Pixel

Therefore, go to !generic > RGB Light > 1 Pixel  in the list of fixtures on the left side. Select the fixture. 

Now, you can see its properties.
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5. In step 5, we want to copy the selected fixture. Go to Fixture > Copy Fixture

You can see that the properties  of  the  fixture  will  be  highlighted  in  green.  That  means  you  can  change  the

properties.

Note:  The  same  effect  occurs  if  you  click  Edit  Fixture.  But  in  that  case,  you  will  override  the  original

properties.
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6. We will now have to change the properties to create our new fixture. The new fixture has  somewhat  similar

properties. We will change the name and add another pixel, so that the fixture has two pixels side by side.

To create a new fixture, we have to change the following entries:

Manufacturer: This is also the name under which you can find the profile in the section Fixture  Library to

the left. In this tutorial we will call it Example  

Homepage: You can add the manufacturer's homepage. In this way, you could call up the DMX Chart again

some time in the future, for instance.

Fixture Name: This is also the name where you can find the correct profile under the Manufacturer branch

in the section Fixture Library. In this example, we will call it 2 Pixel RGB

Short Name: You will see this name later in the Patch of MADRIX. In this example, it is called RGB

Operation Mode: It is possible to create different profiles for one fixture. For instance, the new fixture has a

mode with 3 DMX channels, with 6  DMX  channels,  and  7  DMX  channels.  You  can  implement  the  different

modes  using  the  same  Manufacturer,  Fixture  Name,  and  Short  Name.  Only  the  Protocol  Name  must  be

different. In this example, it is called 6 ch Mode

Protocol: Here you can choose between DMX or DVI. We want to create a DMX fixture.

Voxel Count X/Y/Z: These make up the size of the fixture. In this example, we are only changing the  X-

amount to 2, because we want to have two pixels next to each other. If you changed the Voxel Amount, you

can see the new fixture size in the section Fixture Preview on the right side.

Color Depth: You can change it if you use a non-RGB fixture. For example, that could be an RGBW fixture or

a single-color fixture. In this example, leave it at 3, RGB

DMX Channel Count: Here you can set the required DMX channels for the fixture. In this example, we need

to set up a value of 6
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7. We will add the missing color channels in this step. 

Therefore, select Color Blue in the section Channel and click Add at the bottom of the section.  The  Fixture

Editor will automatically set the correct, new color at the right position.

Repeat this step until the channel list contains a total of 6 entries.
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Click OK
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8. Now, you can find a new branch in the Fixture Library section. It is called, Example and has a fixture called 2

Pixel RGB with the 6 ch Mode

9. You can check your new fixtures in the library. Go to File > Check Library
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10. Save the .mflx file you just changed.

Note: You have to restart MADRIX if you want to see the changes of the Fixture Library in MADRIX. 

Congratulations! You have created a new Fixture with the MADRIX Fixture Editor.

1.9 Creating A Complex Fixture With The Fixture Editor

This tutorial shows you how you can create a complex fixture with the help of the MADRIX Fixture Editor.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

Note: Before you start to read this tutorial, it is recommended to read the tutorial »The MADRIX Fixture Editor

We want to create a new fixture with the following DMX chart:

Channel Function

1 Dimmer
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2 Strobe

3 Red 1

4 Green 1

5 Blue 1

6 Red 2

... ...

29 Blue 9

The RGB pixels of the fixture are located in 3 rows and 3 columns.
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1. Start the Fixture Editor and load the madrix.mflx.
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2. We will create a new fixture profile. Go to Fixture > Add New Fixture

You can see that the settings are turned active and some default entries will be displayed.
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3. First, we have to change the fixture settings to the following: 

Note: For an explanation of each parameter, see the tutorial »The MADRIX Fixture Editor

Manufacturer: Example

Homepage: www.madrix.com

Fixture Name: 3x3 RGB Blinder

Short Name: Blinder

Protocol Name: 29 ch mode

Type: DMX

Voxel Amount X / Y Z: 3, 3, 1

Color Depth: 3

DMX Channel Amount: 29

DMX Address Min / Max: 1, 512
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4. Second, we will change the settings of the first channel:

Name: Type in a name as desired. In this example, this is the dimmer channel. That is why we will  enter

Dimmer

Default Value: 255 

Note: It is important to set it to 255 because MADRIX will control the intensity, not with the dimmer channel.

The intensity will be controlled with the help of the RGB value. If the Dimmer value is set to 0, you would not

see any output.

Fixed: Enable the checkbox for the dimmer, because the value should never change.
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5.  Click Add  in order to add a new channel to the list.
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6. We are changing the  name  of  the  new  channel  to  Strobe,  setting  the  default  value  to  0,  and  enabling  the

option Fixed because we are not going to use the internal strobe effect of the fixture.
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7. Now, click the Add button again and change the name of the third new channel to Red. Leave all other settings

to their default values, because we have added the first color channel.

Afterwards, click Add again and change the color of that channel to green. To do so, change  Color # to 2 or

click the small arrow at the color pop-up menu and change the color to Green.

P

Repeat this step, but change the color to Blue this time.
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8. Click Add again to add channel 006. You will see that X and Y position of the voxel is increased automatically. 

But in this example,  the  order  of  the  pixels  are  positioned  in  rows  from  left  to  right  and  from  up  to  down.

Therefore, we will change Voxel Pos Y to 1. As a result, you can see that the second pixel in the first row will

be used instead. 
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9. Click Add repeatedly until you have added a total of 11 channels. Now, the first row of voxels is complete.

If you click Add again, you will see that the third pixel of the second row will be activated. 
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But in this example,  the  sequence  of  pixels  starts  on  the  left  side  of  each  row.  To  change  the  active  pixel,

change  Voxel Pos X to 1.
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10. Now, you can add all the other RGB channel settings by yourself. Simply, click Add repeatedly  until  you  have

create a total of 29 channels.

11. To complete the fixture creation process, click OK
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12. Now, you will see a new fixture branch with a new fixture in the Fixture Library section. To check if everything

is correct, go to File > Check Library...

A new window will be opened. If all fixtures are created correctly, the following message appears:

Congratulations! You have created a more complex fixture using the MADRIX Fixture Editor. 
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1.10 Importing A Patch Into MADRIX

In this tutorial, you will learn how you can import a prepared patch. That is useful if you create a patch on one PC and

you want to open the patch on another PC or if you want to use the patch for several setups.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

Requirements: For this tutorial it is important to save a patch file first. A previous tutorial explains how to create a

patch file »Creating A Patch With Space Between Fixtures

1. Start MADRIX. You can see the graphical user interface of MADRIX with the default matrix size of 50 x 50 x 1

voxels.
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2. Go to File > Import > Patch...

Choose the directory on your harddisk where your patch file is located, select the patch file, and click Open

MADRIX automatically updates the sizes of the output windows and the Previews according to your patch. 

Congratulations! You have imported a patch file into MADRIX. 
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1.11 Connecting MADRIX With An Art-Net Node

In this tutorial, you will learn how you can connect Art-Net nodes with Find Auto Mode in MADRIX.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

Note: Please make sure that all connected hardware nodes and the PC are in the same network.

1. Start MADRIX, go to Preferences > Device Manager (or press F4), and select the tab Art-Net
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2. Enable the Art-Net checkbox.

After a few seconds, you can see the Art-Net Remote device in the list. That is your own PC.
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3. Now, click Search button on the bottom of the Device Manager.

After a few seconds, you can see the all Art-Net nodes that were found in the network. In this example, it is a

MADRIX PLEXUS with 2 universes. The device is displayed with its Art-Net IP address.

If your PC, cannot find the connected Art-Net nodes, please make sure that the nodes and your PC are in the

same  network.  Another  reason  could  be  that  your  Art-Net  node  does  not  support  the  ArtPoll/ArtPollReply

feature  for  automatic  finding.  You  have  to  add  the  node  manually  »Manually  Connecting  An  Art-Net  Node  In

MADRIX
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4. Change the Device Manager  tab  to  DMX  Devices.  Now,  you  can  see  the  connected  Art-Net  nodes  as  DMX

Devices. But DMX output is currently disabled (State is Off). 



[Part A] Configuration

//93www.madrix.com

MADRIX 3 Tutorials Version 1.9

5. We  will  have  to  enable  all  Art-Net  nodes  for  DMX  output.  Please  select  a  DMX  device,  click  Enable  in  the

Settings section and then Apply.

Repeat this step for all your DMX devices that are connected via Art-Net. ArtNet Remote should be Off. 

Now you can control your Art-Net nodes just like DMX interfaces that are plugged into your PC via USB.

Congratulations! You have successfully connected the Art-Net node with MADRIX.
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1.12 DMX Universe Settings For Several Art-Net Nodes

This  tutorial  shows  you  how  you  can  set  the  DMX  universe  assignment  when  using  more  than  one  Art-Net  node

together with MADRIX.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

Note: Before you start to read this tutorial, it is recommended to work through the tutorial »Connecting MADRIX With

An Art-Net Node
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1. Start MADRIX. 

Go to Preferences > Device Manager (or press F4) and select the tab Art-Net.  Activate  Enable in order to

activate Art-Net. Then, click the  Search button (Loupe icon). 

Now, MADRIX will automatically search and find all connected Art-Net nodes, which are physically connected to

the network, set to work in the same network range, and support the ArtPollReply mechanism.

In this example, we have connected 9 MADRIX LUNA 8. 

Please note that you will always find nodes with a maximum of 4 ports per device  in  the  Art-Net tab  of  the

Device  Manager.  That  is  based  on  the  Art-Net  specifications  where  every  Art-Net  node  can  hold  4  ports

(universes). If the node has more  than  4  ports,  the  node  must  be  split  into  more  nodes  using  the  same  IP

address but a different bind index. For an 8-port Art-Net node, such as the MADRIX LUNA 8, you will therefore

find 2 entries per device using the same IP address. The DMX universe assignment however is set to 1, 2, 3, 4

for the first device entry and 5, 6, 7, 8 for the second device entry.
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2. Please switch to the DMX Devices tab of the Device Manager and have a look at the column Universe. You

will  see  that  all  connected  8-port  MADRIX  LUNA  nodes  are  listed  with  their  individual  ports.  They  were

automatically set to DMX universe 1 to 8.
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3. In our case, we want to set every port to a unique universe number. To do so, select the desired Port, change

the Universe, and click Apply.

In this example, we are leaving the first device assigned to universes 1 to 8 as is and start changing the first

duplicative entry from universe 1 to universe 9.

Note that the virtual DMX universe has been changed to 9. 
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4. Repeat Step 3. for all devices and ports. 

We will give every port a unique virtual universe number and increment the universes. 
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5. All ports are still set to Off. That means that no DMX data is being sent to this port right now.

To switch all ports to On, we will be selecting all ports first. 

Select the first port in the list and scroll down to the last port. Then, press and hold the Shift key, and select

the last port in the list. Or press Ctrl+A. All ports will be selected now.
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6. Activate all selected ports by clicking the Enable checkbox. Confirm with Apply

Now, all selected ports are switched to On.
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Note: The  fixture  assignment  of  the  Patch  Editor  needs  to  align  with  the  DMX  universe  assignment  in  the

Device Manager. Set up MADRIX according to your requirements. In this example, data for DMX universe 9 will

be sent to the node with the IP address 10.206.224.10, Port 0.

Congratulations! You have successfully changed the virtual DMX universes assignment in MADRIX.
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1.13 Manually Connecting An Art-Net Node In MADRIX

This tutorial shows you how you can connect Art-Net nodes manually.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

For this tutorial we want to add an 8 port Sample Node.

Note: An Art-Net node can have up to 4 DMX ports as per official specifications. If your Art-Net device has more than

4 ports, you have to add the node several times with the same IP address. For example,  the  "Sample  Node"  has  8

DMX ports, so we have to add 2 Art-Net nodes. The first node will be used for ports 1-4 and the second node is used

for the ports 5-8.

1. Start MADRIX, go to Preferences > Device Manager or press the F4 key, and then select the Art-Net tab. 
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2. Enable the Art-Net checkbox. 

After a few seconds, you can see the device ArtNet Remote. That is your own PC.
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3. Now, click Add button on the bottom of the Device Manager. 

The Create New Device window will be opened. In this example we want to add 1 Device with 4 ports.

Click OK.

Select the newly added Art-Net node and perform a double-click on it  with  the  left  mouse  button.  A  new

window will be opened and we have to configure the new Art-Net Node. 

Short Name: Define a name for your node. In this example, we will use Sample Node P1-4

Long Name: You can enter a longer description name. In this example, we leave the default settings.

Port Count: Here you can change the number of ports if your device has less than 4 ports. In this example,

we are setting it to 4

Universe Port OUT: You can set the DMX output ports of the Art-Net node. We will use the default settings

. 
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Direct IP Mode: Should be enabled if you want to send only to the IP address of this device. 

You can also send to all Art-Net nodes in the network if you enable Broadcast  Mode.  But  you  should  know

that the data traffic will be much more and every node with port 1-4 will receive the data. 

IP Address: Set the IP address of your Art-Net node. In this example, the IP address of the Sample Node is

10.0.0.15 

Click OK
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4. So far, we have added one Art-Net node with 4 ports. But the Sample Node has 8 ports. That means we have

to add another Art-Net node in MADRIX with the same IP address, but using port 5-8.

In the Device Manager of MADRIX, tab Art-Net, select the Sample  Node P1-4 list  entry  and  click  Duplicate

button on the bottom of the window.

A new Art-Net node will be created. Please select the copied entry (it is the entry wit the name copy  Sample

Node).  Perform  a  double-click  with  the  left  mouse  button  to  open  the  Art-Net  Device  Configuration

window. 

Short Name: X-Net8 Port 5-8 

Long Name: Leave the default settings.

Port Count: 4 

Universe Port OUT: Change the first Universe to  5 (0x04), the second Universe to 6 (0x05), the third

Universe to 7 (0x06) and the fourth Universe to 8 (0x07). 

Direct IP Mode: Should be enabled.

IP Address: Should be the same IP address as the IP of Port 1-4.
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Click OK

5. The Sample Node with 8 ports has now been added.
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6. Change to the DMX Devices tab in the Device Manager.

You can see one DMX universe for every port of the Art-Net nodes. All universes are Off
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7. Now, we have to enable the DMX universes and to set the desired virtual Universe. Select one universe and go

to the Settings section of the Device Manager. Please click Enable, set up a desired Universe and click Apply

. Repeat this for all DMX universes.

Note: The ArtNet Remote device should be Off 

You can use the Art-Net nodes and DMX universes just like they were connected to your PC via USB.

Congratulations! You have manually created new Art-Net nodes in MADRIX. 
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1.14 Remote Control Via DMX-IN

This tutorial shows you how you can control MADRIX remotely via DMX-IN. For this tutorial you need an interface for

DMX input that is supported by MADRIX and an additional DMX controller to control MADRIX. If you want to use DMX

output, another MADRIX-supported interface is required.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

Note: There are several DMX-IN protocols implemented in MADRIX. An overview of all protocols is provided »here 

1. Start MADRIX and go to Preferences > Device Manager or press the F4 key.

You  can  see  all  connected  and  found  interfaces.  In  this  example,  it  is  one  MADRIX  NEO  interface  and  one

MADRIX PLEXUS  (with two DMX universes). If you do not see all  interfaces  you  plugged  into  your  computer,

click Search button. If MADRIX still does not find the interfaces, have a look at  this  tutorial  »Where  You  Can

Find Connected Hardware

http://help.madrix.com/m3/html/madrix/index.html?hid_remotecontrol_dmx.html
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2. We want to use the MADRIX NEO as DMX input interface.  Therefore,  select  the  MADRIX  NEO in  the  list  and

enable the Input checkbox on the right-hand side in the Settings section. 

3. Click Apply on the bottom, right-hand side of the window.
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4. Now, go to the DMX Input tab of the Device Manager. Select the Universe  1 and click on the arrow next to

DMX-IN Device  in  the  Device  section.  Select  your  desired  DMX  input  interface.  In  this  example,  it  is  the

MADRIX NEO. 

5. Enable the Remote checkbox on the right-hand side. 
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6. Select the smallest DMX-In protocol in  the  Remote  Control section.  Use  the  arrow  button  and  and  choose

Simple.

Click OK

7. Connect your DMX controller with the MADRIX NEO interface. 

You can now control MADRIX remotely. 

8. For example, you can change the value of the first  channel  of  your  DMX  controller  to  value  33  and  MADRIX

should change Storage Left to Storage Place 34. 

An other example is: change the value of fourth channel to 128 and MADRIX changes the position of the Master

Fader to value 128.  

Congratulations! You have configured DMX remote control. 
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1.15 Remote Control Via Art-Net And CITP

In this tutorial, you will learn how you can  control  MADRIX  remotely  via  Art-Net  as  well  as  receiving  thumbnails  of

Storage Places via CITP.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

Requirements: Make sure that only one network card is enabled in Windows.

1. Set up an Art-Net compatible IP address/subnet mask in Windows for your network card. In this example, we

are using the network address 10.0.0.39 for the PC on which MADRIX will run (being controlled remotely) and

the network address 10.0.0.23 for the console which should send the  data  to  MADRIX.  The  subnet  mask is

255.0.0.0 on both devices.
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2. Start  MADRIX  and  go  to  Preferences  >  Options...,  select  the  Devices  Network  tab,  go  to  the  section

Capture - CITP and activate Enable Server 

Click OK

MADRIX now runs as CITP server.

Note: If you have more than one active network card, you need to choose the right network interface. Below

the Enable Server checkbox, click on the arrow on the right-hand side of the drop-down menu and select the

correct network interface card.
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3. Now, go to Preferences > Device Manager or press the F4 key and select the Art-Net tab.

4. Click on the checkbox Enable in the upper right corner to enable Art-Net.
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5. Select the automatically created ArtNet  Remote  entry  in  the  list  (the  list  entry  will  be  highlighted  in  green

then) and click the Configuration button on the right side.

c
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6.
6.1 Enable  Direct  IP  Mode  and  enter  the  specific  IP  address  of  your  console.  In  this  example,  it  is

10.0.0.23 

or
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6.2 Enable Broadcast Mode to listen to all IP addresses in the Art-Net network. 

Click OK

7. In the Device Manager, switch to the tab DMX Devices 
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8. Select the automatically created ArtNet  Remote  entry  in  the  list  (the  list  entry  will  be  highlighted  in  green

then), activate Enable to the right, and press  Apply 

9. Now, switch to the DMX Input tab. 

P
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10. Select the first entry of the list (Universe  1), which is  still  empty (the  list  entry  will  be  highlighted  in  green

then), and select ArtNet Remote at DMX-IN Device in the Device section. 

You can check now if you are receiving DMX-IN data via Art-Net. To do so, click Watch  Universe... and  the

DMX Watcher will be opened. 

Please make sure that the DMX Watcher is set to Input and DMX Universe 1.
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If the console is configured correctly and if it sends DMX data, you should see it in the DMX Watcher
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11. While still having selected the  first list entry in the Device Manager, tab DMX Input, enable Remote in the

upper right corner. 

12. Now, click on the little arrow in the  Remote Control section and choose the Simple protocol.

Note: The first list entry must still be selected. 
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13. Click Edit... and you can see the preconfigured DMX protocol.
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14. The  Simple  DMX  protocol  is  configured  as  follows:  CH01  chooses  the  Storage,  while  CH02  chooses  the

Storage Place with its MADRIX Effect, CH03 regulates the Fade Time of the Crossfader, and CH04 controls the

Master Fader.

Note: The Simple protocol will only use and work at the left side of MADRIX.

15. Close the DMX-In Remote Editor, and click OK and the Device Manager will be closed, too.

Note:  You can go to Tools > Logfile to see details  of  what  MADRIX  sends  or  receives  via  CITP.  (To  filter  the  log

messages, set the Filter to CITP.)

Congratulations! You can control MADRIX via Art-Net and CITP now. 
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1.16 Controlling MADRIX With A MIDI Controller

In this tutorial, you will learn how you can connect a preprogrammed MIDI Controller to MADRIX.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

For  this  example,  we  want  to  use  the  Numark  NuVJ  Controller.  You  can  find  a  list  of  all  preprogrammed  MIDI

controllers »here

Note:  If your MIDI controller is on the list, please have a look at this tutorial »Creating  A  New  MIDI  Map  For  A  MIDI

Controller

1. Install the driver of your MIDI Controller according to the installation instructions of the controller's manual.

2. Plug the MIDI controller into your PC. 

http://help.madrix.com/m3/html/madrix/index.html?hidd_device_page_midi_input.html
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3. Start MADRIX and go to Preferences > Remote Control > MIDI...

Now, the  Device Manager with an active the MIDI tab will be opened.

You can see all detected MIDI controllers in the Device list. If not, click the Search button.

Note:  In  this  example,  we  are  using  a  Numark NuVJ  Controller.  You  can  see  the  name  of  the  connected

controller in the Device list.
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4. The device is still deactivated (Off;  red light). We have to enable the MIDI controller and make it available for

MIDI Remote.  Therefore,  select  the  device  in  the  Device  list,  activate  the  Enable  checkbox  as  well  as  the

Remote checkbox on the right-hand side of the Device Manager. 
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5. MADRIX will now interpret the input MIDI commands.  But  we  will  have  to  assign  the  correct  MIDI controller

configuration (MIDI Map). Go to the Remote  Control section and click on the arrow on the right-hand side of

the Edit field. In the drop-down menu, search for and select the connected MIDI controller. For this example,

we will select Numark NuVJ

Click OK

6. Now you can control MADRIX with the MIDI controller.  If  you  want  to  change  the  assignment  of  keys  of  the

controller, have a look to this tutorial »Changing The Predefined MIDI Map Of A MIDI Controller

Congratulations! You have connected a preprogrammed MIDI controller to MADRIX.
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1.17 Changing The Predefined MIDI Map Of A MIDI Controller

This tutorial shows you how to change the assignment of keys of a preprogrammed MIDI controller in MADRIX .

Date: 09/2014

MADRIX Version: 3.3 (Created with)

Requirements: It is necessary to connect a preprogrammed MIDI controller  to  MADRIX  for  this  example.  You  can

learn how to connect one in a previous tutorial »Controlling MADRIX With A MIDI Controller

In this tutorial, we want to change the assignment of several MIDI encoders of a Numark NuVJ Controller.

1. Start MADRIX and make sure that the MIDI controller works correctly. If it does  not,  see  »Controlling  MADRIX

With A MIDI Controller

2. Go  to  Preferences  >  Remote  Control >  MIDI and  you  should  see  the  connected  MIDI  controller.  In  this

example, it is the NuVJ Controller 
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3. Select the MIDI controller in the list and click Edit in the Remote Control section. 
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4. The MIDI Remote Editor will be opened. 

You can see all MIDI commands for this controller here.
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5. In this tutorial, we want to change the MIDI commands for the encoders that are described with the numbers

15, 18, 19, 21 in the »MADRIX User Manual (Color Filter color RED, Color Filter color GREEN, Color Filter  color

WHITE, Color Filter color BLUE).

Therefore, search for the entries Function: Global Filter Red,  Global Filter  Green,  Global Filter  Blue,  and

Global Filter White in the MIDI Remote Editor. These entries are indexed at #27 to #30. 

http://help.madrix.com/m3/html/madrix/index.html?numark_nuvj.html
http://help.madrix.com/m3/html/madrix/index.html?numark_nuvj.html
http://help.madrix.com/m3/html/madrix/index.html?numark_nuvj.html
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6. Perform a double-click with the  left mouse  button on Global Filter Red. A pop-up  menu  appears.  In  this

menu, go to Fade > Color Red 
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7. Change Global Filter Green to Fade > Color Green in the pop-up menu, Global Filter Blue to Fade > Color

Blue, and Global Filter White to Fade > Color White

The four entries in the MIDI Remote Editor should now look like this: 

8. In the next step, we want to save the modified MIDI Map. Enter a new name in the Configuration Name edit

field in the upper corner of the MIDI Remote Editor and click Save As. A new window opens. Select a directory

on your harddisk and click Save



[Part A] Configuration

//136www.madrix.com

MADRIX 3 Tutorials Version 1.9

9. Close the MIDI Remote Editor. You can see that the name of the manufacturer in the Remote  Control section

of  the  Device  Manager,  tab  MIDI has  changed  to  USER  and  the  configuration  name  has  changed  to  your

desired config name. In this example, we have named it NuVJ FadeColor 

Click OK

10. If you now use one of the encoders of your controller and change its value (described with the numbers 15, 18,

19, 21 in the »MADRIX User Manual), you can see that not the Filter Color but the Color Fade color changes. 

Congratulations! You have changed several MIDI commands of a preprogrammed MIDI Map in MADRIX.

http://help.madrix.com/m3/html/madrix/index.html?numark_nuvj.html
http://help.madrix.com/m3/html/madrix/index.html?numark_nuvj.html
http://help.madrix.com/m3/html/madrix/index.html?numark_nuvj.html
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1.18 Creating A New MIDI Map For A MIDI Controller

This tutorial shows you how you can create a new MIDI Map for a MIDI controller in MADRIX.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

Requirements: Before we start, please make sure that the drivers of the MIDI controller are installed correctly. The

controller needs to be connected to your PC.

In this example, we want to add a MIDI command for the Master Fader, a MIDI command for the Audio Input Fader,

and a MIDI command for a direct access to Storage Place S1 P5. 
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1. Start MADRIX and go to Preferences > Remote Control > MIDI...

The Device Manager with an active MIDI tab will be opened as a result.

You can see all detected MIDI controllers in the Device list. If not, click the Search button. 
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2. The device is still Off (red light).  We  will  have  to  enable  the  MIDI controller  and  make  it  available  for  MIDI

Remote. Select the device in the list and activate the Enable checkbox as well as the Remote checkbox.



[Part A] Configuration

//140www.madrix.com

MADRIX 3 Tutorials Version 1.9

3. Now search and select the USER configuration in the drop-down menu of the Remote Control section. 

4. Click Edit to the right of the drop-down menu. 
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5. An empty MIDI Remote Editor will be opened. Click the  + button.

Now you can see a drop-down menu with different groups. Select one group and you can see all possible MIDI

controls of that group. The classification in groups should help you to find the required MIDI command faster. 
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6. First, we want to add the MIDI command that belongs to a fader from our MIDI controller in order to  control

the Audio Input Fader. Go to Audio > Input Level and select it. 

7. A new list entry will be added in the MIDI Remote Editor. Audio Input Level should be written in the Function

column and CH01.CC.060 should be written in the MIDI Command column.

Note: The MIDI command CH01.CC.060 is a default value. Every newly added command gets this value and

you have to change it.
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8. In order to change the  MIDI Command, click Assign. Now, you can "train" the MIDI Remote  Editor with the

help of your MIDI controller. 

Select the list entry where you want to  change  the  MIDI command.  Then,  press  the  desired  button  on  your

MIDI controller, spin an encoder or knob, or move a fader. For this example, we want to move a fader on the

controller. 

You should see that something has changed in the selected line: 

#: Should be the same as before.

Function: Should be the same as before.

MIDI Command:  Should  have  changed  to  the  corresponding  MIDI  command  of  your  controller.  In  this

example,  it  has  changed  from  CH01.CC.060  to  CH01.CC.011.  But  in  your  case,  it  will  probably  be  a

different value.

Control Type: The MIDI Remote Editor automatically recognizes the type of your selected MIDI control. If it

is incorrect, you can change it with a left mouse button double-click.

Interaction: The  MIDI Remote  Editor  automatically  recognizes  the  interaction  type  of  the  selected  MIDI

control. Faders are mostly Absolute and buttons are mostly Toggle. If it is wrong, perform a double-click

with the left mouse button on it. 

Invert: You  can  perform  a  double-click  with  the  mouse  on  it  to  change  it  between  Yes  and  No.  If  you

change it to Yes, all values will be inverted. For  example,  the  value  0  will  be  interpreted  as  255  and  the

value 255 will be recognized as a 0. If Invert is active and you would move a slider upwards, the fader will

move downwards in MADRIX. In this example, leave the default setting No 

Condition: If  you  want  to  control  the  command  with  modifiers,  you  will  need  this  column.  For  further

information on how to work with modifiers, have a look at the »MADRIX User Manual. In this example, we will

not work with conditions. 

MIN: Represents the minimum value of the MIDI command. In this example, we want to control starting from

0.

http://help.madrix.com/m3/html/madrix/index.html?hidd_dmx_in_remote_editor.html
http://help.madrix.com/m3/html/madrix/index.html?hidd_dmx_in_remote_editor.html
http://help.madrix.com/m3/html/madrix/index.html?hidd_dmx_in_remote_editor.html
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MAX: Represents means the maximum value of the MIDI command. In this example, we want to control until

a value of 255. 

Factor: You can multiply the value of the controller with a desired value. Sometimes this is necessary if you

are using a Jog-wheel and the resolution of it is too rough or too fine. For more information, have a look at

the MADRIX User Manual. In this example, it is not necessary to add a Factor for the used controller. 

Description: A default description is set for each control. But you can change it using a double-click on it. 

http://help.madrix.com/m3/html/madrix/index.html?hidd_midi_in_remote_editor.html
http://help.madrix.com/m3/html/madrix/index.html?hidd_midi_in_remote_editor.html
http://help.madrix.com/m3/html/madrix/index.html?hidd_midi_in_remote_editor.html
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9. We will add the second MIDI command (for the  Master  Fader).  Click  +  again,  go  to  Global >  Master,  and

choose it. 
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10. Select the Global Master list entry and move the desired fader on your MIDI controller (Assign should still be

active). You should see that the MIDI Command, Control Type, and Interaction are changed automatically. 

11. Now, we want to add a MIDI command for direct access to Storage Left, Storage Place 5. To do so, click +, go

to Storage Left > Place, and select it. 

Note: In this example, we are always accessing Storage Place 5 on the left side of MADRIX, independently of

what Storage is currently active.
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12. Select the line in the Device list displayed as Storage Left Place. Then, press your desired button on the MIDI

controller. Change change the value for Min and Max to 4 in the MIDI Remote Editor. 

Note: In the MIDI Remote Editor, Storage Places start at 0. 

13. You are now able to add all desired MIDI commands by yourself.

14. Write a Config Name into to the edit box on the upper right-hand  side  of  the  MIDI Remote  Editor  and  click

Save As. Select a directory in the window that opens and save the configuration. 

Now, close the MIDI Remote Editor and you should see that your chosen configuration name  is  shown in  the

Remote Control section. 

Click OK in the Device Manager.

Congratulations! You have just created a MIDI Map for a MIDI controller in MADRIX. 
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1.19 DMX Output With Various DMX Interfaces

In this tutorial, you will learn how to use a (3rd-party) DMX interface for DMX output in MADRIX. For this example, we

will use a Soundlight USBDMX-TWO interface.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

Note: To control DMX fixtures with a third-party DMX interface, you need an additional MADRIX KEY with a license for

DMX512-based output. For further information, please visit »www.madrix.com

Before we start, please make sure that the MADRIX Key and the interface are installed correctly.

http://www.madrix.com/en/home/products/product-overview.html
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1. Start MADRIX, go to Preferences > Options, and choose the tab Devices USB 

Now, you can see a list with supported DMX interfaces. 
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2. Choose your interface and enable it (the checkbox will be illuminated in green). In this example, we choose the

 Soundlight USBDMX-TWO driver. 

Click OK
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3. The driver for the Daslight interface is now enabled. In this step, we have to add the interface to the MADRIX

DMX devices. Go to Preferences > Device Manager and click the  Search button 

4. After a view seconds, you should see the enabled interfaces.

If  you  do  not  see  the  enabled  devices  in  the  list,  please  have  a  look  at  the  tutorial  »Where  You  Can  Find

Connected Hardware
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5. Now select your DMX interface and have a look at the Settings section on the right-hand side of the Device

Manager. 

Enable: If you want to control fixtures with the interface or if you want to MADRIX remotely, the checkbox

should be illuminated in green (activated). Otherwise, the interface is Off.

Output:  The  checkbox should  be  illuminated  in  green  (activated)  if  you  want  to  control  DMX  fixtures  via

MADRIX through the selected interface. 

Input:  This  checkbox  should  be  illuminated  in  green  if  you  want  to  control  MADRIX  remotely  having

connected a DMX controller to this interface. 

Universe: Here you can set which DMX universe should be controlled via the selected interface and MADRIX.

 

Frame  Time  (ms):  Leave  the  default  value.  This  settings  allows  you  to  define  after  which  time  (in

milliseconds) a new frame will be sent. 

Send Full Frames: The default setting is Optimized (deactivated). That means you are sending only DMX

values for the used channels. If you use Full Frames, DMX values for all 512 channels will be sent. 

Click OK
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Congratulations! Now you have configured a (3rd-party) DMX interface in MADRIX.
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1.20 T9 Configuration In MADRIX

In  this  tutorial,  you  will  learn  how  you  can  setup  MADRIX  to  control  a  T9  fixture  without  using  a  screen-capture

software. In this example, we want to use one EUROLITE - LSD 37.5 curtain.

Date: 08/2013

MADRIX Version: 3.0 (Created with)

Note: It is important that you have already configured the LSD  AIO-Network-Control-System. If you have not and

do not know how it works, have a look at this tutorial »Setting Up LED Studio For EUROLITE LED Pixel Mesh 64x64

Before we start, make sure that the network interface card you want to use for the connection with the AIO-Network-

Control-System is able to send 1000 MBit/s. 
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1. Start MADRIX and press the F2 key. The Matrix Generator will be opened. Change the following settings: 

Protocol: DVI 

Fixture: EUROLITE LSD-37.5 DVI 32x64

Rotation: Original 

Count: Set X to 1, Y to 1, and Z to 1 

Merge Fixtures: Should be Enabled 

Click OK
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2. Now, go to Preferences > Device Manager or press the F4 key. Then, go to the DVI Devices tab and click

Add New Device 
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3.  Choose EuroLite T9
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4. A new window will be opened. Select the corresponding Gigabit Ethernet card and click OK 

Note:  If you have not  installed the WinPcap  driver,  you  can  read  the  following  message  next  to  the  RGB

color slider:  Can't find valid network device.  Are  your network card  and  the  WinPcap  driver  installed

correctly? If you can read this message, please close MADRIX, start the installer of MADRIX again, and install

the WinPcap Driver. 

Click OK
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5. Now you can see an EuroLite T9 device in the list. The State should be On. If not, please select the device in

the list and activate the Enable checkbox in the Settings section on the right-hand side. 

Click OK

Congratulations! You have created a configuration for Eurolite T9 fixtures in MADRIX.
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1.21 MADRIX Full Screen DVI Output For Video Projectors

This tutorial shows you how you can control a second monitor or projector in full screen mode with MADRIX.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

Note: For this tutorial it is necessary to have a graphics card  with  a  minimum  of  two  outputs.  Please  connect  two

output devices to your PC (such as one monitor and one projector).
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1. We want to create a new DVI Patch with 200 pixels horizontally and 150 pixels vertically.

Start MADRIX and go to Preferences > Matrix Generator or press the F2 key. The Matrix Generator window

will be opened. Now change the settings to:

Protocol: DVI

Fixture: !generic DVI 1x1 RGB

Rotation: Original

Count: Set X to 200, Y to 150, and Z to 1

Merge Fixtures: Enable this option.

Click OK
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2. Now, go to Previews > External Preview 1 > Full Screen and click it.

The DVI Preview Window will be opened in Full Screen Mode.

3.  It is possible that the full screen window overlies the MADRIX user interface. Press the Tab (Tabulator) key on

your keyboard and the full screen window will switch to the second output device.
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4.  Go again to Previews > External Preview 1. Now you can change several options.

External Preview Settings...: If you click on it, the External Preview Settings window will be opened. In

most  cases,  you  do  not  need  to  change  any value.  For  more  information,  see  this  tutorial  »MADRIX  DVI

Output For Screen-Capture Software 

Keep Always On Top: Enable this option and no other windows will be able to overlay this window even if

you change to another program.

3D Mode: You can change the view to a 3D view, but for video projectors you should use a 2D view.

2D Mode: If 3D Mode is enabled, you can change it the 2D view.

DVI Map Mode: In Full Screen mode you usually do  not  need  to  activate  this  option.  More  information  is

provided in another tutorial »How To Use DVI Map Mode 

Stretch Pixels: If this option is enabled, the pixels will be stretched to full screen (in this example there are

200x150  pixels).  Please  note  there  will  not  be  added  any new  pixels.  The  pixels  will  only  be  taller.  The

following images show the result
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Stretch Pixels disabled Stretch Pixels enabled     

The white borders in the picture represent the size of the display. 

Show Status  Information:  If  you  enable  this  option,  you  should  see  some  information  at  the  top  of  the

window, like the pixel resolution. 

Show Clock: If you activate this option, the current time will be displayed on top of the full screen window.

Show Grid: If you enable this option, you can see a thin frame for each pixel. 

Grid disabled Grid enabled     

Show Background Image...: There is the possibility to load a background image into  the  output  window.

You can see the loaded image if the Stretch Pixels option is disabled. 
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Reset View: If  you  zoomed  in  and  changed  the  position  of  the  matrix  in  the  preview,  you  can  reset  the

preview to default with this option. 

Move  To  Next  Screen: You  can  send  the  preview  to  the  next  screen,  such  as  the  second  graphic  card

output.

Congratulations! You have arranged a second output window in Full Screen Mode. 

1.22 MADRIX DVI Output For Screen-Capture Software

This tutorial shows you how you can send MADRIX output data to a screen capture software.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

Note: It is important for this tutorial that the screen-capture software of your fixture is installed and working correclty.

If you use the software LED Studio, this tutorial can be very useful to you.

In this example, we want to control  16 EUROLITE LED  Pixel Mesh 64x64. The fixtures will be installed in a 4 by 4

grid. We will use the screen-capture software LED Studio 10.4D in this example.

1. Configure your screen-capture software.
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2. Start MADRIX and go to Preferences > Patch Editor or press the F3 key.

(If you do not know how the Patch window works, please have a look to this »Creating A  Patch With Different

Fixtures)

In  the  Patch  Editor,  click  the  New button  on  the  toolbar.  Afterwards,  click  Add  and  change  the  following

settings in the Add Fixtures window: 

Protocol: DVI 

Fixture: EUROLITE Pixel Mesh 64x64 16x16 pixel dvi 

Count: Set X to 4, Y to 4, and Z to 1 

Merge Fixtures: Should be Disabled (the checkbox is gray).

Start Corner: Bottom Left

Main Orientation: Vertical

Snake Mode: Should be Disabled

Start Position: Leave the default settings (X is 1, Y is 1, and Z is 1).
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Click OK

3. We need to change the Matrix Size to 64 x 64. Click Matrix Size on the toolbar and set Size  X to 64, Size  Y to

64, and Size  Z to 1. This step is necessary because the Patch Size is not be updated after changing a patch

and its included fixtures. 

Click OK

4.  Close the Patch Editor.
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5. Go to Previews > External Preview 1 and select DVI 

Now, you can see a (small) new window according to the size of your patch. In this example, its size  is  only

64x64 pixels. 
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6. Start  your  screen-capture  software.  It  is  important  that  the  External  DVI  Preview  Window  of  MADRIX  is

positioned in the  capture  area  of  your  screen-capture  software.  Perform  a  left  mouse  button  click on  the

External DVI Preview Window of MADRIX and move it to the position of the  capture  area  while  continuing  to

holding down the mouse button. Or go to Previews > External Preview 1 > External Preview Settings....

The External Preview Settings window will be opened. You can adjust specific settings there:

DVI Window Position: Here you can set the position of the DVI Preview Window starting from the left and

from the top.

DVI Windows Size: If Display Area Size is enabled, the size of the DVI Preview Window is as large as the

Patch Size in pixels. If it is disabled, you can change the Width and Height of the DVI Preview Window. 

Display Area: If Full Size is enabled, the complete patch size will be displayed on the DVI Preview Window.

If Full Size is disabled, you can choose which area (from which and to which pixel) should be displayed on

the DVI Preview Window.  

Slice Alignment: This option is important when you have created a 3D patch. Because DVI controllers usually

do not accept any 3D input image. So you have to send a 2D image. You can change the Slice  Type and the

Slice Order.

Display Transformation: You can Flip and Rotate the "DVI Preview Window". That is important if you have

turned your fixtures during installation, for example. 
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7.  Now, go to Previews > External Preview 1  and select Always On Top. Often, this is necessary so that no

other windows overlay the DVI Preview Window.
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8. Note: The EUROLITE LED Pixel Mesh 64x64 fixtures we used in the above example are connected as shown in

the following picture:

Congratulations! You have set up a MADRIX DVI Preview Window for your screen-capture software.
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1.23 Creating A 3D Patch Using The Matrix Generator

This tutorial shows you how to create  a  3D Patch  with  the  Matrix  Generator  and  how  you  can  change  the  view  in

MADRIX to 3D.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

Note: If you have never worked with  the  Matrix  Generator  before,  please  have  a  look at  the  tutorial  to  »The  First

Patch

We will now patch 100 LEDWalker LW-RGBVT100-D3216 tubes.

1. Start MADRIX and press the F2 key. The Matrix Generator will be opened.  
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2. Set up the following settings:

Protocol: Should be DMX

Product: Change it to LEDWalker DMX Vertical Tube - LW-RGBVT100-3216 48 Ch Mode 

Rotation: Should be Original

Count: We want to have 10 tubes side by side and 10 in a row. Therefore, set X to 10, Y to 1, and Z to 10 

Offset: Leave the default setting. 

Start Corner: Top Left 

Main Orientation: Vertical 

Snake Mode: Disabled

Z-Order: Front To Back 

Z-Snake Mode: Flip H and Flip V are disabled

DMX Start Channel: 1 

DMX Start Universe: 1 



[Part A] Configuration

//175www.madrix.com

MADRIX 3 Tutorials Version 1.9

Click OK
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3. You can see the following Preview in MADRIX:

That is no 3D Preview, yet. To change the Preview to 3D, perform a click with the right mouse  button on one

of the Previews and select 3D Mode in the pop-up menu.

 



[Part A] Configuration

//177www.madrix.com

MADRIX 3 Tutorials Version 1.9

4. To see the patched matrix better (and in 3D), change the color of the SCE Color Effect.

Navigation in the Preview is very easy. Use the mouse wheel to zoom in and zoom out or hold the left mouse

button down and move the mouse to turn the matrix within the Preview. 

Congratulations! You have created a 3D Patch and changed the view to 3D in MADRIX.
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1.24 Creating A Complex 3D Patch Using The Patch Editor

This tutorial shows you how to create a 3D Patch with different fixtures.

Date: 09/2014

MADRIX Version: 3.3 (Created with)

Note: It is useful to read the tutorial »Creating A Patch With Different Fixtures beforehand. 

We want create a patch with one Eurolite  -  LSD soft display, several of the Litecraft -  PowerBars, and several of

the Ehrgeiz - FS-60 fixtures.

1.  Start MADRIX and go to Preferences > Patch Editor or press F3. 

2. Create a new, empty patch. To do so, click New on the toolbar and confirm the next dialog. 
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3. Now change the size of the patch. Click Matrix Size and set the values to: 

Size X: 20

Size Y: 20 

Size Z: 10

Confirm with OK

In this way, we have changed the patch size to 20 pixels in X and Y with 10 levels in Z. 
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4.  Right now, you can see only one Z-Level. If you want to navigate through the layers, you have to change the

index number of the First Z control. 
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5. In  the  following  steps,  we  want  to  patch  some  fixtures.  We  will  start  with  adding  several  Litecraft  -

PowerBars.

Click Add and change the settings as shown in the following picture:

Confirm with Add

Click Close in order to close the Add Fixtures window. You should see 2 PowerBar fixtures in the middle of the

first row of your patch. If you navigate through the Z-Levels, you can see that on each of the 10 levels these 2

fixtures are placed in the middle of the first row. 
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6. Click Add again. Now, we want to add the Eurolite  -  LSD DVI fixture. Please change the settings as shown in

the following picture:

 

Click Add
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7. We will continue to add fixtures. In  this  step,  we  will  add  several  Ehrgeiz  -  FS-60.  Change  the  settings  as

shown in the following picture:

Click Add
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8.  In this step, we are going to add the last fixtures of this tutorial. We want to patch Ehrgeiz -  FS-60 fixtures

again. But this time, we want to place only 2 in the middle of Z-Level 10. Change the settings as shown in the

following picture:

Click Add and Close 
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9. Close the Patch window and the Preview in MADRIX should now look like this:

If you do not see a 3D view  in  MADRIX,  perform  a  click  with  the  right  mouse  button on  the  Preview  and

change the mode to 3D Mode

Congratulations! You have created a more complex 3D patch including different fixtures.



B//PART 
Effects
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2 Effects

2.1 Dropped Equalizer

In this tutorial, you will learn how you can create a dropped equalizer effect in MADRIX. 

Date: 09/2014

MADRIX Version: 3.3 (Created with)

Requirements: For this tutorial you will need audio input into MADRIX.

0. Before we start, make sure that you are receiving audio in MADRIX. Start  your  audio  and  check the  input  in

MADRIX with the help of the Audio section in the middle of the user  interface  of  MADRIX.  The  Audio  button

should be green and the level meter should show an amplitude.
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1. Select a free Storage Place (in this example it is Storage 1, Place 1). Then, choose the  S2L EQ /  Spectrum

effect via the drop-down list in the upper left corner of the Effect Area. 
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2. We want to change the colors. Click the Colors button.

A new window, the Gradient, will be opened. Now, we can change the colors. 

To  select  a  color,  please  click  on  the  very  small  square  above  the  color  gradient.  Change  the  color  by

changing the values for Red, Green, and Blue. 

Or click and hold the left mouse button on the color field in the upper left corner to choose your color.

If you want to add a new color, please click with the left mouse button on the gradient.

If  you  want  to  delete  a  color,  please  click  with  the  left  mouse  button  on  the  little  cross  below  the  color

gradient.

We want to change the first color to blue. To do so, change the values of the color fields to:  Red = 0, Green

= 0, Blue = 255. 

Then, change the color of the second color to: Red = 0, Green = 167, and Blue = 255. 

We want to change the third color to yellow: Red = 255, Green = 255, Blue = 0.

Now,  change  the  position  of  the  second  color:  Click  on  the  small  box above  the  gradient  and  hold  the  left

mouse button down. Then, move the mouse to move it to position 0.30.
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Click Close to close the window.

3. Perform a right mouse  click on the Layer tab  (labeled  EQ  /  Spectrum)  on  the  bottom  left  side  and  select

Duplicate. A new Layer with the same Effect settings will be added.

Note: The new Layer will be inserted on the right side of the currently selected Layer. That means the effect of

the new Layer is above the other effect and its Layer. 
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4.  Now, please select the left Layer again.
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5. Click Colors again. 

This time, change the colors to: 

First color: Red = 0, Green = 0, Blue = 255

Second color: Red = 0, Green = 0, Blue = 0

Third color: Red = 0, Green = 0, Blue = 0
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The position of the second should be 0.15 

Click Close

6. Adjust the following effect settings:

Drop: 5 

The Drop value defines how fast displayed frequencies drop to make room for new ones.

Fade: 2000 

The Fade value defines how fast the bars fade out.

Amplify: 50

The Amplify function defines that the input signal will be displayed more intensely. You can change the value

by clicking the AMP button and holding down the left mouse button while choosing the right value. 
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7. The result will look similar to this:

Congratulations! You have created a dropped Equalizer.

2.2 Working With Layers

In this tutorial, you will learn how you can work with different Layers.

Date: 10/2013

MADRIX Version: 3.0 (Created with)

Requirements: Please make sure that MADRIX receives audio input.

1. Select a free Storage Place. In this example it is Storage 1 and Place 1.
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2. Now, choose and select SCE Metaballs from the drop-down list of effects. 
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3. Click the Layer button in the middle at the bottom and choose New

A new Layer will be added and you should see that Preview Left  is  black now,  where  you  just  saw  the  SCE

Metaballs Effect. 

Note: Every time you add a new Layer, this Layer will be inserted with the default effect next to the currently

selected Layer. SCE Color with a black color is this default effect.
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4.  Change the effect of the newly inserted Layer to S2L EQ / Spectrum 
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5. Now, have a closer look at the order  of  the  effects.  The  desired  order  should  look like  shown the  following

picture. SCE Metaballs can be  seen  in  the  background  and  S2L EQ  /  Spectrum  is  shown in  the  foreground,

above  any  Metaball.  The  order  of  the  Layers  determines  this  outcome:  SCE  Metaballs  and  its  Layer  are

positioned to the left. The Layer of S2L EQ / Spectrum is positioned next to it on the right-hand side.

Note: In general you can say that effects/Layers positioned to the right, are placed above other Layers.
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6. Now, we want to change the order of the Layers. Therefore, select the Layer EQ / Spectrum  and click on the

arrow showns on the left side of the label.

 

As a result, you can see that this Layers has been moved on step to the left.
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7. Have a second look at Preview Left. Now, the equalizer effect is in the background and the Metaballs are shown

in the foreground. 

Exercise: Create an effect with more than two Layers and choose a different effect for each Layer. Change the

order of the Layers and monitor the different results. 

8. You can change also the name of a Layer.

Perform a double-click with the left mouse button on the Layer tab and its label. The  Layer Name window will

be opened. Now, you can enter any name. Press OK to confirm the change. 
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Congratulations! You have learned how to work with Layers in MADRIX.  

2.3 The Link Button

This tutorial shows you how you can work with the Link button in MADRIX. 

Date: 10/2013

MADRIX Version: 3.0 (Created with)

The Link button is useful to create new lighting effects by using several Layers. 

1. Please select a free Storage Place. In this example it is Storage 1 and Place 1. 
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2. Select the SCE Ticker / Scrolling Text effect. 
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3. Now, add a new Layer. To do so, click the Layer button and select New

A new Layer will be inserted with the default effect SCE Color and black color.

Note:  Your first effect  is  currently  in  the  background.  A  newly  inserted  Layer  will  always  be  above  at  first,

because it is inserted to the right of the current Layer.
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4. Change SCE Color to SCE Gradient for the second Layer. 
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5. Change the direction of the Gradient to right
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6. Now, activate the Link button on the Gradient Layer, which is the second Layer. 

You can see that the right Layer will be linked to the Layer  left  of  it.  In  this  example,  SCE  Gradient will  be

linked to SCE Ticker / Scrolling Text. The result is a colorful, scrolling text as shown in the following picture. 

 



[Part B] Effects

//207www.madrix.com

MADRIX 3 Tutorials Version 1.9

7. As an advanced user, you might say: "Mix Mode Mask produces the same result!". That  is  correct  if  you  are

only using two Layers.

In this tutorial, we will add another Layer to see the difference between Mix Mode Mask and Link Mode when

using more than two Layers.

Please add a new Layer as shown in Step 3. 
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8. We have to change the order of the Layers. The newly inserted Layer should be in the background. That means

that the "Layer" must be positioned on the very left of the three Layers. Hence, select the newly inserted Layer

and click the arrow shown next to the label Color. The Layer will be moved to the second position. Click on the

 arrow again and the Layer will be moved to the first position on the left.
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9. Change  SCE Color of the first Layer to SCE Wave / Radial
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10. Change the color to Red = 125, Green = 125, Blue = 125

11. You should be able to see a colored text and a gray radial in the background on your Preview Left.
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12. In this step, we want to see the difference between Mix Mode Mask and Link Mode.

First, select Layer 3 (Gradient). Second, deactivate the Link button (the button should  be  gray now).  Third,

click on Normal to choose a different Mix Mode. Select Mix Mode Mask.

Now, you can see a different result compared to Step 11. Mix Mode Mask causes all Layers behind this Layer to

be colored. 
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Congratulations! You have learned how you can work with the Link button.  

2.4 Solo Mode And Blind Mode For Layers

In this tutorial, you will learn how you can work with the Solo (S) and Blind (B) button. The functionality is very helpful

for creating new effects and to see how each Layer of the created effect works. 

Date: 10/2013

MADRIX Version: 3.0 (Created with)

1. Select a free Storage Place. In this example, we have selected Storage 1 and Place 1. 
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2. Choose and select SCE Wave / Radial from the drop-down list of effects. 

3. Click on the Layer button and choose New. A second Layer will be created automatically.
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4. Select the effect SCE Graph for the new Layer.

5. In the Preview of MADRIX, you can now see a white wave with a colorful graph in the foreground as shown in

the following picture. 
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6. Please  select  the  first  Layer  again  (with  its  label  Wave  /  Radial).  Click  on  the  Blind  button  B  (the  button

should illuminated in red now). As a result, you will only see the SCE Graph effect. 

 

Note: If you are only using 2 Layers, activating Blind Mode on the Wave / Radial Layer is equal to an activated

Solo Mode on the Graph Layer. 
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7. Click the Blind button B again. In this way, you will disable Blind Mode again and you should be able to see both

the Radial and the Graph.

Click the Solo button S (the button should illuminated in green) and you will only see the Radial. 

8. Here are further tips when working with Blind Mode and Solo Mode:

Note: If you have selected Blind Mode and Solo Mode on the same Layer, you will see the Layer in Solo Mode.

That means the priority of Solo Mode is higher.

Note: If you work with Mix Modes and Solo Mode on a Layer, you will see the effect without the Mix Mode. 

Congratulations! You can now create effects with the advantage of using the Blind Mode and Solo Mode. 
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2.5 Using Video Files And Movie Content

In this tutorial, you will learn how you can import video content into MADRIX. 

Date: 10/2013

MADRIX Version: 3.0 (Created with)

Requirements: Make sure to save a video file on your hard disk beforehand.

1. Select an empty Storage Place. In this example it is Storage 1 and Place 1. 

2. Choose and select SCE Video from the drop-down list of effects.
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3. We want to load a video file from the hard disk, such as a VJ loop. To do so, click the Folder button. 

A new window will be opened, choose the correct directory on your hard disk and select the video file. Confirm

with Open and MADRIX will load and start the movie.

Note:  By default,  AS is  activated  (Autostart).  That  means,  MADRIX  will  automatically  start  to  play  back the

video file once loaded. 

Note:  Do  not  move  or  delete  the  video  content  from  your  hard  disk,  when  it  used  in  MADRIX.  Otherwise,

MADRIX will not be able to find the movie. 
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4. You can change some settings:  

BPM:  The  BPM  value  defines  the  speed  of  the  animation.  You  can  add  an  animation  by  changing  the

direction, for example.

Position: You can set the position of the video in the X, Y, and Z directions in the patched virtual LED matrix. 

Playback Rate: The default setting is 1. That is the original speed of the movie. You can change the value

between 0 and 2. For example, a speed value of 0.5 means the video will be played  back with  half  of  the

original speed. 

Extrude: Here you can set how many Z-levels should display the video.

DI: You can activate the Deinterlace Mode. It is often useful if you use digital cameras, digital broadcasting,

or  digital  filming  which  are  often  done  via  interlacing.  In  order  to  get  an  undisturbed  picture,  proper

deinterlacing is necessary. 

Start: You can set a specific position at which the video starts playing. 

End: You can set a specific position at which the video stops playing. 

Loop: Here you  can  choose  between  Normal (the  video  stops  playing  after  it  reaches  the  end  position),

Loop (the video is played in endless repetition), Loop backward-forward (when the video reaches the start

or end position, it changes the playback direction and continues playback).

AS: That means Autostart. The video will be automatically started after selecting the Storage Place. 
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Congratulations! You have just learned to import and control videos in MADRIX. 
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2.6 Capturing With A Blackmagic Intensity Pro 4K

In this tutorial, you will learn how you can receive a video stream in MADRIX with the help of a Blackmagic Intensity

Pro 4K capture card.

Date: 11/2015

MADRIX Version: 3.4 (Created with)

Blackmagic Desktop Video Utility: 10.4.2 (Created with)
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1. Open the Blackmagic Desktop Video Utility software. In that application, you will find the information if the

Blackmagic Intensity Pro 4K  is receiving a video input stream and also the resolution of this input. 

Please make sure that the Blackmagic Intensity Pro 4K is receiving a video stream. In our example, the card is

receiving a video stream with 1080i and 60 FPS over HDMI. 

Note: The details about the resolution of the video input stream are necessary for the settings in MADRIX.
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2. Now, start  the  MADRIX  Software,  select  a  free  Storage  Place,  and  choose  the  SCE  Capture  effect.  In  this

example, we have selected Storage 1 and Place 1 (S1 P1).
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3. Click the Open button to open the Capture Device Selection. 
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4. In the Capture Device Selection, select the Blackmagic WDM Capture device and confirm with OK.
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5. Now, the Blackmagic WDM Capture driver has been selected and we have to change its settings. Therefore,

please click on the Configuration button. 



[Part B] Effects

//228www.madrix.com

MADRIX 3 Tutorials Version 1.9

6. The  SourceFilter Properties  window  opens.  Please  go  to  the  Video  Format tab  and  enable  the  Override

Video Mode checkbox. Now, we have to change the Display Mode as well ass the Pixel Format. The Display

Mode refers to the resolution and frame rate of the inputted video stream and we have to set it to the same

value  as  displayed  in  the  Blackmagic  Desktop  Video  Utility  software  (see  Step  1).  In  this  example,  we

receive a 1080i stream with 60 FPS. The  Pixel Format refers to the color mode of the video input stream. In

this  example,  it  is  a  10  bit  RGB input.  After  you  have  chosen  the  settings  according  to  your  inputted  video

stream, click OK.
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7. Now, you have to select another Storage Place in MADRIX and go back to the Storage Place which contains the

SCE Capture effect of the Blackmagic Intensity Pro 4K.

Congratulations! You can now work with the video input stream of a Blackmagic Intensity 4K capture card. 
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2.7 Using Images And Pictures

This tutorial shows you how you can create effects using pictures. 

Date: 10/2013

MADRIX Version: 3.0 (Created with)

Note: MADRIX supports the following  formats:  BMP,  GIF,  JPEG,  PNG,  TIF,  TIFF,  and  the  MADRIX  Image  Table  file

type. 

1. Select an empty Storage Place. In this example it is Storage 1 and Place 1. 

2. Choose and select the SCE Image from the drop-down list of effects.
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3. There are several possibilities to add images to the effect. In this example, we want to use the Image Table.

Click the  Image Table button.  

A new window, the Image Table, will be opened.
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4. Now, we have to add images to the table. Therefore, click the Add Image(s) button +.

Note: To save performance and resources, MADRIX automatically resizes images to the size of the virtual LED

matrix before importing them into the software when Optimize is activated. 

5. Choose  the  correct  directory  on  your  hard  disk  and  select  the  images  you  want  to  use  in  MADRIX.  In  this

example, we will select multiple files, but you can also select only one image. Confirm with Open 
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6. If you have added more than one image, MADRIX creates an automatic transition between images. But you can

still  individually  set  the  Duration  and  Fade  Time  for  each  image.  To  change  these  settings,  select  the

respective image and enter your desired values for Duration and Fade Time. In this example, we will set  the

same Duration and Fade Time for all images. Press Crtl + A on your keyboard and then change the Duration

to 0.2 and Fade Time to 0.1
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7. You can also change the order of images. Select one or more images and then click the  Arrow Up to move the

images up in the list or Arrow Down to move the images down in the list. 
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8. Click Close to close the Image Table.

Now, you can change some settings on the regular user interface: 

Filter: You can add a Color Filter. This filter works in multiply mode (additive  mode).  That  means  that  the

colors of the effect are multiplied with the colors of the filter. 

BPM:  The  BPM  value  defines  the  speed  of  the  animation.  You  can  add  an  animation  by  changing  the

direction, for example.

Position: You can change the position of the  images  in  the  patched  virtual  LED matrix  in  the  X,  Y,  and  Z

direction. 

Playback Speed: The default setting is 1. That is the original speed of the animation. You can change the

value between 0 and 50. This mainly influences the Duration and Fade Time of the Image Table.

Extrude: If you have  created  a  3D patch,  the  images  will  be  extruded  across  the  Z-levels  to  the  desired

value in percent.

GS - Grayscale: If you enable it, the images will be displayed in monochrome colors.  

RGB To RGBW: It is important if you are using RGBW fixtures and if you want to use the white channel. 

Matrix (Stretch and Aspect Ratio): If it is enabled, MADRIX resizes the image size to the matrix size.

Tile: If it is enabled, MADRIX duplicates the images on the matrix. This option takes only effect if the image is

smaller than the matrix size.
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Note: If you save the MADRIX Setup File, MADRIX saves the loaded images  including  the  imported  images.  Hence,

MADRIX can display the effect right away.

Congratulations! You have created an image effect in MADRIX.  
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2.8 Mix Modes

This tutorial shows you how the different Mix Modes work.

Date: 10/2013

MADRIX Version: 3.0 (Created with)

Note: Please read the tutorial »Working With Layers first.
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1. Select a free Storage Place and insert an additional, second Layer. The effect of the first Layer should be SCE

Wave/ Radial and its color should be yellow.

The effect of the second Layer should be SCE Metaballs. The colors of  the  Color  Table  are  Turquoise  and

Pink. Leave the default values of all other settings.
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2. To work with the Mix Modes, you have to select  the  Layer  that  is  in  the  foreground  (i.e.  the  Layer  which  is

located to the right). In this example, it is the Layer with the Metaballs label. The default Mix Mode is Normal

and you can change it if you click on Normal on top of the Effect Section.
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3. A popup menu with all available Mix Modes appears. You can change the mode by selecting a new mode on the

list. The label of the button then shows you which Mix Mode is currently active.
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4. We now want to check which effects are created when using different Mix Modes.

Darken: Compares the Red, Green, and Blue channel of each Layer and only uses the darkest color value for

each color channel per pixel.

Multiply: Multiplies the color values of each pixel of Layer 2 with the color values of each pixel of Layer 1.

Color Burn: Layer 1 will be darkened by Layer 2.
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Linear Burn: The color values of both Layers will be added up. But when the result is lower than 255, the

values will be set to 0 (black).

Lighten: It compares both Layers and only uses the brightest color value for each color channel per pixel.
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Screen: Layer 2 and Layer 1 will be negatively multiplied and often brighten each other.

Color Dodge: The colors of Layer 1 are brightened by the colors of Layer 2. A black Layer 2 will not change

Layer 1, but a white Layer 2 will brighten every color channel of Layer 1.

Linear Dodge: Adds up the color values of both Layers.
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Overlay: The result depends on the underlying Layer. If areas  of  Layer  1  are  darker  than  50% Gray,  the

color values will be multiplied with the color values of Layer 2. If areas are brighter than 50% Gray, the color

values will be negatively multiplied with the color values of Layer 2.

Soft Light: Layer 2 will modulate the color values of Layer 1 and create soft mixtures in areas of highlights

and shadows.
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Hard Light: If Layer 2 is brighter than 50% Gray, Layer 1 will be brightened. If Layer 2 is darker than 50 %

Gray, Layer 1 will be darkened.

Vivid Light: Will mainly increase the contrast of highlights and shadows.
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Linear Light: Increases the contrast.

Pin Light: Is like a combination of Darken and Lighten.

Hard Mix: Only uses the six primary colors red, green, blue, yellow, cyan, magenta, or black, or white. Color

channels will be mixed and either be set to 0 or 255.
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Difference: Will calculate the difference between the color values for each pixel.

Exclusion: Bright color areas will invert the color values of the corresponding area of the other Layer. White

areas will completely invert the color. Very dark areas (black) will change nothing on the other Layer.
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AND: The color values of each Layer will be converted into 8-bit binary form. AND will only result in 1, when

both bits have a value of 1.

OR: The  color  values  of  each  Layer  will  be  converted  into  8-bit  binary  form.  OR  will  result  in  1,  when

minimum one bit have a value of 1.

XOR: The color values of each Layer will be converted into 8-bit binary form. XOR will result in 1, when both

bits are not identical.
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NAND: The color values of each Layer will be converted into 8-bit binary form. NAND will result in 1, except

when both bits have a value of 1. 

NOR: The color values of each Layer will be converted into 8-bit binary form. NOR will result in 1, when both

bits have a value of 0. 
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Mask:  It  will  merge  the  Layers  together.  The  result  will  only  be  visible  on  areas  where  the  two  Layers

overlap. The rest will be set to black. 

Congratulations! You now know the different Mix Modes.   

2.9 Mapping - Tile, Repeat, And Rotate

In this tutorial, you will learn how you can create a repeated and rotated effect with advanced mapping in MADRIX. 

Date: 10/2014

MADRIX Version: 3.3 (Created with)

Note: The Map Effect window is useful for creating various variations of an effect. For more information, please read

the tutorials »Map - Effects For Fixtures With Space Inbetween and »Map - Mirroring

1. Select an empty Storage Place. In this example, it is Storage 1 and Place 1. 
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2. Now, select SCE Radial / Wave from the drop-down list of effects.
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3. Change BPM to 1000 and Length to 25
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4. Click Map button on top of the Effect Section

5. A new window, the Map Settings, will be opened. 
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6. Now, please click the Preset button in the Tiling section on the right-hand side and select Top Left from the

drop-down list.

Have a look at the Previews of MADRIX. You can see that  the  SCE  Radial effect  is  located  in  the  upper  left

corner and the rest of the LED matrix is black. 
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7.  Go back to the Map Settings window. Change the Tile Mode to Repeat.

Take a look at the Previews again. You can see the SCE Radial effect of the upper left corner is now repeated

on the whole matrix. 
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8. We want to go ahead and rotate the effect around the Z-Axis. Go to the Rotate section of the Map Settings

window and change Z to 38. You can do this by simply writing 38 in the text box or by moving the slider to the

right side.

9.  If you press the Animation button at the right-hand side of the slider, the effect will be rotated continuously.

Move the slider again to change the speed. 
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10. Have another look at the Previews and you can see how the SCE Radial / Wave effect has changed again. 

Congratulations! You have learned how you can repeat and rotate effects. 
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2.10 Mapping - Effects For Fixtures With Space Inbetween

In this tutorial, you will learn how you can create effects and map them to only one fixture of your LED matrix and how

you can handle space between your fixtures. 

Date: 10/2014

MADRIX Version: 3.3 (Created with)

Note: For this tutorial we are going to use the patch we created in this tutorial »Creating A Patch With Space  Between

Fixtures

It is also useful to read the tutorial »Working With Layers beforehand.
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1. Please open the saved patch of the tutorial »Creating A Patch With Space Between Fixtures

To do so, first press the F3 key on your keyboard or go to  Preferences > Patch Editor and the Patch Editor

window will be opened. 
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2. Click Open on the toolbar and select the saved patch file on your computer's harddisk. 

3. The Patch we have just loaded into MADRIX should look like this:

Close the Patch Editor.
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4. Change the color of the default effect SCE Color from black to red. This will help you see the patched fixtures

better in the Previews of MADRIX.

Note: The darker red areas in the Previews are the areas where no fixtures are located. The bright red areas

represent the patched fixtures. 
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5. We want to change SCE Color to SCE Color Scroll. To do so, select SCE Color Scroll from the drop-down list

of effects.

We want to continue by removing several colors from the Color Table. Click on Colors

Please delete all colors, except Red, Green, Blue, and Yellow. 

Note: You can delete a color by selecting the color first and then pressing the - button.
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6. We want to change the location of the effect on the LED matrix now. Please click the Map button in the Effect

Section. 
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7. The Map Settings window will be opened. First, we want to change the range of the values from percentage/

relative to pixel/absolute. Click the Pixel button at the bottom.

8. Second, we want to change the size and position of the SCE Color Scroll effect. As you know, every fixture of

the Patch has 4 pixels and there is space between each fixture.

We want to achieve the following pattern: Only the first two rows of the fixtures should display the SCE Color

Scroll effect and every pixel of the fixtures should display the same colors at the same time.  It  will  be  like  a

repetition of the first fixture.

To do so, change the following settings:

Note: Please use the slider to change the values and while doing so have a look at the Previews and graphical

mapping overview to see how the changes affect the result. 

1] In the Mapping section: Leave Size X at 31 and change Size Y to 7

2] In the Tiling section: Change Size X to 4 and Size Y to 1  

3] In the Tiling section: Change the Tile Mode to Repeat 

4] In the Tiling section: Change Offset X to 5 and Offset Y to 3
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Close the Map Effect window. Then, have a look at the Preview of MADRIX. You should see that only fixtures

of the first two rows display the SCE Color Scroll effect in repeat mode. 
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9. Add a new Layer and change the order of the two Layers. SCE Color Scroll should be on the right side, while

the new Layer should be on the left side. Change the color of the newly inserted Layer for SCE Color to Red  
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10. We want to change the mapping of this new SCE Color effect to the first  fixture  in  the  third  row.  Select  the

Layer Color and click the Map button again. 

11. In the Mapping section change Position Y to 8, Size X to 4, and Size Y to 1. 

Then, close the Map Effect window. 
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12. In this step, change the label of the SCE Color  Layer  from  Color to  Red.  Therefore,  perform  a  double-click

with the left mouse button on the label Color and now you can rename the Layer to Red

13. In  this  step  we  want  to  duplicate  Layer Red.  Select  the  Layer  and  perform  a  click  with  the  right  mouse

button on the Layer itself and choose Duplicate from the context menu. The duplicated Layer will be inserted

right beside the selected one.

Note: If you duplicate a Layer, you duplicate all information of this Layer. This includes the settings of the Map

Effect window. 
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14. Change the label of the new Layer to Green, change the color of its SCE Color effect to green, and change

the mapping in the Mapping section  for  Position  X  to  9.  We  will  not  change  Positon  Y,  Size  X,  or  Size  Y,

because the size of the fixture is the same and Position Y has not changed as well. 

15. Now, duplicate Layer Green. Change its label to Blue, change the color of its SCE Color effect to blue, and

change the mapping in the Map section for Position X to 18
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16. Duplicate  Layer Blue. Change its  label  to  Yellow,  change  the  color  of  its  SCE  Color effect  to  yellow,  and

change the mapping in the Mappingf section for Position X to 27

Have a look at the Previews and you can see that each fixture of the third row has now its own  color  effect.

Each fixture of the third row has received its own effect and mapping.

17. Finally, we want to map another  SCE Color  Scroll effect  to  the  fourth  row  of  fixtures  (but  this  time  without

repetition and the color scroll should be continuous). 

Duplicate the Layer Color Scroll and change its label to Color Scroll 1.  Afterwards,  open  the  Map  Settings

window. Change the following settings:

1] In the Tiling section: Change the Tile Mode to None, Offset X to 0, and Offset Y to 0

2] In the Tiling section: Change Size X to 31 and Size Y to 1

3] In the Mapping section: Change Position Y to 12 and Size Y to 1
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18. Close the Map Settings window. Your MADRIX  Previews should now display the following effects: 

Note:  In the last row of the Preview you can see  some  darker  and  some  brighter  areas.  Only  at  the  bright

areas there are fixtures patched. But for this effect (SCE Color Scroll) it does not matter if there is a fixture or

not at every position. The effect will be replayed in the mapping area. The respective fixture fetches the color

information at the position of the Patch. 
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Congratulations! You have created an effect with different Layers for different fixtures. 

2.11 Mapping - Mirroring

This tutorial shows you how you can use mirroring to create a new effect. 

Date: 10/2014

MADRIX Version: 3.3 (Created with)

Requirements: For this tutorial MADRIX needs to receive an audio input signal.

Note: It is also useful to read the tutorial »Working With Layers beforehand.

1. Select an empty Storage Place. In this example we will choose Storage 1 and Place 1.
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2.  Select the effect S2L EQ / Spectrum from the drop-down list of effects.

3. Click Map in the Effect Section of the user interface and the Map Settings window will be opened.
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4. In the Tiling section click on the Preset button and choose Top from the list. 

Afterwards, change the Tile Mode to Mirror V 
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Change the value of Offset Y to 3

 

5. Close the Map Effect window.

The Preview should now look similar to this picture: 

6. So far, we have created a mirrored Equalizer effect. In addition, we want to change the mirrored part further.

Therefore, please add a new Layer: Click Layer > New

Note: After adding the new Layer, the Preview of MADRIX will be black. Do not worry about it. 
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7. Please do not change any effect parameters of the newly inserted Layer. The Layer should remain black. 

But please select the newly created Layer Color and click Map  again.  In  the  Mapping  section,  click  on  the

Preset button and change it to Bottom 

Close the Map Settings window.

8. Change the Opacity of the Layer Color to 170. You can control the Opacity with the horizontal slider on top of

the Effect Section 
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9.  Your effect should now look like the following picture in the MADRIX Preview. 

Note:  You  can  change  the  colors  of  the  Equalizer  and  the  mirrored  Equalizer  will  change  the  colors

automatically, too. 

Congratulations! You have just created a mirrored effect. 
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2.12 Mapping - Using Fixture Groups For Mapping

In this tutorial, you will learn how you can use Fixture Groups to map effects in MADRIX.

Date: 07/2015

MADRIX Version: 3.4 (Created with)

Note: For this tutorial, we are going to use the Patch and fixture groups created in the tutorial »Working With Groups.

It is useful to read this tutorial first.
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1. Start MADRIX and select an empty Storage Place. In the screenshot below, Storage Place S1 P1 is selected on

the left side.

Change the color of the SCE Color effect to Red. Then, click on the Map button.

The Map Settings window opens.

In the Mapping section, click on the Preset button. On the top of the  list  of  presets,  you  will  find  a  section

which contains all created fixture groups.

Note:  Your Patch needs to include fixture groups. Otherwise,  the  list  of  presets  will  not  include  any presets

based on such fixture groups. 
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2. We are now assigning this Layer (SCE Color with the color Red) to the first fixture group by selecting the preset

 Left in the preset list.

The Preset button has also been changed to Left, which helps you see which preset was chosen. 

Please  also  have  a  look at  the  MADRIX  Preview  Left and  you  will  see  that  the  effect  mapping  has  been

changed to cover only fixtures that are included in the fixture group Left
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3. Let us add a new Layer in MADRIX. We will change SCE Color to Yellow and set the Preset of the Mapping

section (in the Map Settings window) to the fixture group Middle

Note:  If you do not know how you  can  work with  Layers  in  MADRIX,  please  see  the  tutorial  »Working  With
Layers

Preview Left should now look like this:
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4. In the last step of this tutorial, we want to add another Layer, change SCE Color to Blue, and set the Preset

of the Mapping to fixture group Right

Congratulations! You have learned how you can use fixture groups for the mapping of an effect.
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2.13 Chaser - Changing Directions Automatically

In this tutorial, you will learn how you can automatically change the direction of a MADRIX Effect by using the Effect

Parameter Chaser.

Date: 06/2015

MADRIX Version: 3.4 (Created with)

1. Select an empty Storage Place. In this example, we will choose Storage Place S1 P1.

2.  Select the effect SCE Color Scroll from the drop-down list of effects.
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3. Please perform a click with the right mouse button on the Chaser button.

Then, choose Edit...
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4. A new window, the so-called Effect Parameter Chaser, opens with a blank Step list.
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5. Now, we want to add Steps to the list. 

Therefore, click on the + button in the Effect Parameter Chaser window to store the first Step. 

Note: Every effect setting will be stored in a Step. In this example, we are only going to change the Direction

of SCE Color Scroll. 

Second, change the direction to Bottom and click the + button again.
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Third, change the direction to Left and click the + button again in the Effect Parameter Chaser.

Fourth, we are changing the direction to Top and click the + button one more time.
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6. We have now added 4 Chaser Steps to the list. Every Step has a different direction.
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7. We are now changing the Wait Time for all Chaser Steps. 

Please select all Steps first. You can select all Steps in the list by pressing Ctrl+A or you select the first entry in

the list and press and hold the Shift key and select the last entry in the list. 

Perform a click with the right mouse button on the Wait Time column of one entry and change it to 3.
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8. We will now play back the created Chaser. 

Therefore, click the Play/Pause button and look at the Previews in MADRIX. You will see that every 3 seconds

the direction will be changed.

Congratulations!  You  have  learned  how  you  can  create  an  Effect  Parameter  Chaser  which  plays  the  effect  in

different directions. 
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2.14 Chaser - Changing A Slider Value Continuously

This  tutorial  shows  you  how  you  can  let  MADRIX  change  a  MADRIX  Effect  slider  continuously  by  using  the  Effect

Parameter Chaser with Fade Time.

Date: 07/2015

MADRIX Version: 3.4 (Created with)

1. Select an empty Storage Place. In this example, we are going to use Storage Place S1 P1.

2.  Select the effect SCE Wave / Radial from the drop-down list of effects.
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3. Please change the Shape to Helix by clicking on the Mode button that by default  says  Circle.  Choose  Helix

from the list.
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4. Change the Width value to 20

Now, we want to add the first Step to the Effect Parameter Chaser.

Perform a click with the right mouse button on the Effect Parameter Chaser button and click  Add Step with

the left mouse button. A Step will be added to the Chaser and the icon will change to blue.
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5. Now, change the value of the Width slider to 140

Again,  add  these  settings  as  a  new  Step  by choosing  Add  Step  from  the  Effect  Parameter  Chaser  context

menu.

6. We are now going to change a number of settings of the Effect Parameter Chaser.

First, we have to open the Effect Parameter Chaser  window.  Click  on  the  Effect  Parameter  Chaser button

with the right mouse button to call up the context menu and select Edit
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7. As a result, the Effect Parameter Chaser window opens. You can now see 2 Steps in the list with a Fade Time

of 0.00 seconds and a Wait Time of 1.00 seconds. Please select the both Steps via the Ctrl+A keys on your

keyboard.

8. We are going to change both, Fade Time and Wait Time.

To  change  the  Fade  Time,  perform  a  right  mouse  click  on  one  of  the  entries  of  the  Fade  Time  column.

Change the Fade Time to 3.00 and press Enter

To  change  the  Wait  Time,  perform  a  right  mouse  click  on  one  of  the  entries  of  the  Wait  Time  column.

Change the Wait Time to 0.00 and press Enter
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9. Click the Play/Pause button to start the Effect Parameter Chaser. You can see the result immediately in the

MADRIX Preview.

Congratulations! You have learned how you can create an Effect Parameter Chaser which continuously changes the

values of a slider. 

2.15 Chaser - Changing Map Settings

In this tutorial, you will learn how you can create an Effect Parameter  Chaser  which  does  not  change  settings  of  a

MADRIX Effect but the Map Settings of a Layer.

Date: 07/2015

MADRIX Version: 3.4 (Created with)

1. Select an empty Storage Place. In this example, we have Storage Place S1 P1 selected.
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2.  Select SCE Graph from the drop-down list of effects.
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3. Click with the left mouse button on the Map button.

The Map Settings window opens. In this window, please select Top as Preset in the Mapping section. 
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4. Switch back to the main user interface and perform a right mouse click on the Chaser button and select Edit

The Effect Parameter Chaser will open. Please open the Parameters selection. To do so, click on the button

which is called Effect Settings by default.

First, select None

Then, please select Map Settings and confirm with OK
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We have now prepared the Effect Parameter Chaser to store Steps that include Map Settings.

5. Click the + button in order to add the first Step to the Effect Parameter Chaser

The  new  Step  has  been  added  to  the  list.  For  easier  reference,  we  are  changing  the  Description  in  this

example to Top

To change the description of a Step, select the Step in the list first and perform a left mouse double-click on

the description field of the selected row.
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6. We are changing the Map Settings  again.  In  this  example,  we  are  now  choosing  Bottom  as  Preset in  the

Mapping section.

7. We are adding these settings as a second Step to the Effect Parameter Chaser List by clicking the + button.

We also want to change the Description for this list entry. We are changing it to Bottom, for example.
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8. At last, let us change the Fade Time and Wait Time of the Chaser. 

To change the Fade Time and/or Wait Time of all entries in the Effect Parameter Chaser list, select all entries

first by pressing Ctrl+A on your keyboard. Then, perform a click with the right mouse  button  on  the  desired

entry and change the value. For this example, change the Fade Time to 2.00 and the Wait Time to 0.00

Click the Play/Pause button and the Effect Parameter Chaser starts.

Congratulations! You have learned how you can create an Effect Parameter Chaser only for Map Settings. 



C//PART 
Workflow
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3 Workflow

3.1 Exporting And Importing Storages

This tutorial shows how you can export a Storage of an existing  MADRIX  Setup  and  import  it  into  another,  already

existing Setup. In this way, you can bring a complete Storage over to another Setup.

Date: 08/2014

MADRIX Version: 3.2 (Created with)

Note: For this tutorial it is important that you have two Setup files to work with. 
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1. Start MADRIX and open an existing Setup. 
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2. We want to export Storage 2 from the Right, including all effects we have saved there. Go to File  > Export >

Storage > Storage  Right and save the Storage to a desired folder. Remember where you saved it and how

you named it.
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3. Open another, existing MADRIX Setup file.
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4. Choose a free Storage: Our sample Setup only occupies Storage 1 and 2. Therefore, we change Storage  Left

to 3.
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5. In  order  to  import  the  Storage,  go  to  File  >  Import  >  Storage  >  Storage  Left  and  choose  the  MADRIX

Storage file you have exported in step 2.
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6. Storage 3 now contains all the effects you have just imported.

 

Congratulations! You have transferred a Storage from one Setup to a different Setup. 
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3.2 Exporting And Importing Storage Places

In this tutorial you will learn how you can export a Storage Place (that means one effect you have created) and import

it into a different Setup file. This workflow could be  useful,  for  example,  when  creating  a  new  effect  at  home  and

implementing it into an existing show at work. 

Date: 08/2014

MADRIX Version: 3.2 (Created with)

Note: For this tutorial it is important that you have an existing Setup file to work with. 
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1. Start MADRIX and create a new effect. 

In this example, we have created an effect with 2 Layers on Storage Place S1 P1 on the Left. SCE Fluid can be

found on Layer 1. Layer 2 is set to SCE Simple Shape.

Layer 2 has been further modified. For the effect, choose Ellipse Filled as shape and set the Position to X: 10,

 Y: 10 and the Size to  X: 80, Y: 80. Also, change the Mix Mode to Mask. Finally, click on Map and  set  Top

Left as well as Tile: Repeat in the Tile section.
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2. We now want to export the active Storage Place from Storage 1 (in this example it is S1 P1 activated on the

Left). Go to File > Export > Storage Place  > Storage  Place  Left... and choose a name and directory for this

file.

The default folder is the MADRIX3/storage_places folder which is located in your user documents folder.

Note: If you want to export an active Storage Place from the Right side, choose  Storage Place Right... instead

of Storage Place Left... 



[Part C] Workflow

//315www.madrix.com

MADRIX 3 Tutorials Version 1.9

3. Now, open an existing MADRIX Setup and select an  empty Storage  Place.  In  this  example,  we  are  selecting

Storage Place 33 on the Left.

Note: An empty Storage Place will be shown as a gray button. An occupied Storage Place is shown in blue, the

active one is green. If it is shown in red, the Storage Place is already selected on the other side, Left or Right. 
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4. Go to File > Import > Storage Place > Storage Place Left... and select the file you have exported in step 2. 



[Part C] Workflow

//317www.madrix.com

MADRIX 3 Tutorials Version 1.9

5. Now, you can see that the desired effect has been imported. 

Note: Do not forget to save your Setup to fully include the new Storage Place.

Congratulations! You have exported and imported a single Storage Place.
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3.3 Exporting / Importing V2.X Setups Into One V3.X Setup

In this tutorial you will learn how you can import one or more MADRIX 2 Setups into one MADRIX 3 Setup. 

Date: 08/2014

MADRIX Versions: 2.14e and 3.0 (Created with)

Note: For this tutorial it is important that you have saved two MADRIX V2.X Setup files beforehand. 

1. Open the first Setup in MADRIX 2.

Go to File  > Export > Export to MADRIX3 > Setup and choose a desired directory  and  file  name.  Confirm

with Save. 
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2. Now, open another MADRIX V2.X Setup and export this Setup as described in step 1, too. 

3. Please close MADRIX 2 and open MADRIX 3. 

Go to File > Open Setup and choose the first of the exported Setups. 
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4. MADRIX 3 can easily store more than only 2 Storages A and B. In order to create one MADRIX 3 Setup file out

of several MADRIX 2 Setups, we will export both Storages of a MADRIX 2 Setup. To do so, go to  File  > Export

> Storage > Storage Left. Choose a name and press Save.

Now export the right Storage of this Setup. Go to File > Export > Storage > Storage Right.
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5.  Go  to  File  >  Open  Setup... in  order  to  load  the  second,  exported  Setup.  The  first  two  Storages  will  be

occupied. Choose a free Storage, such as Storage 3 on the Left.
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6. To import a Storage to the currently selected Storage on the Left, go to File  > Import > Storage  > Storage

Left. Select the Storage file you have exported in step 3 which contains the effects of the left storage. 

Storage 3 now contains the imported set of effects.
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7. Please select Storage 4 on the left side and import the Storage file you have exported in step 3 which contains

the effects of the right storage. Repeat step 6 to import this file.
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8. Storage 1, Storage 2, Storage 3, and Storage 4 now all include imported Storages and in this way all effects of

the two MADRIX 2 Setups.

Congratulations! You can create a MADRIX 3 Setup that contains your MADRIX 2 Setups. 
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3.4 Controlling MADRIX Via Touch Screen

This tutorial shows you how to work with the integrated Touch Window. The Touch Window can be controlled with a

regular mouse or better if you own a touch screen monitor that allows touch input.

Date: 08/2014

MADRIX Version: 3.0 (Created with)

Note: It is useful to use an exisisting Setup that already includes effects.  

1. Start MADRIX and open an existing Setup or create a new one. 
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2. Click once on the 'MADRIX Logo'. You will find it above the Preview Output. 
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3. A new window will open and the view will be changed to the MADRIX touch view. 

Note: If you want to move this view to another connected display or monitor, please press the Tabulator key

on your keyboard. 
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4. How to select higher Storage Places:

If you want to change the Storage Place to a number higher than 32, you have to scroll down. A scroll button is

located on the left side and right side. 
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5. How to select a different Storage:

Click on the Storage selection button, located in the bottom left and right. 

A new pop-up window will be opened. Simply choose another Storage as needed. 
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6. How to change the Fade Time:

Press the button on the left next to FADE.

 

Change the value as needed by changing the slider position. 
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Note: When you are editing the Fade Time, you need to press x to close the slider again. Only then, the other

controls will be available to you again. The same is true, when pressing Filter or  CF in  order  to  change  the

filter color.
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Congratulations! You have learned to control MADRIX using the Touch Window. 



[Part C] Workflow

//336www.madrix.com

MADRIX 3 Tutorials Version 1.9

3.5 Changing The Storage Place View

In this tutorial you will learn how you can change the view of the Storage Places.

In MADRIX you have the possibility to change the view of the Storage Places between 1x1, 2x2, 4x4 and 8x8.

Date: 12/2014

MADRIX Version: 3.3 (Created with)

1. Start MADRIX and click the Storage Option button 
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2. Please select the 1x1 option in the popup menu

Now you will see the Storage Place buttons will be very lage and you can see the thumbnail on it.
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3. The  2x2 Storage  Place  view  shows  also  the  thumbnails  on  the  button.  The  Storage  Place  buttons  will  be

arranged in sections of 2 by 2 buttons.
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4. The 4x4 Storage Place  view  is  the  default  view  of  MADRIX.  The  Storage  Place  buttons  will  be  arranged  in

sections of 4 by 4 buttons. MADRIX will show the thumbnails when you will stay on a Storage Place for longer

then one second.

You also see the different background colors of the Storage Place buttons. 

A green background means this Storage Place is active at the moment

A blue background means on this Storage Place is an effect stored but it is not active.

A gray background means this Storage Place is empty.
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5. The 8x8 Storage Place view shows you very small buttons without numbers. The Storage Place buttons will be

arranged in sections of 8 by 8 buttons. 

Congratulations! You have learned how you can work with the different Storage Place views.
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3.6 The DMX Fader Tool

In this tutorial you will learn how you can control a DMX fixture, such as a fog  machine,  with  MADRIX  by using  the

DMX Fader Tool. This tool is also very useful to quickly test any DMX fixture.

Date: 08/2014

MADRIX Version: 3.2 (Created with)

1. Open MADRIX and go to Tools > DMX Fader Tool... or press the Ctrl+Alt+F on your keyboard. 



[Part C] Workflow

//342www.madrix.com

MADRIX 3 Tutorials Version 1.9

2. The DMX Fader Tool will be opened in a new window. 

3. To control a fader, you have to activate it first. Enable  On and the fader below will be activated.

Note: If you have activated a fader in the DMX Fader Tool, the value of the DMX Fader Tool will be control this

channel. That means you could not control, for instance, an RGB fixture using a  MADRIX  Effect  and  the  DMX

Fader Tool at the same time. If you try, the values of the DMX Fader Tool will win. 
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4. Continue with defining which Universe and Channel the fader should control. 

5. In  this  example,  the  DMX  channel  of  the  fog  machine  is  120  in  universe  2.  We  are  therefore  changing

Universe to 2 and Channel to 120 accordingly. 
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6. Move the slider and the fog machine will begin to fog. You can also enter any specific DMX value for Value.  

You can also click on Flash. As long as you press the button, the DMX value will  be  set  to  255.  Release  the

button and it will be set to 0 or your set Value again.

 

Congratulations!  You can now use the  DMX  Fader  Tool  to  your  advantage  to  control  certain  DMX  fixtures  or  for

testing purposes. 
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3.7 The DMX Watcher

Learn in this tutorial how to monitor input and output data using the DMX Watcher.

Date: 08/2014

MADRIX Version: 3.2 (Created with)

Note:  It  is  useful  to  read  the  tutorial  Remote  Control  Via  DMX-IN  first.  The  steps  to  connect  a  DMX  controller  to

MADRIX are the same and they will not be shown again in this tutorial. 

1. Start MADRIX and go to Tools > DMX Watcher... or press Ctrl+Alt+D on your keyboard. 
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2. The DMX Watcher window will be opened.

3. Here is a short overview over the provided controls:

1 Choose between Virtual OUT or Input and set up the DMX universe you wish to monitor. 

2 Change  the  channel  view  between  512  channels  or  1024  channels.  Note:  Virtual  OUT  must  be

activated.
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3 Change the presentation of values by selecting DMX (to show DMX values), %  (to  show  values  in

percent), HEX (to show hexadecimal values), or BAR (to show graphical bars).

4 Change the background of the data table.

5 Change  the  refresh  rate  to  1  Hz  (data  will  be  refreshed  once  per  second),  10  Hz  (data  will  be

refreshed ten times per second), 50 Hz (data will be refreshed fifty times per second). Or you can

freeze the data display by clicking the Freeze button.
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4. Monitoring data output:

Set up an SCE Color Scroll effect to generate DMX data. Change the view of the DMX Watcher to Virtual OUT.

You will now be able to see which DMX values will be sent to the connected hardware. 
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5. Monitoring data input:

If you want to check DMX input, please set up a DMX input device in MADRIX first (as explained in the Remote

Control Via DMX-IN tutorial). Change the DMX Watcher to Input and connect the DMX controller to the MADRIX

input device. If you send DMX data with your  connected  controller,  you  should  see  the  incoming  data  in  the

DMX Watcher.

Note: Values that changed recently, will be displayed in green for a few seconds. 

Congratulations! You have learned on how to monitor DMX data with MADRIX. 



[Part C] Workflow

//350www.madrix.com

MADRIX 3 Tutorials Version 1.9

3.8 Highlight Modes

This tutorial shows you how you can work with the different Highlight Modes in MADRIX. The software  provides  the

possibilities to highlight a complete DMX universe or individual DMX fixtures. This feature can prove useful to identify

DMX connections as well as specific fixtures in your LED installation. It is great for testing as well as  the  process  of

DMX addressing.

Date: 08/2014

MADRIX Version: 3.2 (Created with)

1. Start MADRIX.
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2. Highlighting a complete DMX universe:

Open the Device Manager by pressing F4 or go to Preferences > Device Manager... 

In the DMX Devices tab, you will find all the connected DMX devices. In this example, one MADRIX PLEXUS  is

connected via USB.

To highlight a DMX universe, please the select the desired DMX universe and click Highlight Device.

Note:  If you want to highlight more than one  DMX  universe,  please  press  and  hold  Ctrl and  select  all  DMX

universes in the Device Manager. Then, click Highlight Device.
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3. Highlighting a single DMX fixture:

In MADRIX, go to Preferences  >  Patch... and the Patch window will open.

Enable Highlight in the Patch window and then select a DMX fixture. Now, you will see that the selected fixture

glows white on the LED installation.

Note: If you want to highlight more than one fixture, press and hold Ctrl and select all desired fixtures. Make

sure to activate Highlight in the Patch.
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Congratulations! You can now work with the different highlight modes of MADRIX. 
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3.9 DMX-Thru And DMX Merging In MADRIX

In this tutorial you will learn how you can use the MADRIX software to merge DMX data, that is sent with MADRIX and

a lighting console, to a designated DMX output port.

Date: 08/2014

MADRIX Version: 3.2 (Created with)

Note:  For  this  tutorial  you  will  need  one  DMX  interface  for  DMX  output,  one  DMX  interface  for  DMX  input,  and  a

lighting console of your choice.

1. Please start MADRIX and open the Device Manager under Preferences > Device Manager...  
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2. In the DMX Devices tab of the Device Manager  you  can  find  all  connected  DMX  interfaces  (that  have  been

found by MADRIX).

In this example, a MADRIX PLEXUS  unit is connected. The MADRIX PLEXUS  provides two physical DMX  ports.

We will switch one of the ports to receive DMX input.

In order to change an output port to an input port in MADRIX, please select the desired port in the list and then

activate Enable as well as the Input checkbox in the Settings section.

Confirm the changes by clicking on the Apply button. In this example, we want to use the second port of the

connected MADRIX PLEXUS for DMX-IN (DMX 2).
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In the list, you can now see in the column OUT / IN that the configuration has been changed to IN
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3. Now, change to the tab DMX Input in the Device Manager. 

Please select a desired Universe (1 to 8) in the list (The row should be illuminated in green). In this example

it is Universe 1

Next, choose your DMX-IN Device in the Device section by clicking on the little arrow and choosing MADRIX

PLEXUS - DMX2, for example. 
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4. In  this  step,  we  are  going  to  activate  the  DMX  merging  functionality  in  MADRIX.  Therefore,  please  select

Universe 1 again and enable Mapping

5. We can now set up the Mapping section as required:

Map

Channel

s From:

Here you can choose the channel from which the mapping should begin. In this example, we want

to merge the complete universe. That is why we begin at channel 1

To: This setting defines the last channel of the mapping area. In this example,  we  want  to  map  the

complete universe and so we set it to 512

To

Univers

e:

With  this  option  you  can  set  to  which  Universe  you  will  map  the  incoming  DMX  data.  In  this

example, we want to map it to DMX universe 1

Start  At

Channel

:

Here you can set the start channel of the mapping area in the DMX universe. In this example, we

want to include all 512 channels and so we start at channel 1
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Use HTP With this option you can set if the mapping works in HTP mode (Highest Takes Precedence) or in

LTP mode (Latest Take Precedence). In this example, we want to use the HTP mode and therefore

we enable the checkbox.

 

6. You can now connect the output of the lighting console to the DMX 2 port of the MADRIX PLEXUS.

You will see you have created a data chain: Control data is sent from the connected lighting console to the DMX

2 port of the PLEXUS  interface. In MADRIX, this data is mapped onto Universe 1. At  the  same  time,  MADRIX

can generate control data and it is sending all data for Universe 1 (data from the console as well as data from

MADRIX itself) to the DMX 1 port of the PLEXUS using HTP mode.

Note:  In order to connect the output of the lighting console  to  the  DMX  2  port  of  MADRIX  PLEXUS,  you  will

need a 5-pin XLR male to 5-pin XLR male gender changer.

Congratulations! You have learned how you can merge DMX data in MADRIX.
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3.10 HTTP Remote Control

This tutorial shows you how you can work with the MADRIX HTTP Remote Control option. With this functionality you

are able to control MADRIX remotely with any device that features a web browser, such as a mobile device or another

computer which is connected to the same network.

Date: 08/2014

MADRIX Version: 3.2 (Created with)

1

.

Please start MADRIX and go to Preferences > Remote Control > HTTP...
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2

.

The Remote Control HTTP window opens. If you want to use the Remote HTTP option in MADRIX, you have to

activate Enable first. 

You can also change also the Port on which the web server will run and the Path where the initial HTML page

(index.html) is located. In this example, we are not going to change the default settings.

Click Call

Note: You can close the Remote Control HTTP window (by clicking OK) and the MADRIX HTTP Remote Control

option will still work.
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3

.

A  new  website  will  be  opened  in  your  standard  web  browser.  Please  have  a  look at  the  address  bar  of  the

browser. You can enter this IP address into the web browser of a mobile device, tablet, or computer in the same

network and you will have access to this page. In this way, you can control MADRIX remotely.

Note: If you want to control MADRIX remotely with a mobile device or another computer, please make sure that

the device is correctly connected to the same network as the MADRIX computer.
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4

.

There are several predefined user interfaces (HTML sites) already provided to control MADRIX remotely. In this

example, we want to have a look to the user interface called preview

Click  on  the  preview  button  and  your  browser  will  open  the  corresponding  HTML  site.  You  will  see  a  web

interface to control MADRIX remotely. According to its name, this interface will also show  you  3  Previews  in  a

similar way to MADRIX.

Simply use this web interface to control MADRIX as needed!
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5

.

You also have the possibility to create your own HTML web interface. 

Return to the initial HTML site (for example by clicking on return to start menu).

When  you  now  click  on  MADRIX  Remote  Members,  a  new  site  will  be  opened  that  includes  all  available

MADRIX HTTP Remote Control functions.

 

On this page you will find all available functions shown with their function name, an example, and a description.
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Congratulations! You have completed this tutorial about MADRIX HTTP Remote Control.
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3.11 Cue List With Time Code And Duration

Learn how to create a Cue List and trigger this Cue List via MIDI Time Code. You  can  use  a  Cue  List  for  automatic

playback in MADRIX.

Date: 12/2014

MADRIX Version: 3.3 (Created with)

1. Please start MADRIX. 

Open a Setup file or create a number of new visuals. Then, open the Cue List view by clicking on the Cue List

button.
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2. MADRIX will switch to the Cue List view. If you have not added a Cue to the Cue List yet, the list will be empty.

 

We now want to add Cues to the Cue List. To add a Cue, we have to select the desired Storage Place first and

then click the Cue button on the main interface.

Note: A Cue is an entry in the Cue List where -among other things- the Storage and Place is stored. It will be

selected, when the Cue is active.
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3. We have added 7 Cues in this example.

4. If you now start the playback of the Cue List, you will see that the Cues will not be changed automatically. You

can choose to change Cues manually by clicking the Go or Goto buttons.

But  in  our  case,  we  want  to  create  a  Cue  List  which  is  changing  effects  automatically.  MADRIX  provides

several options:

Date You can create a Cue which will only be played back on a specific date (31.12.2014, for example)

or a specific day in the week (Friday, for example).

Time

Code

You can play back a Cue when MADRIX receives a time code. MADRIX can work with different time

codes. You can use the system  time  as  time  code  or  an  external  time  code.  (MADRIX  supports

MIDI Time Code, Art-Net Time Code, and SMPTE Time Code.)

Duratio

n

With the help of the duration, you can set how long a Cue is active  before  changing  to  the  next

Cue.

Note: When you want to create an automatic Cue List, you have to trigger it by using Time Code or Duration
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5. In this example, we want to control the Cue List via Time Code and Duration

You can see if MADRIX already receives time code in the Time Code section of the Cue List.  In  this  section,

you can also choose which time code source and which time code format you want to use.

 

Please enable Use External Source because we want to receive MIDI Time Code (MTC).
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6. When we want to use the MTC for triggering the Cue List, we have to enable the MIDI interface which receives

the time code. Therefore, please open the MIDI tab of the Device Manager or go to Preferences > Remote

Control > MIDI...

In the MIDI tab of the Device  Manager,  please select the desired device and activate the Enable and MTC

checkboxes to enable the reception of the time code. Afterwards, please click OK
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7. If the MIDI device receives MTC, you can see the received time code in the Time Code section of the Cue List



[Part C] Workflow

//376www.madrix.com

MADRIX 3 Tutorials Version 1.9

8. In this step, we want to create the time code trigger for the first Cue. The first Cue should be activated when

MADRIX receives the time code 00:00:00:00

We want to enter this time code into the Time Code column of the first Cue list entry. To do so, select the first

Cue and perform a double-click on the  column Time  Code.  Now,  you  are  in  the  editing  mode  and  you  can

enter the time code.

9. The next Cue should start at 00:00:10:00

We select the second Cue list entry and type in 10s into the column Time Code
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10. We will switch the triggering now. The next Cues are going to be triggered by their duration.

Therefore, we also have  to  set  a  duration  for  the  second  Cue.  In  this  example,  we  set  the  duration  of  the

second Cue to 15 seconds. The duration of the third Cue will be set to 1 minute  and 10 seconds, and we

set the duration of the fourth Cue to 30 seconds

In the below image, you will see that the Follow Cue column of the fourth Cue is not empty. In this example,

we have set the Follow Cue of this Cue to 7. That means that the Cue List will continue with Cue 7; after Cue

4 has ended.
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11. We will change the Duration for the remaining Cues. The duration of Cue number 5 will be set to 12 seconds

and  22  frames  (00:00:12:22),  the  duration  of  Cue  number  6  will  be  set  to  30  seconds  and  4  frames  (

00:00:30:04), and the duration of Cue number 7 will be set to 5 minutes and  32  seconds  in  this  example  (

00:05:32:00).

In Addition, Cue number 7 gets its Follow Cue set to 5. That means after Cue 7 has ended, the Cue List will

continue with Cue number 5. This will happen in a loop until you stop the Cue List or MADRIX receives the time

code 00:00:00:00 or 00:00:10:00

Congratulations! You have learned how to set up a Cue List with time code and duration triggering.
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3.12 Working With Fixture Groups

Learn how to work with Fixture Groups in MADRIX in this tutorial. We want to create 3 different Fixture Groups  and

learn how we can change the values of these groups. 

Date: 07/2015

MADRIX Version: 3.4 (Created with)

Note: For this tutorial we are going to use the Patch we created in the tutorial »Creating A  Patch With Space  Between

Fixtures. Please read it first.

1. Start MADRIX and open the Patch Editor (press the F3 key on your keyboard). 

After creating or loading the Patch from the tutorial »Creating A  Patch With Space  Between Fixtures, the Patch

Editor should look this:
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2. Now, we want to create the first fixture group of this tutorial.

First, select all fixtures of the left column. To do so, press and hold the Ctrl key down and click with the left

mouse  button on the fixtures  in  the  Patch  Editor  grid.  The  selected  fixtures  are  illuminated  in  lime  green.

When you have selected these 4 fixtures, click the Create From Selection button in the upper toolbar.

The New Fixture Group window opens. In this window, you can change the Display  Name, Display  Color,

and ID for the fixture group you just have created.

The Display  Name defines  the  description  of  how  the  fixture  group  will  be  displayed  in  MADRIX.  In  this

example, we change it to Left

The Display Color is responsible for the background color used for this group in the MADRIX Group Control.

In this example, we change it to Red

Note: The Display Color does not define the default color for the light output of the fixtures. 
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The ID is responsible for the order of groups in the MADRIX Group Control.  Normally,  you  do  not  need  to

change this value.

After you have changed the settings, please click OK

Now, you can see that a new group with the name Left was added to the group section of  the  Patch  Editor.

You will find the group section on the bottom left of the Patch Editor.
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3. In this step, we want to add the second fixture group.

Therefore, select the fixtures of the two columns in the middle. To select the fixtures, please press  and  hold

the Shift key down, click and hold the left mouse  button down, and move the mouse  to  create  a  bounding

box over  the  8  middle  fixtures.  After  all  8  fixtures  are  selected,  click  again  on  the  Create  From  Selection

button.

Now, the New Fixture Group window opens.

In this example, we want to change the Display  Name to Middle and  the  Display  Color to  Yellow.  Then,

please click OK and the fixture group will be created.
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4. Now, we want to create the third fixture group. We are selecting all fixtures of the right fixture column and click

 Create From Selection

The  New Fixture Group window opens.

 

We want to change the Display Name to Right and the Display Color to Blue and confirm with OK
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5. There are now three different fixture groups listed in the group section of the Patch Editor.

6. Now, please close the Patch Editor. In MADRIX, please select an empty Storage Place and change the color of

the SCE Color effect to Red
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7. In this step, we want to open the Group Control. To do so, click on the Programmer button and a  context

menu opens. You will find this button below the Fade section.

As a result, the lower part (Effect Section) of the MADRIX user interface will change into the Group Control

section.
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8. You  can  now  change  the  values  of  the  sliders.  You  can  see  the  result  in  the  Preview  Output  and  on  your

connected  fixtures.  The  fixture  groups  are  working  like  dimming  groups  for  the  assigned  fixtures  in  every

group.

Congratulations! You have learned how you can create and work with fixture groups.
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3.13 Working With Group Presets

This tutorial shows you how you can work with Group Presets in the MADRIX Group Control.

Date: 07/2015

MADRIX Version: 3.4 (Created with)

Note:  For this tutorial, we  are  going  to  use  the  Patch,  including  groups,  we  created  in  the  tutorial  »Working  With

Groups

1. Start MADRIX and open the Group Control (press the F9 key on your keyboard). 

After creating or loading the Patch from the tutorial »Working With Groups, the MADRIX Group Control should

look like in the below image.

On the left side of the Group Control, you can see a section with numbered buttons. This section is contains

the Group Presets and you can store different group slider values on each preset.
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2. We want to create and save such a Group Preset. In this example, we are changing the value for group Left to

59 and the value for group Right to 168. We leave the value for group Middle at 255. 

Then, we are changing the Group Preset name to Intro (1) and click Set (2).

The Set Group Preset window will be opened. In this window, you an choose on which Group Preset button

you want to store the current slider settings. We are going to store it on Group Preset 1. To store the preset,

please click OK

3. We now want store a second Group Preset.

First, we will change the values for groups Left and Right to 255 and the value for fixture group Middle to 0.

Second, we change the Group Preset name to Main Part (1). Third,  we  perform  a  right  mouse  click  on  the

second Group Preset button. A context menu opens and we choose Set (2) to store the preset.
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4. You can see that there are 2 blue buttons now in the Group Preset section. When you click on one of the blue

buttons, the sliders will be changed to the stored values within.  Such  a  fade  will  be  executed  within  the  set

Fade Time. You can change the Fade Time on the bottom left side of the Group Preset section.

Note: If you do not want to switch between 2 Group Presets with a fade, perform a double-click on the desired

Group Preset.

Congratulations! Now you can work with Group Presets in the MADRIX Group Control.
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3.14 Working With The Group Value Chaser

Learn how to create a Group Value Chaser in MADRIX in the following tutorial. 

Date: 07/2015

MADRIX Version: 3.4 (Created with)

Note:  For this tutorial, we  are  going  to  use  the  Patch,  including  groups,  we  created  in  the  tutorial  »Working  With

Groups

1. Start MADRIX and open the Group Control (press the F9 key on your keyboard). 

After creating or loading the Patch from the tutorial »Working With Groups, the MADRIX Group Control should

look like in the below image.

On  the  right  side  of  the  Group  Control,  you  can  see  a  Chaser button  (similar  to  a  the  Effect  Parameter

Chaser of the MADRIX Effect section). With the Group Value  Chaser,  you  are  able  to  change  fixture  group

values automatically after a desired time and with or without fade.
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2. Let us add the first Step to the Group Value Chaser

Therefore, please perform a click with the right mouse button on the Chaser button and choose Edit

The Group Value Chaser window opens. In this example, the group values for our first step are set to 255 for

all three groups. Please click the + button to add the Chaser Step.

3. We are changing the value of every fixture group to 70 for the second Chaser Step. You can change the group

values using a multiselection. To do so, press and hold the Shift key down and click on the first group and then

on the last group. Every selected group will be illuminated in green and you can move the slider down to 70.

After selecting all groups, click the + button in the Group Value Chaser again.
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4. We are going to change the Fade Time and  Wait  Time  of  this  Chaser.  Please  select  all  Steps  by pressing

Ctrl+A on your keyboard.

In this example, we are changing the  Fade Time to 5.00 seconds and the Wait Time to 10.00 seconds.

You can quickly change the Fade Time and Wait Time by clicking with the right mouse  button  on  a  desired

value. The value will become editable and you can change it. Please apply your new value with Enter
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5. Now, we want to start the Group Value Chaser and store it as a Group Preset

To start the Chaser, please click with the mouse button on the now blue Chaser button. The button color will

be changed to green. This means it is now playing.

To store this Chaser in a preset, we will first change the  Group Preset name to Chaser and then we perform

a right mouse click on the first preset button. We choose Set from the context menu.

Note: If you want to learn more about Group Presets, please have a look at the tutorial »Working With Group

Presets

Congratulations! You have just created a Group Preset which includes a Group Value Chaser.
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3.15 Controlling A Kinetic Lighting System With MADRIX

This tutorial shows you how you can control a kinetic system, with 5 x 5 fixtures for example, with MADRIX.

Date: 03/2016

MADRIX Version: 3.5a (Created with)

Note: In this example, we are assuming that the movement channels of our 5 x 5 fixtures are occupying the first 25

DMX channels on DMX universe 1. And we are assuming that the color channels of our 5 x 5 fixtures are occupying the

first 75 DMX channels on DMX universe 2. 

1. Start MADRIX and open the Patch Editor (press the F3 key on your keyboard). 

After the Patch Editor window has been opened, please create a new patch file. To do so, click New

Change the Matrix Size to Size X = 5, Size Y = 10, and Size Z = 1
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2. Now, we want to add the fixtures for the kinetic movement. We are going to add one-channel lights at the top

of the patch, in this example.

Please click the Add button and change the following settings in the Add Fixtures window:

Product: !generic 1 Channel Light 1 Channel Light

Count X = 5, Count Y = 5, Count Z = 1 

Confirm by clicking Add
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3. In this step, we want to add the fixtures to control the RGB lights of the kinetic system. In this example, we are

going to 3-channel RGB lights below the fixtures that are used for the movement.

Please open the  Add Fixtures window again and change the following settings:

Product: !generic RGB Light 1 Pixel

Count X = 5, Count Y = 5, Count Z = 1 

Start Position X = 1, Start Position Y = 6

DMX Start Universe = 2

After you have adjusted the settings, click Add
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4. We have now added all necessary fixtures.

The 1st area is responsible for the kinetic movement of the fixtures.

The 2nd area is responsible to control the colors of the fixtures.



[Part C] Workflow

//399www.madrix.com

MADRIX 3 Tutorials Version 1.9

5. In this step, we want to create two fixture groups.  With  the  help  of  the  fixture  groups,  you  can  control  and

assign the desired fixtures in MADRIX more easily.

If you want to learn more about how to create fixture  groups,  please  see  this  tutorial  »Working  With  Fixture
Groups

Here in this example, we are going to call the first  fixture  group  RGB  and  we  are  adding  all  fixtures  of  the
second  DMX  universe  to  this  group.  To  do  so,  please  select  all  fixtures  of  the  second  DMX  universe,  click
Create From Selection, and change the Name to RGB

We  are  calling  the  second  group  Movement and  will  be  responsible  for  controlling  the  movement  of  the
fixtures.  Please  select  all  fixtures  of  the  first  DMX  universe,  click  Create  From  Selection,  and  change  the
Name to Movement

Please close the Patch Editor now.
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6. When you now click on Map, the Map Settings window will launch. There, you have the option to change the

mapping to the newly created fixture groups very easily.  Choose  Mapping > Preset >  RGB  or  Mapping  >

Preset > Movement
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7. We want to create the first MADRIX Effect for the kinetic lighting system.

In this example, we are going to use two Layers in MADRIX. The first layer is  responsible  for  the  movement

and the second layer is responsible for the color of the LEDs. 

First, we have changed the Name of the first Layer to Movement. Second, we are assigning the Mapping to

the Movement Preset, as described above. Third, we have set the color channel Red of the MADRIX Effect

SCE Color to 255

Fourth, we want to change the Name of the second Layer to RGB. Second, we are assigning the Mapping to

the RGB Preset, as described above. Third, we are switching to the effect SCE Color Scroll

When you now have a look at the real fixtures in the installation, you should see scrolling colors on the  LEDs

and the winches should be extended to the maximum.
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Congratulations! You have just learned how you can use MADRIX to control a kinetic lighting system.



D//PART 
Miscellaneous
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4 Miscellaneous

4.1 Setting Up LED Studio For EUROLITE LED Pixel Mesh 64x64

In this tutorial, you will learn how to create a setup in LED Studio 10.40D for 16 EUROLITE LED Pixel Mesh 64  x  64.

The fixtures will be placed in 4 rows and 4 columns.

Date: 12/2012

LED Studio Version: 10.40D  (Created with)

1. Start the LED Studio software and go to Option > Software Setup

Now, write linsn on your keyboard. There is no edit field for that, so just type it in. As a result, the software

will require a password. Enter in the edit field 168 as the password. 
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2.  A new window will be opened. Select the Sender tab and change the  Display  mode  to  1024x768.  Then,

click Save on sender 
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3.  Change to the Receiver tab, click Load from files, and load the Pixel Mesh.RCG

Now change the following settings: 

refresh FRQ: 70 

Gray level: Normal 512 

Scan clock: 2.0 

Row blanking time: 200 

duty ratio: 50 

Blanking Delay: 3 

Gray equalize: 1 

Afterwards, click Send to receiver and then click Save on receiver

Go to the Load capacity setup section on the Receiver tab. Change Actual width to 256 and Actual height

to 128

Click Send to receiver and then click Save on receiver again. 
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4.  Change to the Display connection tab and at the bottom change Width to 64 and Height to 64

Now, click again Send to receiver and then Save to receiver

Click Exit and after that, click Close 
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5. Note: The fixtures EUROLITE LED Pixel Mesh 64x64 are connected as shown in the following picture: 

Congratulations! You have just created a setup for 4 rows and 4 columns of the EUROLITE LED Pixel Mesh 64 x 64

fixture. 
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4.2 Setting Up LEDShow T9 For EUROLITE LSD Soft Displays

In this tutorial, you will learn how you can set up the EUROLITE LSD AIO Network control system in order to use it with

MADRIX and the T9 protocol.

Date: 12/2012

LEDShow T9 Version: 10.50  (Created with)

Note: It is necessary to configure the AIO Controller/LED Show T9. Without this initial configuration, you cannot use

T9 in MADRIX. But after this one-time configuration, you will not need to use LED Show T9 anymore.

Before we start, please note: If the following warning appears, please always confirm with Yes

1. Download  the  Preset  T9.DAT  again  and  unzip  it.  The  file  is  available  in  the  Downloads  section  of  the

following »Link

http://eshop.steinigke.de/de/Video/Media-Systems/LSD-AIO-Netzwerk-Control-System/category-dc66b0b17f6b752aa44bc9ce8aea9063/product-ARTI_80503300.html
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2. Start the LED Show T9 software and go to Control(C) > LEDAdmin(L)
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3. The following window will be opened. 

Click the button parameter set, which you can find  to  the  middle  on  the  right-hand  side.  Now,  you  will  be

asked for a password. Type T9 into the textfield and confirm with OK
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4. Now, the window LED Setting(LED1) will be opened. Please click Load on the Board Type tab. 

Note: If there is no reaction of the button, please click below the label of the Load button. 
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5. Now, choose the Preset T9.DAT file you just downloaded and click Open 

6. Close the LEDSetting(LED1) window by clicking the X on the top.
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7. Now, go to Control(C) > LEDAdmin(L) again and change the width and height to 128 each. Confirm with

the button Change 
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8. Usually, you can see a preview image displaying a white eurolite on the LSD curtain. If it is displayed correctly,

you do not need  to  change  anything.  If  it  is  mirrored/inverted,  you  should  to  change  direction(front) from

right-left to left-right 

9. Now, click parameter set again, type in T9 as the Admin key into the textfield of the Key Input window, and

click OK. The  LEDSetting(LED1) window will be opened.

10. Select to the receiver connection tab of the LEDSetting(LED1) window. 

a Select the displayed LSD on the left side (it should be illuminated in blue). 
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b Enable use  real-time parameters in computer...  and click Send. You  can  see  a  progress  bar  and

after it has been sent, you will get a send complete message. Click OK to close the message.

c Now, select use parameters saved in receiver card... and click S end again. You can see a progress

bar and after it has been sent, you will get a send complete message. Click OK to close the message.

11. Close  the  LEDSetting(LED1)  window  and  close  the  LEDShow  T9  software.  Please  make  sure  that  the

software is really closed, as it sometimes will be minimized to the Windows system tray.

12. You can now configure MADRIX for T9 control. Please have a look at the tutorial »T9 Configuration In MADRIX 
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Congratulations! You have configured your EUROLITE LSD AIO Network control system.
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4.3 Configuration Of Light-O-Rama S3 And MADRIX

This  tutorial  shows  you  how  you  can  configure  Light-O-Rama  S3  software  to  trigger  effects  within  MADRIX  using

E1.31. Triggering can now be done through software control and no longer requires  external USB DMX adaptors or

an iDMX1000.

Date: 09/2013

LOR S3 Version: 3.6.0 (Created with)

MADRIX Version: 3.0 (Created with)

Note: MADRIX will allow you to trigger  effects  via  E1.31  while  outputting  to  standard  DMX  controllers.  You  do  not

have to have an E1.31 controller connected for this this process to work.

Requirements:  Before  going  any further,  you  must  have  a  LOR  USB  485  Converter  connected  to  the  computer.

Although we will not be sending any DMX commands out of this unit, the LOR control panel requires it be connected to

send an E1.31 stream.
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1

.

Please start the Light-O-Rama Sequencer (version 3.6.0 or better) and start a sequence as you normally would.

Go to Edit > Preferences > Network Preferences. Make sure the DMX tab is selected and click the Advanced

button on the right side. Now, a list of  DMX  universes  will  be  displayed.  Please  select  Unv  1.   At  the  pop-up

menu, select Use E1.31, then select Multicast. Click OK  and Exit the program without saving.
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2

.

Now, start MADRIX and go to Preferences > Options and click on the Devices Network tab.  Please  activate

Enable ACN E1.31 (the checkbox should be illuminated in green). If you have no other E1.31 devices connected,

change the Count of ACN Devices Used to 1, otherwise enter the  total number of ANC universes MADRIX will

be controlling. Click OK
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3

.

Now,  go  to  Preferences  >  Device  Manager,  select  ACN  id:00001,  Univ:00001  and  select  Input  at  the

Settings panel. Click Apply

4

.

Switch to the DMX Input tab. Click on the first row (Universe 1), from the DMX-IN Device drop-down list select

 ACN id:00001,  Univ:00001,  turn  on  the  Remote  option  (located  on  the  upper  right)  and  select  Simple  4

Channels at the Remote Control section. Click OK
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5

.

On the MADRIX user interface, change the Fade Time to 0

P

Now, save your MADRIX Setup File and exit MADRIX.

6

.

Make sure all programs are closed. Start the programs in the exact order as shown below. If you do not, you will

not be able to control MADRIX. Also, make sure the Comm Port Status indicator located in the lower right-hand

side of the LOR Sequencer shows blue. If it does not, exit and use LOR Hardware utility to find and  assign  the

Comm Port.

1. Start the Light-O-Rama Control Panel.

2. Start LOR S3 Advanced (do not move on until you are asked to load or start a new sequence).

3 Start MADRIX.
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4. Load your MADRIX Setup File you created, make sure Load Patch and Load DMX Device  Settings are

both selected when prompted.

5. Go back to LOR S3 and start a new sequence (or load and existing one).

6. In the timeline, click on the first device button (ie. Unit 01.1)

Enter the following settings:

Name: DMX

Device Type: DMX Universe

Universe: Universe 1

Address: 1

7. Go to Edit > Preferences > DMX Preferences > Allow DMX Editing (you should only need  to  do  this

once).
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8. Go to Play and make sure Control Lights is selected (you should only have to do this once).

9. Click on the DMX button in the toolbar.

10. Using the chart below enter the DMX value and apply it to the timeline.

7

.

MADRIX  3  now  gives  you  256  storage  groups  (Storages)  and  256  bins  under  each  storage  group  (Storage

Places).  When  creating  effects  for  multiple  songs,  you  may find  it  useful  to  give  each  song  its  own  storage

group. You can then have 256 effects for each song. Storage groups and bins use the same chart below.

1. Click on the DMX button in the toolbar.

2. Select the DMX vale for the storage bin being used by the song and apply it to all cells in that row.

3 Select a DMX value fro the bin you wish to access and drag it across all cells for the desired time.
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Congratulations! You have just configured Ligth-O-Rama to control MADRIX remotely.
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4.4 RGB Colors

In this tutorial you will learn how RGB color mixing works.

Date: 07/2014

Introduction

The RGB color system is an additive color mixing system. That means the colors will be added. The system is defined

by the values of the primary colors: red [R], green [G], and blue [B]. 

Each of the 3 colors [red, green, blue] are represented in 8 bit. That means it is possible to control each color in 256

steps [0 - 255]. All color values together can control 16.7 million different colors [256 x 256 x 256].

Mixing Colors



[Part D] Miscellaneous

//431www.madrix.com

MADRIX 3 Tutorials Version 1.9

Now, we want to create several colors by mixing the values of the 3 colors:

To create a bright red color, the value of the red channel should be 255. The values of blue and green have to be 0.

If you want to create black, all 3 color values should be 0.

To generate white, the values of red, green, and blue have to be 255.
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If the values of red and green are 255 and blue is 0, you will produce a bright yellow.

To produce an orange color, set up the following color values: The value of red should be 255. The  value  of  green

should be 127. The blue value should be 0. 

Note: Lower the color value of green, for example, and you will see that the color will become more and more red.
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Turquoises color will be displayed if red is set to 0 and green and blue are set to 255.

Congratulations!  You have learned the  first  rules  about  RGB color  mixing  and  you  have  successfully  finished  this

tutorial.
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4.5 What Is DMX

This tutorial is an introduction to DMX.

Date: 08/2014

Introduction

DMX is the standard digital protocol to control lighting fixtures on a stage. It was standardized in 1990 by the United

State  Institute  for  Theater  Technology (USITT)  and  was  called  DMX512/1990.  The  actual  DMX  standard  is  called

DMX512/A and contains several additions, but it is also compatible with the old standard DMX512/1990. 

What do we need to install a stable DMX line?

DMX Interface Includes hardware devices, like the MADRIX NEO, MADRIX PLEXUS, or MADRIX LUNA.

A DMX interface sends the control signal for a maximum of 512 DMX channels per DMX universe.

 The control information  will  be  transmitted  by using  a  data  word  of  1  Byte  [8  Bit].  That  is  the

reason why you can control each DMX channel with 256 steps [0-255].  

DMX

 Interpreter/

Controller

Can  usually  be  foun  inside  a  fixture.  It  receives  the  DMX  signal,  interprets  it,  and  changes  the

values of each attribute of the fixture to the desired value which is set by the DMX signal.

DMX

Connectors

As described in the DMX512 specifications, a 5-pin XLR connector has to be used. The first pin is

used for ground, the second pin  for  the  inverted  DMX  signal  ['Cold'],  and  the  third  for  the  DMX

signal. Pin  four  and  pin  five  are  occupied  for  other  tasks,  which  are  specified  in  the  DMX512/A

norm. That means in most cases that a 3-pin connector will suffice, but as mentioned above that is

not the norm of DMX512.

Connectors are available in 2 designs, male and female. The male connector is connected  to  the

transmitter [DMX interface] and the female connector is connected to the receiver.
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DMX Cables It is recommended  to use only cables with an impedance of 110 ohm. Otherwise, it is possible to

get unwanted side effects.

A  DMX  connector  is  found  at  each  cable  ending:  The  male  connector  on  the  one  side  and  the

female connector on the other side.

DMX Fixture Includes lighting devices, such as Dimmers, RGB fixtures, and Moving Heads.

DMX fixtures receive and interpret the signals from the DMX controller according to  the  allocated

function of the channel. Furthermore, the DMX signal  will  often  be  forwarded.  In  many cases,  a

DMX  fixture  features  a  DMX-IN as  well  as  a  DMX-OUT  connector.  This  allows  to  daisy-chain  a

certain number of DMX fixtures.

Note: You should feed the signal anew after a maximum of 32 fixtures,  because  the  DMX  signal

strength will be too weak otherwise.

DMX Splitter A DMX splitter mainly splits and duplicates an incoming DMX signal into several DMX output signals.

Each output signal is basically the same. It is like a Y-split cable for the audio engineer. But at the

same time, the DMX splitter amplifies the signal to ensure the signal strength.

DMX Booster A DMX-Booster amplifies the incomming DMX-Signal. That is necessary if the signal  is  to  low  for

the nex DMX-Fixture. 

DMX

Terminator

A DMX terminator of 120 Ohm impedance should be used at each last fixture or end of a DMX line!

If not, unwanted transmission interference is common. The terminator is connected to pin two and

pin three of a male connector.

DMX Universe A DMX universe consists of 512 DMX channels. If you need control more than 512 DMX channels in

your installation, it is necessary to use an additional universe or even more.

Congratulations! This tutorial should have provided important information on how to build a stable DMX line.
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4.6 Calculating DMX Channels

This tutorial shows you how to calculate how many DMX channels will be needed in a project.

Date: 08/2014

Introduction

Nowadays,  LED installations  are  getting  bigger  and  bigger  and  it  is  common to  control  a  lot  of  LED  DMX  fixtures.

Especially, when you want to control a  project  with  MADRIX,  it  is  useful  to  know  how  many DMX  channels  will  be

controlled in total.

DMX Channels And DMX Universe

1 DMX universe includes 512 DMX channels. If you need more channels, it is necessary to use additional universes.

After your calculations, you will know two numbers: 

1) the total number of DMX channels and 

2) the equivalent number of DMX universes, which usually is also the number of required DMX lines.

Example 1

How many RGB 1-pixel fixtures can be controlled with 1 DMX universe?

1 DMX universe contains a maximum of 512 DMX channels. A normal RGB 1-pixel fixture uses 3 color channels to mix

all other colors. These color channels are Red, Green, and Blue.

At the same time this means that such a fixture usually requires 3 control channels (one control channel for each color

channel). 

Control Channels Per Fixture:

1 pixel * 3 color channels = 3 control channels per fixture
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Calculation:

512 DMX channels / 3 control channels = 170.66667 fixtures per universe

Now, we need to round that number down to 170.

170 fixtures * 3 control channels = 510 DMX channels

When we use 170 RGB 1-pixel fixtures, channel 511 and channel 512 would still be unused. Can we fit fixture #171 in

there with its first two channels?

The answer is no, we cannot. If a fixture is included in a universe, normally the full fixture needs to be able to fit into

that  universe.  Because  of  this,  channel  511  and  channel  512  are  usually  not  used  in  case  of  RGB 1-pixel  fixtures.

Fixture #171 would not fit fully into the universe anymore.

Number Of DMX Universes:

From the beginning we knew that we only wanted to use 1 universe.

510 control channels / 512 DMX channels per universe = 0.99 universe = 1 universe.

We need to round that number because there are only complete DMX universes.

Result:

That means you can control a maximum of 170 RGB 1-pixel fixtures (if each fixture needs 3 control channels). 

Example 2

How many RGBW 1-pixel fixtures can be controlled with 2 DMX universes?

A normal RGBW 1-pixel fixture uses 4 color channels to mix all other  colors.  These  color  channels  are  Red,  Green,

Blue, and White.

Control Channels Per Fixture:

1 pixel * 4 color channels = 4 control channels per fixture

Available DMX Channels:

2 universes * 512 channels per universe = 1024 available channels 

Calculation:

1024 available channels / 4 control channels = 256 fixtures in total

256 total fixtures / 2 available universes = 128 fixtures per universe

Number Of DMX Universes:

2 universes
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Result:

You can control a maximum of 256 RGBW 1-pixel fixtures (if each fixture needs 4 control channels). 

Example 3

You might want to use 300 pieces of RGB LED tubes. Each tube features 16 pixels. How many DMX channels will be

needed?

Control Channels Per Fixture:

16 pixels * 3 color channels = 48 control channels per fixture

Calculation:

48 control channels * 300 pieces = 14,400 DMX channels in total

Number Of DMX Universes:

14,400 DMX channels / 512 channels per universe = 28.125 universes = 29 universes

Result:

You will 14,440 DMX channels / 29 DMX universes for such an installation. 

Example 4

You might want to use 1) 100 pieces of 32-pixel RGB LED tubes as well as 2) 200 pieces of 16-pixel RGBW LED tubes.

How many DMX channels will be needed?

Control Channels Per Fixture:

1) 32 pixels * 3 color channels = 96 control channels per fixture

2) 16 pixels * 4 color channels = 64 control channels per fixture

Calculation:

1) 96 control channels * 100 pieces = 9,600 DMX channels

2) 64 control channels * 200 pieces = 12,800 DMX channels

3) 9,600 DMX channels + 12,800 DMX channels = 22,400 DMX channels in total



[Part D] Miscellaneous

//439www.madrix.com

MADRIX 3 Tutorials Version 1.9

Number Of DMX Universes:

22,400 DMX channels / 512 channels per universe = 43.75 universes = 44 universes

Result:

You will 22,400 DMX channels / 44 DMX universes for such an installation. 

Congratulations!  The  examples  above  should  have  shown you  the  basic  calculations  when  it  comes  to  the  total

number of required DMX channels.
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4.7 Setting Up The DMX Address And DMX Start Channel

In this tutorial you will learn the meaning of the DMX start channel and the DMX address.

Date: 08/2014 

Introduction

The DMX address of a fixture is a combination of the assigned DMX universe and the assigned DMX channel. This DMX

channel needs to be set up on the fixture itself (the universe is  usually  automatically  assigned  by using  the  specific

DMX line) as well as in MADRIX. Using the right DMX address is very important for DMX fixtures to function correctly.

The DMX start channel also refers to the DMX channel mentioned above. It is the DMX channel where the fixture will

start  to  react.  In  DMX  you  can  only  setup  the  start  channel  of  a  fixture  and  you  will  have  access  to  all  the  other

channels of the fixture. To change the assignment of a fixture, it is only necessary to set the first DMX channel anew.

All other channels will be changed automatically. 

Usually, all fixtures have a unique DMX address so that they all can be controlled individually.

Note: 1 DMX universe includes 512 DMX channels. That means you can control a maximum 170 RGB fixtures (if each

fixture needs 3 channels). If you need more channels, it is necessary to use additional universes.

Using Unique DMX Addresses

For example, we want to set up the DMX start channel for a generic RGB fixture to channel 1. Now, we have access to

the red color channel with DMX channel 1, to the green color channel with DMX channel 2, to the blue color channel

with DMX channel 3.

The next free DMX address is DMX channel 4. When we set up the next fixture to this address, it means we will be

able to control this fixture independently from the first fixture. 

Let us set up the next generic RGB to start channel 4. That means with DMX channel 4 we are able to control the red

color channel, with channel 5 the green color channel, and with channel 6 the blue color channel.

The next free DMX address is 7.
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Note: The DMX start channel of a fixture should be an unassigned DMX channel in the specific DMX universe. 

Counterexample: Two generic RGB fixtures are configured as follows. Fixture number one is set to DMX start channel

1. Fixture number two is set to DMX start channel 2 in the same DMX universe. In such a configuration the following

issue will occur. If you want to control the DMX channel for green of the  first  fixture,  you  will  inevitably  control  the

DMX channel for red of the second fixture.

Note: It is also possible to set up more than one fixture to the same DMX start address. But in that case, you cannot

control every fixture individually.

The Last Usable Start Channel For A Fixture

The last usable DMX start channel for a fixture can be calculated as follows:

(512 available channels) - (DMX channels required by the fixture) + (1). 

Is is necessary to add +1 because the start address is also the first channel the fixture occupies. 

For instance, if a fixture uses 5 DMX channels: 

512 - 5 + 1 = 508

The last useable DMX start channel is 508.

Example 1

Imagine we have an empty DMX universe and we want to patch two fixtures. The first fixture is set up in 4-channel

mode (for instance, an RGBW fixture) and the second fixture is a 3-channel RGB light.

The DMX start channel of the first fixture is 1, because the patch is empty and usually the DMX start channel of the

fixture is the next, free channel in the universe. Now, the first DMX channel controls the first channel of the fixture, the

second DMX channel controls the second fixture channel, the third DMX channel controls the third fixture channel, and

the fourth DMX channel controls the fourth fixture channel.

We can see that the next empty DMX channel of this universe is channel 5. 

Therefore,  we  will  change  the  start  channel  of  the  second  fixture  to  channel  5.  That  means  that  DMX  channel  5

controls the first channel of the second fixture, DMX channel 6 controls the second channel of this  fixture,  and  DMX

channel 7 controls the third channel of the second fixture.
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Example 2

In this example, we want to patch one  3-channel  fixture,  two  24-channel  fixtures,  and  one  4-channel  fixtures.  The

DMX universe is empty.

The DMX start channel for the first fixture is 1. 

Now, we have to calculate the DMX  start  channel  of  the  second  fixture.  We  know  that  the  first  3  channels  will  be

occupied by the first fixture. That means that the DMX start channel of the second fixture is 4. This fixture occupies 24

DMX channels.

The third fixture should be patched to DMX start channel  28,  because  the  first  fixture  occupies  3  channels  and  the

second fixture uses 24 DMX channels. Together, the two fixtures occupy 27 DMX channels, starting with channel 1 and

therefore the next free channel is 28.

Now, we have only to change the DMX start address of the last fixture. We know that the first three fixtures occupy 51

DMX channels (3 + 24 + 24). The next free DMX channel is 52. That is the DMX start channel of the last fixture in our

example.

Example 3

In this example, the DMX universe is occupied until DMX channel 480. We want to add two additional fixtures with 24

channels each.

The next free DMX channel is channel 481. This is the new DMX start channel of the first fixture.

Now, let us calculate the DMX start channel of the second fixture. The occupied DMX channels are 480  + 24  = 504

channels. We know that the next free DMX channel is channel 505 and we can change the DMX start channel of the

second fixture to 505. 

STOP! This is a mistake because our fixture has 24 channels and 505 + 24 is higher than 512. That means we have to

set the DMX start channel to channel 1 and connect this fixture to the next DMX universe.

Congratulations!  You have learned to calculate the correct DMX start channels for your fixtures. 
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5 Hardware

5.1 MADRIX PLEXUS

5.1.1 Recording MADRIX PLEXUS Stand-Alone Files

This tutorial shows you how you can create stand-alone files for MADRIX PLEXUS (of the file type *.dxd). 

Date: 10/2014

MADRIX Version: 3.3 (Created with)

Note: In this example we want to create *.dxd files for 4 DMX Universes (for 2 MADRIX PLEXUS). 
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1. Start MADRIX and press the F2 key on your keyboard. In the Matrix Generator, create a new Patch with 26 x 26

x 1 generic RGB lights. To do so, choose: 

Protocol : DMX

Product : !generic RGB Light 1 pixel  

Count X / Y / Z : 26, 26, 1 

You can find detailed information about the Matrix Generator in a previous tutorial (»The First Patch).

If you now open the Patch Editor, the configured Patch should look like in the following screenshot: 
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2. In order to continue we have to create visuals or open an existing Setup file. In this example, we  will  create

three simple effects, including SCE Wave / Radial, SCE Fluid and an SCE Graph effect.

The SCE Wave / Radial effect is set up at Storage Place S1 P1. We will only change the color to amber. 

SCE Fluid is located at Storage Place S1 P2 and all effect settings are set to their defaults. 
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SCE Graph is located at Storage Place S1 P3 with its default settings.
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3. Go to Window > Recording... or press Ctrl+Alt+R together on your keyboard. 

The Recording window will be opened. 

We want to record Storage Place S1 P1 first. Therefore, activate this Storage Place and move the crossfader

accordingly to show the Storage where the effect is running. In this example it is Storage Left. You should see

the effect in the Preview Output as a result. 

Please  select  the  Recording  tab  and  then  click  the  Start button.  The  output  of  MADRIX  (as  shown  in  the

Preview Output) will be recorded. 



[Part E] Hardware

//449www.madrix.com

MADRIX 3 Tutorials Version 1.9

Let the recording process run for a sufficient time or as long as needed (In this example we stopped recording

after 18 seconds and 23 frames). Click the Start button again, which now reads Stop. 

The recording will stop and a Save As window will be shown. Choose a desired File  name for the record and

conform with Save.

You can now see the recorded file with additional information in the file list. 
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5. Please switch to the Record Editing tab, select  the  recorded  *.mrec  file  in  the  list  (it  will  be  illuminated  in

green in the list), and then click Find Loop.

If a loop was found, the following message appears: 



[Part E] Hardware

//452www.madrix.com

MADRIX 3 Tutorials Version 1.9

Click OK and you can see that the Out Frame will be set automatically. The Out Frame marker will be shifted

to left. That means the file will be cut there. 

We now have to save the new (and shorter) file. Click Export and a Save As window will be opened. Choose a

desired File name and click Save. In this example, we chose to keep the file name and overwrite the existing

file, since we only want the looped visuals.
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6. Now, switch to Storage Place S1 P2, SCE Fluid, record it, and save the file.  

7. Repeat the recording process while the SCE Graph effect is selected on Storage Place S1 P3.
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8. Switch again to the Record Editing tab and select your recorded file for the SCE Graph. 

We want adjust the record to achieve better visuals.

Start  by changing  the  In  Frame  to  a  position  where  the  left,  red  square  of  the  effect  is  displayed  at  the

bottom. In this example it is at frame 53. You can search for the correct frame by moving the slider. Then, click

 S to set the In Frame or manually enter the frame (such as 53). 
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We also want to change the Out Frame to a position where the left, green shape is at the bottom in order to

create a smooth animation. In this example, it is at frame 324. We therefore set the Out Frame to 324.
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Click  Play/Pause  to  preview  the  edited  record.  Adjust  In  Frame  and  Out  Frame  if  the  animation  needs

adjustment.
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When the visuals are ready, click the Export button and the Save As window will be opened again. Choose a

file name and click Save. In this example, the existing file will be overwritten. 



[Part E] Hardware

//458www.madrix.com

MADRIX 3 Tutorials Version 1.9

9. Switch  to  the  PLEXUS Conversation tab.  You  can  see  all  recorded  *.mrec  files  in  the  upper  half  of  the

Recording window. (These are files which are stored in the chosen Directory).

Now, select one of the *.mrec files and then click the Auto button.
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MADRIX will automatically calculate and suggest the settings for each  DMX  Universe  and  fill  the  list  with  the

settings for the required *.dxd files.

Note: If the created Patch uses more than 2 DMX universes, several *.dxd files will be created. The reason is

that a file is created for each PLEXUS which contains the output settings for two DMX universes.

To create the *.dxd files, click the Generate button.



[Part E] Hardware

//460www.madrix.com

MADRIX 3 Tutorials Version 1.9

Note:  The list entries for DMX 1 and DMX 2 are the corresponding DMX universe numbers  from  the  Patch.

That means the data for these DMX universes will be saved in the *.dxd file and assigned to the DMX  1  and

DMX 2 output ports of a MADRIX PLEXUS. You can change the DMX routing by performing a double-click with

the left mouse button on the number you want to change. (In this example, *.dxd file 001 will contain data of

DMX universe 1 and 2, while *.dxd file 002 will contain the data of DMX universe 3 and 4.)
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10. After generating the *.dxd files, you can see the new files in the file list above. These are the *.dxd files which

you can copy to the SD card of a MADRIX PLEXUS. (Learn how to copy the files to the MADRIX PLEXUS  in the

next tutorial »Copying Stand-Alone Files To MADRIX PLEXUS.)

Repeat  the  file  generation  steps  above  for  the  2  other  recorded  *.mrec  files.  In  the  end,  you  should  have

created 6 *.dxd files (two for each Storage Place).
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Congratulations! You have just created MADRIX PLEXUS stand-alone files. 
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5.1.2 Copying Stand-Alone Files To MADRIX PLEXUS

In this tutorial, you will learn how to copy *.dxd stand-alone files to MADRIX PLEXUS.

There are different ways to copy such files. You could copy *.dxd files directly to the SD-Card using an SD card reader

connected  to  your  computer.  In  this  tutorial,  we  will  use  the  PLEXUS  Configuration  window  and  use  two  MADRIX

PLEXUS with an inserted SD card.

Date: 10/2014

MADRIX Version: 3.3 (Created with)

Note: You will need *.dxd files for this tutorial. Learn how to create *.dxd files in this tutorial.

1

.

Open MADRIX and go to Tools > PLEXUS Configuration...
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2

.

The PLEXUS Configuration window will be opened and you can see connected PLEXUS  devices. In this example

two MADRIX PLEXUS are connected via USB. MADRIX PLEXUS could also be connected via Art-Net.

If you do not see your connected devices, click the Search button. 



[Part E] Hardware

//465www.madrix.com

MADRIX 3 Tutorials Version 1.9

3

.

First, we want to download any Scenes that are already uploaded to the PLEXUS. Therefore, select the PLEXUS

unit from which you want to download the files. In this  example  we  want  to  download  the  Scenes  from  every

device. That is why we first select all of them and then click the Download button. 

When the download is complete, you can see the downloaded Configurations in the left Configuration section and

the Scenes of a Configuration in the Scenes section to the right. 



[Part E] Hardware

//466www.madrix.com

MADRIX 3 Tutorials Version 1.9

4

.

We  will  now  prepare  our  two  PLEXUS  devices  for  stand-alone  playback.  We  will  have  to  create  a  new

Configuration for each PLEXUS. To create a new Configuration, click the + button to the left of the Configuration

section. 

In the next step, type in a Name for the new Configuration and click OK. In this example the first Configuration is

called Tutorial PLEXUS 1. 

Every new Configuration is empty at first. To add Scenes to the Configuration, please select the Configuration and

press the + button in the Scenes section. 
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A new window will be opened. Here you can select which Scenes are added to the Configuration. To import new

Scenes, click the Import button and select the desired *.dxd files on your harddisk. Right now, we are creating

the Configuration for the first PLEXUS. That is why we will select all *.dxd files with #001.dxd in their  file name.

Confirm with Open. 
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All imported files will be shown in the list. Now, select the required files and confirm with OK.
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You can see that the Scenes have been added to the Configuration. 
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5

.

In this step, we want to make a small adjustment to the Configuration. One Scene  should  be  played  back in  a

loop. 

In the Scenes section, search for the Repeat column and change the value to 3 for the Scene graph#001.dxd.

To change the value, perform a double-click with the left mouse  button on the number. This  means  that  this

Scene will be played back 3 times as one loop. 
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6

.

The Configuration of the first MADRIX PLEXUS is now complete. We will still have to create another Configuration

for the second MADRIX PLEXUS.

Note:  The  second  Configuration  is  necessary  because  every  *.dxd  file  contains  the  data  for  up  to  2  DMX

universes. We created a Patch for 4 DMX universes and the data of universe 1 and 2 is different to the data of

universe 3 and 4.

Please create a new Configuration for the second PLEXUS. In this example, it is called Tutorial PLEXUS 2. 

Continue by importing and adding all *.dxd files to this Configuration that have #002.dxd in their file name.

Note: It is important that the order of the *.dxd files and other settings of each file, such as the loop count, are

the same as in the first Configuration. In this example, we have to change the Repeat count of the graph#002.

dxd to 3. 
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7

.

We have now created 2 new PLEXUS Configurations, which we can upload to the PLEXUS  units. Please note that

each PLEXUS will receive its own configuration.

To upload the Configuration to the first PLEXUS, select the first PLEXUS  in the upper list (the name of the device

is  PLEXUS 1 in  this  example).  Then,  select  the  Configuration  which  should  be  uploaded  (the  Configuration  is

called Tutorial PLEXUS 1 in this example), and finally click the Upload button.

A confirmation window will be opened. Please click Yes.

Note: Before the upload process of the Configuration to the PLEXUS starts, all existing files on the SD card will be

deleted.  If  you  want  to  append  new  Scenes  to  an  existing  Configuration,  please  download  the  Configuration,

append the desired *.dxd files, and then upload the updated Configuration again.
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You can see the upload status at the lower left. 

MADRIX will inform you when the upload process has been completed. 
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8

.

Repeat step 7. But now select the second PLEXUS and the corresponding Configuration for this device.  

Congratulations! You have learned how you can copy stand-alone files to MADRIX PLEXUS.
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5.1.3 MADRIX PLEXUS Master-Slave Synchronization

This tutorial shows the steps to configure two or more MADRIX PLEXUS units for Stand-Alone Mode and Master-Slave

Synchronization with the help of the MADRIX software.

The Master-Slave Synchronization function is used when you want to control more than 2 DMX universes with MADRIX

PLEXUS  units in  Stand-Alone  Mode.  If  you  want  to  create  a  stand-alone  show  with  output  of  more  than  two  DMX

universes, you will need to use several MADRIX PLEXUS. To synchronize all units, the Master-Slave function will help

you. To create stand-alone effects for the PLEXUS, please follow the following tutorials:  »Record  PLEXUS  Standalone

Files and »Copy Standalone Files to PLEXUS.

Date: 10/2014

MADRIX Version: 3.3 (Created with)

PLEXUS Firmware Version: 1.8.5168 (Created with)

1. Start  MADRIX  and  connect  MADRIX  PLEXUS  via  USB  or  Ethernet  to  the  computer  that  runs  the  MADRIX

software.

Please note: If you want to use the Ethernet network connection, make sure that the PLEXUS  is connected to

power via USB or the provided power supply.
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2. In MADRIX, go to Tools > PLEXUS Configuration...

3. The PLEXUS Configuration window opens. You will find all connected PLEXUS  devices in the upper section of

the PLEXUS Configuration window. In this example, two MADRIX PLEXUS are connected via USB.



[Part E] Hardware

//478www.madrix.com

MADRIX 3 Tutorials Version 1.9

4. We will now configure the first PLEXUS unit as Master for the synchronization. Please select the first PLEXUS,

perform a double-click on the Off  label of the Sync column, and select Master in the pop-up menu.

 

5. In  this  step,  we  want  to  configure  the  second  PLEXUS  as  Slave  for  the  synchronization.  Please  select  the

second PLEXUS, perform a double-click on the Off  label of the Sync column, and select Slave.
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6. The two devices are now configured to act as Master and as Slave interface,  respectively.  The  Master-Slave

Synchronization will keep all Scenes  and  effects  in  sync.  Even  though  you  are  controlling  more  than  2  DMX

universes with several PLEXUS  units, Scenes will be triggered at the same time and visuals will be shown as

one, coherent image on the LED installation. 

Please note: If you want to use the synchronization for two or more PLEXUS  units in Stand-Alone Mode, it is

necessary that all PLEXUS devices are connected via Ethernet to one network.

Congratulations!  You have successfully set up several MADRIX PLEXUS  devices for synchronization  in  Stand-Alone

Mode.
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5.1.4 Creating A Time-Triggered PLEXUS Configuration

In this tutorial, you will learn how to create a time-controlled stand-alone show for MADRIX PLEXUS. Such Timers are

important when you want to trigger Scenes at a certain date and time.

Date: 12/2014

MADRIX Version: 3.3 (Created with)

Note:  Before reading this tutorial, it is recommended to read the tutorials »Recording MADRIX PLEXUS  Stand-Alone

Files and »Copying Stand-Alone Files To MADRIX PLEXUS.

1. Please start MADRIX and open the PLEXUS Configuration window (go to Tools > PLEXUS Configuration...). 

When you have created PLEXUS Configurations before, the lower half of this window should look like shown in

the image. In this example, we use the Configuration of the tutorials mentioned above.
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2. Please select a PLEXUS  Configuration on the left side and switch to the Timers tab  in  the  lower  right  of  the

PLEXUS Configuration window. The list will be empty.
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3. We will add the first Timer in this step. Click on the + button on the left-hand side of the Timers list.

A new Timer with the default settings will be added. 

The default settings are:

Action: Scene

Value: 1 (That means the first scene will be triggered and activated.)

Type: Daily (The trigger will be activated every day.)

Time Type: Time (This means it will be triggered on a specific time.)

Start: 20:00:00 (This is the time when the Timer will be started.)

In this example, we want to play back the recorded Scene 1 every day at 8 o'clock a.m.

You can change the settings with the help of a double-click with the left mouse button on the desired column.

We want to change Start to 08:00:00
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Please change the time to 08:00:00 (or  08:00:00 AM)  and  confirm  with  OK.  You  can  see  how  it  has  been

changed in the list.
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5. In this step, we want to add a Timer that will activate the third Scene on every Sunday.

Click the + button again. Choose a value of 3 by performing a double-click with the left mouse button on the

Value column.

Change the Type to Weekly.
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Double-click on the list entry for Start. A new window opens. Change  the  Day  to  Sunday  and  the  Time  to

15:30:00 (or 3:30:00 PM). Click OK.

6. Finally, when we have a look at the  created  Timer,  we  can  see  that  we  created  a  Timer  which  will  trigger

Scene 3 every Sunday at 15:30:00.

Congratulations! You have learned how to create Timers for the MADRIX PLEXUS. 
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5.1.5 Configuring MADRIX PLEXUS Using The MADRIX Software

In this tutorial, you will learn how you can  configure  a  MADRIX  PLEXUS  with  the  help  of  the  PLEXUS  Configuration

window of the MADRIX software.

Date: 10/2014

MADRIX Version: 3.3 (Created with)

PLEXUS Firmware Version: 1.8.5168 (Created with)

1. Start  MADRIX  and  connect  MADRIX  PLEXUS  via  USB  or  Ethernet  to  the  computer  that  runs  the  MADRIX

software.

Please note: If you want to use the Ethernet network connection, make sure that the PLEXUS  is connected to

power via USB or the provided power supply.

2. In MADRIX, go to the menu Tools > PLEXUS Configuration...
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3. The PLEXUS Configuration window opens. In the upper list, you will find the connected PLEXUS devices and you

can change all the settings of a PLEXUS. 



[Part E] Hardware

//488www.madrix.com

MADRIX 3 Tutorials Version 1.9

4. First, we want to change the name of the PLEXUS. Select the  PLEXUS  in  the  list  and  perform  a  double-click

with the left mouse button on the name of this PLEXUS. The Name will now be editable.

 

Enter any name. In this example, we are changing the name from MADRIX PLEXUS to PLEXUS 1.
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5. In this step, we will change the values for Brightness Dimmed and Dim  After. Select the PLEXUS  in the list

again and scroll sideways to the right until you can see the columns Brightness Dimmed and Dim After.

In this example, we are changing using a left mouse button double-click:

1 Brightness Dimmed to 0 %

2 Dim After to 10 s
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Congratulations! You have successfully changed the first settings. Change any other settings as required.

5.1.6 Changing The MADRIX PLEXUS Network Address

This tutorial shows how you change the network address of a MADRIX PLEXUS on the device itself. 

As an example, we will now change the network address of one device from 10.16.1.123 to 2.0.0.123.

Date: 10/2014

PLEXUS Firmware Version: 1.8.5168 (Created with)

1. Please connect MADRIX PLEXUS to power.
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2. After the startup of the device, you can see the Status screen of the PLEXUS.
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3. Please press the OK key on your MADRIX PLEXUS device.

The menu will appear and you can navigate with the help of the arrow keys. Please press the right arrow key

two times.
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4. You will reach the Network menu. Now, press the down key two times. The submenu IP Address  should be

selected. Press OK.
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5. You can now see the IP Address Settings of the MADRIX PLEXUS.
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6. To change these settings, press the OK key for 3 seconds. As a result, you will enter the  edit  mode  and  the

first number of the IP address will be highlighted in white.
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7. We can now change the IP address of the PLEXUS. 

Use the up and down keys to switch columns (octets). Use the left and right keys to change the values. If you

are done changing the settings, press the OK key and the settings will be saved.  

Note: In this example, we want to change the IP address to 2.0.0.123. We will not change the settings for the

subnet mask (Mask) and gateway (Gate). 

Congratulations! You have changed the network address of the MADRIX PLEXUS.
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5.1.7 Changing MADRIX PLEXUS Display Settings

In this tutorial, you will learn how you can change the different display settings of MADRIX PLEXUS  ('Brightness On',

'Dim After', and 'Display Rotation').

Date: 10/2014

PLEXUS Firmware Version: 1.8.5168 (Created with)

1. Please connect MADRIX PLEXUS to power.

2. Press OK to open the menu and navigate with the arrow keys on the PLEXUS  to Settings > Display. Press

OK to enter the submenu.

A display settings overview will be provided.
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3. Press  the  OK key for  3  seconds.  You  will  enter  the  edit  mode  and  the  value  for  Brightness  On  will  be

highlighted in white.

Use the left and right arrow keys to change the value of Brightness On. In this example, we want to change

the value to 50%. Please press and hold the left arrow key to decrease the value to 50%. You should still be

in edit mode. 

 

4. Now, we want to change the time for Dim  After to 10 seconds. Press the down arrow key 2 times to select

the value for Dim After. It should be highlighted in white. Press the left arrow key again to decrease the time

to 10 s.

Please press OK to leave edit mode.
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5. Press the OK key again to open the menu and navigate to Device.

Please press OK again to enter the submenu and you will see the Device settings.

6. Press OK for 3 seconds, then navigate to Rotate 180°, and press the left key (or right) to rotate the display.

Press OK and the settings will be saved.

Note:  If you change the display rotation, the  key mapping  will  be  rotated,  too.  That  means  the  up  key will

switch to be the down key, the left key will switch to be the right key, and so on.

Congratulations! You have changed various display settings of MADRIX PLEXUS.
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5.1.8 MADRIX PLEXUS Remote Control

In this tutorial, you will learn how you can control MADRIX PLEXUS remotely in Stand-Alone Mode using DMX-IN.

Date: 10/2014

PLEXUS Firmware Version: 1.8.5168 (Created with)

1. Please connect MADRIX PLEXUS to power.

2. Press OK and navigate to the menu Remote Control > Remote Options

Open the Remote Options submenu by pressing the OK key.
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3. In this example, we want to change the value for Receive Via to DMX and the value for On Port to DMX 2.

Now, press the OK key for  3  seconds  to  enter  edit  mode.  The  value  for  Receive  Via  will  be  highlighted  in

white.

You can change a value with help of the left and right arrow keys. After changing the value for Receive  Via,

please press the down key once and change the  value  for  On  Port by  using  the  left and  right arrow  keys

again. After setting these values, confirm the current settings by pressing the OK key. 

 

4. In this step, we want to test if the PLEXUS receives DMX data on DMX 2. 

Please connect a console or any other DMX sender to the XLR port DMX 2. (Maybe it is necessary to use a 5-

pin gender changer.)

In the PLEXUS menu, navigate to Remote Control > Monitor Remote and press the OK key.
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5. Now, you will see the Monitor Remote screen. If all the settings are correct and if you have connected a DMX

sender to DMX 2, you will see the DMX input values on DMX 2.

Please Note: You can find an overview over all remote commands of MADRIX PLEXUS here: »Remote Commands

Congratulations! Now, you can control MADRIX PLEXUS remotely.

5.1.9 MADRIX PLEXUS Test Sending

This tutorial shows you how you can use MADRIX PLEXUS to send DMX data for testing.

Date: 10/2014

PLEXUS Firmware Version: 1.8.5168 (Created with)

1. Please connect MADRIX PLEXUS to power.

http://help.madrix.com/m3/html/plexus/index.html?hidd_remote_control.html
http://help.madrix.com/m3/html/plexus/index.html?hidd_remote_control.html
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2. Press OK and navigate to Tools  > Test Sending.

Open the Test Sending submenu by pressing the OK key.

3. We are now able to use the Test Sending functionality of the PLEXUS. With the current settings, the PLEXUS

will send DMX data on XLR port DMX 1.

In this example, we want to send DMX data on  DMX  channel  4  with  a  value  of  255.  Therefore,  we  have  to

change the channel number with the left and right key to 4 and we are changing the value of this channel with

the up and down keys to 255.

The PLEXUS is now sending the maximum DMX value on channel 4 using the DMX output port 1. You can check

this when you connect a fixture to DMX 1 of the PLEXUS. For instance, use a simple  RGB fixture  and  set  the

start address of the fixture to 4. The fixture will light up in red.
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4. The Test Sending function also provides other options, which we are going to use now. 

Press the OK key for 3 seconds and the PLEXUS will switch to the Test Sending options screen.

 

5. In this step, we want to change the settings for the Test Sending.

Change values with the left and right keys. If you want to change another option of this page, use the up and

down keys to select it and when the desired option is highlighted in white, you can change the value.

Send Via You can change the setting between DMX and Art-Net. In this  example,  we  want  to

use DMX.

Send On Port When DMX is selected, you can change between DMX 1 and DMX 2. When you have

chosen Art-Net, it switches to Send On Universe and you can change the value to a

desired universe between 1 and 256. In this example, we want to use DMX 2.

Show Values As It is possible to change the view of the  DMX  value  between  Percent,  Hexadecimal,

and Decimal. In this example we want to use Percent.

Test Mode This option provides possibility to set the test sending only to:

Channel - The output will be sent only to one channel of the DMX universe.  

Universe  -  Allows  you  to  set  different  values  for  different  channels  of  the  DMX

universe.

All Channels - All channels of the DMX universe will be set to the same output value.

In this example, we want to use Universe.
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6. Please confirm the settings with the OK key. Now, you can see  that  the  PLEXUS  will  send  the  DMX  data  via

DMX 2 and the DMX value will be displayed in percent.

Congratulations! You have learned how you can use MADRIX PLEXUS for DMX test sending.
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5.1.10 Testing DMX Input And DMX Output

In this tutorial, you will learn how you can use the MADRIX PLEXUS as a DMX testing tool for input and output data.

Sometimes it is necessary to test DMX lines with and without fixtures inbetween. You might need to find an issue in

the line. To do so, you can use a special DMX testing device or you can use the integrated DMX testing tool of MADRIX

PLEXUS. The PLEXUS provides the possibility to monitor incoming data or outgoing data of its two DMX ports.

Date: 10/2014

PLEXUS Firmware Version: 1.8.5168 (Created with)

1. Please connect MADRIX PLEXUS to power.

2. The menu Information > Status on the PLEXUs already provides useful information. 

4 status symbols shown at  the  bottom  indicate  the  status  of  the  4  ports  at  the  bottom  of  MADRIX  PLEXUS,

including DMX 1, DMX 2, USB/Power, and Ethernet. 

An arrow from bottom to top means that the PLEXUS receives data on this port.

An arrow from top to bottom means the PLEXUS sends data to the port.

A line means that the PLEXUS neither sends nor receives data on the port.

An X means that there is currently no connection available at this port.

In this example, the PLEXUS has the following status:

1 MADRIX PLEXUS receives DMX data on DMX 1.
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2 MADRIX PLEXUS sends DMX data on DMX 2.

3 MADRIX PLEXUS receives data via USB.

4 MADRIX PLEXUS neither receives nor sends data via Ethernet.

3. Now, please navigate to Tools > Monitor DMX 1 and open the monitor by pressing the OK key.

4. In the DMX Monitor of the PLEXUS, you can find the following information:

1 Shows the amount of DMX channels in the DMX universe that are currently used.

2 Shows the frame rate of the data. If the PLEXUS  receives DMX data on this port, you will see the

frame rate of incoming data.

3 Shows the current DMX value of the currently selected channel. You can change the channel with

the left and right arrow keys. In the screenshot below, channel 3 is shown with a value of 0.
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The screenshot below also graphically shows the current DMX values of the complete universe. 

 

5. You can further change how the DMX Monitor looks and shows the data to you. To change it, press the OK key

for 3 seconds. The PLEXUS will switch to the options page and you can change the following settings:

Show As  When the value for Show As is highlighted in white, you can choose between Graphic

, Table, and Channel with the left and  right arrow  keys.  In  this  example,  we  have

chosen Graphic.

Show Values As  When the value for Show Values As is highlighted in white, you can choose between

Decimal,  Hexadecimal,  and  Percent  with  the  left  and  right  arrow  keys.  In  this

example, we have chosen Decimal.

Congratulations! You have learned to use the DMX Monitor function of MADRIX PLEXUS.
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5.1.11 MADRIX PLEXUS Art-Net Configuration

The different Art-Net settings of MADRIX PLEXUS are explained in this tutorial.

Date: 10/2014

PLEXUS Firmware Version: 1.7.4369 (Created with)

1. Please connect MADRIX PLEXUS to power.

2. Navigate to Network > Art-Net and open the Art-Net submenu by pressing the OK key.

3. In the Art-Net submenu, you will find two sections:

1 Art-Net -> DMX 1 and Art-Net -> DMX 2:  Use this option to change the assignment of Art-Net

universes to the DMX 1 and DMX 2 output ports. For instance, you can set that DMX 1 outputs data

from Art-Net universe 3.

2 DMX 1 -> Art-Net and DMX 2 -> Art-Net:  Use this option to change the assignment of DMX data

to a desired Art-Net universe. With this option, you can use the PLEXUS as Art-Net sender.
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4. Let us now change the Art-Net assignment of output DMX 1 and output DMX 2.

Please press the OK key for 3 seconds and the value for Universe for DMX 1 will be highlighted in white. You

are able to change the Art-Net universe assignment by using the left and right keys. Use the up and down

keys to select which option you want to change. In this example, we want to change port DMX 1 to Universe 3

and port DMX 2 to Universe 4. Please  confirm the new settings with OK.

The Art-Net universe assignment has now been changed. That means if  an  lighting  console  or  other  Art-Net

sender sends Art-Net data to Art-Net universe 3, this data will be put out on DMX 1. If the console sends Art-

Net data to Art-Net universe 4, the PLEXUS will send it on DMX 2.

Note: If you want to use the PLEXUS as Art-Net sender, please set Art-Net -> DMX 1  and Art-Net ->  DMX 2  to

OFF.

Congratulations! You have finished the MADRIX PLEXUS Art-Net configuration tutorial.
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6 Imprint And Copyright
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Under no circumstances does inoage GmbH take on the responsibility for liabilities for faults for losses in sales volume
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ASIO is a trademark and software of Steinberg Media Technologies GmbH.

Intel is a trademark of Intel Corporation in the U.S. and/or other countries.

NVIDIA is a trademark and/or registered trademark of NVIDIA Corporation in the U.S. and/or other countries.

Other product and company names, terms, or [trade] marks are the property of their respective holders.
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Index

- 3 -

3D        173, 178

3rd-Party        155, 405, 411, 420

- A -

Art-Net        89, 94, 102, 114, 510

- C -

Chaser        284, 292, 297

CITP        114

Cue List        368

- D -

DMX512        18, 149, 341, 345, 355, 434, 436, 440, 507

DMX-IN        110, 501

DVI        49, 155, 161, 166, 405, 411

- E -

E1.31        420

Export        305, 312, 318

- F -

Fixture Editor        60, 71

Fixture Groups        379, 388, 391

Full Screen        161

- H -

Hardware        10

HTTP        361

- I -

Images        230

Import        305, 312, 318

Installation        6

- L -

Layers        187, 194, 201, 212, 237, 258, 272, 278

- M -

MADRIX PLEXUS        444, 463, 476, 480, 486, 490, 498, 501,
503, 507, 510

Mapping        250, 258, 272, 278

Merging        355

MIDI        126, 130, 137

Movie        218

- P -

Patch        23, 28, 41, 87, 173, 178

Pictures        230

- R -

RGB        430

- S -

S2L        187, 272

sACN        420

Streaming ACN        420

- T -

T9        155, 411

Touch        327

- V -

Video        218

- W -

Web        361
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