The Script/Macro Editor

   Print  Previous  Next

Introduction

The Script/Macro Editor is the tool to control and manage macros and scripts.

Script Editor Screenshot

 

Menu - Includes several submenus to perform various actions of the Script/Macro Editor.
Toolbar - Includes various shortcuts to quickly execute the most common actions, such as Save, Load, or Compile.
Text Field - The text field to enter source code and functions takes up the largest part of the Script/Macro Editor.
Script Output - Provides a display to put out messages from the script itself.
- Go to Edit > Clear Script Output or Edit > Clear Script Output / Compiler Messages  to delete messages that are not needed anymore.
Compiler Messages - Provides information of the Script/Macro Editor and displays errors or other messages.
- Go to Edit > Clear Compiler Messages or Edit > Clear Script Output / Compiler Messages to delete messages that are not needed anymore.

 

Overview

Creating, Loading, and Saving Scripts

Go to File > New to create a new template, which is the basis of a new script or macro. Or use the toolbar shortcut.
Go to File > Open... to load an existing script or macro from an external file. Or use the toolbar shortcut.
Go to File > Save or File > Save As... to store a script or macro on your harddisk or any other storage medium. Or use the toolbar shortcut.
Go to File > Close to close the Script/Macro Editor. Or use the window shortcut.

 

Compiling and Executing Scripts

Before a script or macro can run, it needs to be compiled. While compiling the script, it is analyzed and translated into the format MADRIX understands internally.

Go to Script > Compile to compile the current source code. Or use the toolbar shortcut. After the script was compiled successfully, it will be executed automatically. If the compilation fails, the script cannot be executed. An error message will be displayed. Just double-click on the message and the cursor will jump to the referred position. In addition, the line number is printed with each compiler message.
Go to Script > Compile And Save... to create a crypted, secured macro or script. Or use the toolbar shortcut.
Go to Script > Start Script to start a script or macro once it has been compiled and stopped again. Or use the toolbar shortcut.
Go to Script > Stop Script to halt the execution of a script. Or use the toolbar shortcut.

 

File Types

*.mas

MADRIX Script File
A script for the MAS Script Effect.

*.macs

Encrypted MADRIX Script File
A compiled and encrypted script for the MAS Script Effect.  This is a script which does not contain any source code, but only the runtime code. This means that with the help of compiled scripts it is possible to share scripts, but to let the source code remain a secret at the same time. Because a compiled script does not contain any source code, only the script's meta data will be displayed in the window when you load such a kind of file. You (or others) will not be able to edit the code.

*.mms

MADRIX Effect Macro
A Macro for an effect, a Storage Place Macro, or a Main Output Macro.

*.mcm

MADRIX Crypted Effect Macro

A compiled and encrypted Macro for an effect, a Storage Place Macro, or a Main Output Macro. This is a macro which does not contain any source code, but only the runtime code. This means that with the help of compiled macros it is possible to share macros, but to let the source code remain a secret at the same time. Because a compiled script does not contain any source code, only the script's meta data will be displayed in the window when you load such a kind of file. You (or others) will not be able to edit the code.

 

MADRIX Version: 3.6g | Script Version: 2.21
[Ctrl & +/-] = Zoom In/Out | [Ctrl & 0] = 100%
Print   Previous   Next